vlc crashed with SIGSEGV in QList()

Bug #1280889 reported by Fredrik Jacobsson on 2014-02-16
102
This bug affects 13 people
Affects Status Importance Assigned to Milestone
VLC media player
Unknown
Unknown
vlc (Ubuntu)
High
Unassigned

Bug Description

1.) Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

2.) vlc:
  Installed: 2.1.2-2build1
  Candidate: 2.1.2-2build1
  Version table:
 *** 2.1.2-2build1 0
        500 http://archive.ubuntu.com/ubuntu/ devel/universe amd64 Packages
        100 /var/lib/dpkg/status

3+4.) I were watching TV using an USB receiver (Anysee E30 Plus, DVB-T).
I added an icon to the toolbar (infobutton, I were looking for a button for Program Guide, couldn't find any)
Clicked on the Info button, closed the window that popped up and then went to the menus, crash.
During all this the TV-stream were running and i had the Program Guide window open.

That's it.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: vlc-nox 2.1.2-2build1
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu4
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Feb 16 21:56:24 2014
ExecutablePath: /usr/bin/vlc
InstallationDate: Installed on 2011-02-04 (1108 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
ProcCmdline: /usr/bin/vlc --started-from-file
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f3ee540dd97 <_ZNK7QWidget7actionsEv+7>: mov 0x1b8(%rdx),%rdx
 PC (0x7f3ee540dd97) ok
 source "0x1b8(%rdx)" (0x7f3e000001cb) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: vlc
StacktraceTop:
 QWidget::actions() const () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QMenu::clear() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 ?? () from /usr/lib/vlc/plugins/gui/libqt4_plugin.so
 ?? () from /usr/lib/vlc/plugins/gui/libqt4_plugin.so
 ?? () from /usr/lib/vlc/plugins/gui/libqt4_plugin.so
Title: vlc crashed with SIGSEGV in QWidget::actions()
UpgradeStatus: Upgraded to trusty on 2013-07-27 (204 days ago)
UserGroups: adm admin audio cdrom dialout fuse lpadmin plugdev pulse pulse-access sambashare video

StacktraceTop:
 QList (l=..., this=0x7f3ee889b5c0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
 QWidget::actions (this=0x7f3ed8262a90) at kernel/qwidget.cpp:3344
 QMenu::clear (this=0x7f3ed8262a90) at widgets/qmenu.cpp:1731
 VLCMenuBar::updateAudioDevice (p_intf=p_intf@entry=0xcfe488, p_aout=p_aout@entry=0xcfe208, current=0x7f3ed8262a90) at menus.cpp:1558
 VLCMenuBar::AudioMenu (p_intf=0xcfe488, current=0x7f3ed82b7ab0) at menus.cpp:619

Changed in vlc (Ubuntu):
importance: Undecided → Medium
summary: - vlc crashed with SIGSEGV in QWidget::actions()
+ vlc crashed with SIGSEGV in QList()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in vlc (Ubuntu):
importance: Medium → High
JB VideoLAN (jb-videolan) wrote :

This is fixed in VLC 2.1.3

JB VideoLAN (jb-videolan) wrote :

Fixed in 14.10

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
Changed in vlc:
milestone: none → 2.1.5
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.