VLC looks for /dev/dvd which does not exist

Bug #1255824 reported by Alex Henrie on 2013-11-28
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Undecided
Rémi Denis-Courmont
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce, open VLC, click Media, and click Open Disc. By default VLC selects /dev/dvd, but this does not exist at all. You have to type in /dev/sr0 to play the DVD. I wasted a lot of time trying to figure out why this wasn't working.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: vlc 2.0.8-1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Wed Nov 27 21:29:03 2013
InstallationDate: Installed on 2013-11-28 (0 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
SourcePackage: vlc
UpgradeStatus: No upgrade log present (probably fresh install)

Alex Henrie (alexhenrie24) wrote :
Benjamin Drung (bdrung) wrote :

This is not a VLC bug. There should be a udev rule that creates the /dev/dvd symlink to the drive when inserting a DVD.

I can reproduce the problem by inserting a DVD:

$ udevadm info /dev/sr0
P: /devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sr0
N: sr0
L: -100
S: cdrom
S: disk/by-id/ata-HL-DT-ST_BDDVDRW_CH10LS20_K9VA5JL2620
S: disk/by-label/THE_BOURNE_SUPREMACY
E: DEVLINKS=/dev/cdrom /dev/disk/by-id/ata-HL-DT-ST_BDDVDRW_CH10LS20_K9VA5JL2620 /dev/disk/by-label/THE_BOURNE_SUPREMACY
E: DEVNAME=/dev/sr0
E: DEVPATH=/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sr0
E: DEVTYPE=disk
E: ID_ATA=1
E: ID_ATA_FEATURE_SET_PM=1
E: ID_ATA_FEATURE_SET_PM_ENABLED=0
E: ID_ATA_SATA=1
E: ID_ATA_SATA_SIGNAL_RATE_GEN1=1
E: ID_BUS=ata
E: ID_CDROM=1
E: ID_CDROM_BD=1
E: ID_CDROM_CD=1
E: ID_CDROM_CD_R=1
E: ID_CDROM_CD_RW=1
E: ID_CDROM_DVD=1
E: ID_CDROM_DVD_PLUS_R=1
E: ID_CDROM_DVD_PLUS_RW=1
E: ID_CDROM_DVD_PLUS_R_DL=1
E: ID_CDROM_DVD_R=1
E: ID_CDROM_DVD_RAM=1
E: ID_CDROM_DVD_RW=1
E: ID_CDROM_MEDIA=1
E: ID_CDROM_MEDIA_DVD=1
E: ID_CDROM_MEDIA_SESSION_COUNT=1
E: ID_CDROM_MEDIA_STATE=complete
E: ID_CDROM_MEDIA_TRACK_COUNT=1
E: ID_CDROM_MEDIA_TRACK_COUNT_DATA=1
E: ID_CDROM_MRW=1
E: ID_CDROM_MRW_W=1
E: ID_FS_LABEL=THE_BOURNE_SUPREMACY
E: ID_FS_LABEL_ENC=THE_BOURNE_SUPREMACY
E: ID_FS_TYPE=udf
E: ID_FS_USAGE=filesystem
E: ID_MODEL=HL-DT-ST_BDDVDRW_CH10LS20
E: ID_MODEL_ENC=HL-DT-ST\x20BDDVDRW\x20CH10LS20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20
E: ID_REVISION=1.01
E: ID_SERIAL=HL-DT-ST_BDDVDRW_CH10LS20_K9VA5JL2620
E: ID_SERIAL_SHORT=K9VA5JL2620
E: ID_TYPE=cd
E: MAJOR=11
E: MINOR=0
E: SUBSYSTEM=block
E: TAGS=:seat:uaccess:
E: UDISKS_PRESENTATION_NOPOLICY=0
E: USEC_INITIALIZED=83774

Benjamin Drung (bdrung) on 2013-11-30
affects: vlc (Ubuntu) → systemd (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Upstream udev has dropped the old /dev/cdrom and /dev/dvd aliases ages ago. We kept it around in Ubuntu for a little longer, but at some point video players have to enter this century and stop relying on hardcoded device names. It should detect all available CD/DVD drives and their capabilities using sysfs or libudev.

affects: systemd (Ubuntu) → vlc (Ubuntu)
Benjamin Drung (bdrung) wrote :

Good to know. Do you have some pointers to how the usual way to probe for DVD drives look like?

Rémi Denis-Courmont (rdenis) wrote :

That's already implemented in the Disc category of the playlist. Unfortunately, in my experience, detecting discs that get inserted while the software is already running is a bit flaky with udev.

Mantas Kriaučiūnas (mantas) wrote :

Could you test if your problem with VLC is not fixed in latest upstream version (2.1.1)?
You can install VLC 2.1.1 from ppa:dirk-computer42/c42-backport

See https://launchpad.net/~dirk-computer42/+archive/c42-backport for more info about installing.

codeslinger (codeslinger) wrote :

I didn't have this problem in 12.05... so, /dev/dvd is considered obsolete??? and is now removed?!?!? Well, somebody forgot to tell that to all the app developers.

In BETA 14.04 the following are broken due to this *feature*
xine, gxine, (totem) Videos
I didn't test VLC but this bug was orignally entered for vlc.

So, Basically any and every video player in existance is broken by the remove of /dev/dvd

is that really such a good idea??? especially since xine sucks at trying to manually select a disk.

I can get the players to work by creating a symlink to /dev/cdrom, which itself appears to be a link to /dev/sr0
but every time that I reboot the computer I have to recreate the symlink. This is a major headache and 80% of end users will not figure this out, instead they will conclude that Ubuntu won't play DVD's and they should use windows instead.

This should be a death by 1000 cuts item....

Why would anyone ever think that removeing /dev/dvd and breaking all of the video players in existance was actually a good idea?!?!?!?

codeslinger (codeslinger) wrote :

related/dup bugs

bug #1084855 udev is creating symlinks for optical drives incorrectly
bug #1098323 Parole failes to play DVD
bug #237874 kaffeine refers to "/dev/dvd
bug #1248194 Gnome-Mplayer cannot play commercial videos: Couldn't open DVD device: /dev/dvd
bug #1295561 /dev/dvd doesn't exist

affected apps: Gnome-Mplayer, kaffeine, xine, gxine, (totem) Videos, vlc ...
they all expect /dev/dvd and are broken without it.

How can you say that udev should not support /dev/dvd unless you intend to also at the same time coordinate the modification of every single video player program -- all of them -- at the same time. Otherwise all you are delivering is *MAJOR* Breakage of Ubuntu.

This affects all flavors of ubuntu...

I found this in the 14.04 BETA, but apparently it's been broken since 13.04 (which I never ran due to other bugs), it works fine in 12.04 which has the /dev/dvd.

Pierre (pierrewinnipeg) wrote :

I fully agree with codeslinger.

This is a MAJOR BUG. It should have been solved in 13.04.

Changed in vlc:
milestone: none → 2.2.0
assignee: nobody → Rémi Denis-Courmont (rdenis)
assignee: Rémi Denis-Courmont (rdenis) → nobody
status: New → Fix Released
assignee: nobody → Rémi Denis-Courmont (rdenis)
Changed in vlc (Ubuntu):
status: Confirmed → Fix Committed
JB VideoLAN (jb-videolan) wrote :

2.2.0-pre2 is in Utopic

Changed in vlc (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers