vlc has unmet dependencies

Bug #1196 reported by Jeroen
6
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Medium
Unassigned

Bug Description

jeroen@breezy:~$ sudo -i
root@breezy:~ # apt-get update
Get:1 http://nl.archive.ubuntu.com breezy Release.gpg [189B]
Get:2 http://nl.archive.ubuntu.com breezy-updates Release.gpg [189B]
Get:3 http://nl.archive.ubuntu.com breezy-security Release.gpg [189B]
Hit http://nl.archive.ubuntu.com breezy Release
Hit http://nl.ar...

jeroen@breezy:~$ sudo -i
root@breezy:~ # apt-get update
Get:1 http://nl.archive.ubuntu.com breezy Release.gpg [189B]
Get:2 http://nl.archive.ubuntu.com breezy-updates Release.gpg [189B]
Get:3 http://nl.archive.ubuntu.com breezy-security Release.gpg [189B]
Hit http://nl.archive.ubuntu.com breezy Release
Hit http://nl.archive.ubuntu.com breezy-updates Release
Hit http://nl.archive.ubuntu.com breezy-security Release
Hit http://nl.archive.ubuntu.com breezy/main Packages
Hit http://nl.archive.ubuntu.com breezy/universe Packages
Hit http://nl.archive.ubuntu.com breezy/main Sources
Hit http://nl.archive.ubuntu.com breezy/universe Sources
Hit http://nl.archive.ubuntu.com breezy-updates/main Packages
Hit http://nl.archive.ubuntu.com breezy-updates/universe Packages
Hit http://nl.archive.ubuntu.com breezy-updates/main Sources
Hit http://nl.archive.ubuntu.com breezy-updates/universe Sources
Hit http://nl.archive.ubuntu.com breezy-security/main Packages
Hit http://nl.archive.ubuntu.com breezy-security/universe Packages
Hit http://nl.archive.ubuntu.com breezy-security/main Sources
Hit http://nl.archive.ubuntu.com breezy-security/universe Sources
Fetched 3B in 0s (10B/s)
Reading package lists... Done
root@breezy:~ # apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@breezy:~ # apt-get install vlc
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  vlc: Depends: dbus-1 (>= 0.23.4) but it is not installable
       Depends: libflac6 but it is not installable
       Depends: libhal0 (>= 0.4.0) but it is not installable
       Depends: libmodplug0 (>= 1:0.7-1) but it is not installable
       Depends: xlibmesa-glu but it is not going to be installed or
                libglu1
       Depends: wxvlc but it is not going to be installed
E: Broken packages
root@breezy:~ # apt-get install dbus-1
Reading package lists... Done
Building dependency tree... Done
Package dbus-1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libdbus-1-1 dbus-1-utils dbus
E: Package dbus-1 has no installation candidate
root@breezy:~ # apt-get install libflac6
Reading package lists... Done
Building dependency tree... Done
Package libflac6 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libflac6 has no installation candidate
root@breezy:~ # apt-get install libhal0
Reading package lists... Done
Building dependency tree... Done
Package libhal0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libhal0 has no installation candidate
root@breezy:~ # apt-get install libhal
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package libhal
root@breezy:~ # apt-get install hal
Reading package lists... Done
Building dependency tree... Done
hal is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@breezy:~ # apt-get install libmodplug0
Reading package lists... Done
Building dependency tree... Done
Package libmodplug0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libmodplug0c2
E: Package libmodplug0 has no installation candidate
root@breezy:~ # apt-get install xlibmesa-glu
Reading package lists... Done
Building dependency tree... Done
The following packages will be REMOVED:
  audacity bum freeglut3 gdm gksu gnome-netstatus-applet gnome-system-monitor
  gnome-system-tools gnome-volume-manager hwdb-client libgksu1.2-0
  libgksuui1.0-0 libgle3 libglu1-xorg libglut3 libwxgtk2.4c2 python-opengl
  python2.4-opengl rss-glx ubuntu-desktop x-window-system-core xbase-clients
  xscreensaver-gl
The following NEW packages will be installed:
  xlibmesa-glu
0 upgraded, 1 newly installed, 23 to remove and 0 not upgraded.
Need to get 366kB of archives.
After unpacking 60.3MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
root@breezy:~ # apt-get install libglu1
Reading package lists... Done
Building dependency tree... Done
Note, selecting xlibmesa-glu instead of libglu1
The following packages will be REMOVED:
  audacity bum freeglut3 gdm gksu gnome-netstatus-applet gnome-system-monitor
  gnome-system-tools gnome-volume-manager hwdb-client libgksu1.2-0
  libgksuui1.0-0 libgle3 libglu1-xorg libglut3 libwxgtk2.4c2 python-opengl
  python2.4-opengl rss-glx ubuntu-desktop x-window-system-core xbase-clients
  xscreensaver-gl
The following NEW packages will be installed:
  xlibmesa-glu
0 upgraded, 1 newly installed, 23 to remove and 0 not upgraded.
Need to get 366kB of archives.
After unpacking 60.3MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
root@breezy:~ # apt-get install wxvlc
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  wxvlc: Depends: vlc (= 0.8.1-1ubuntu7) but it is not going to be installed
         Depends: libwxgtk2.5.3 (>= 2.5.3.2ubuntu3) but it is not installable
E: Broken packages
root@breezy:~ #

Jeroen (jeroenubuntu)
Changed in vlc:
status: New → Fixed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers