vlc-nox depends on missing libpostproc0d

Bug #119016 reported by Luca Falavigna on 2007-06-06
8
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Medium
Emmet Hikory

Bug Description

Binary package hint: vlc

vlc-nox can not be installed in Gutsy since it depends on libpostproc0d, which is no longer present.
It should use libpostproc1d, instead.

Changed in vlc:
assignee: nobody → dktrkranz
status: Unconfirmed → In Progress
Luca Falavigna (dktrkranz) wrote :

Attached debdiff should fix this.
b/i/r on up-to-date Gutsy box.

Changed in vlc:
assignee: dktrkranz → nobody
status: In Progress → Confirmed

The changes you requested are not needed. Just a rebuild is necessary. Could you prepare a debdiff for that?
Thanks for contributing.

Luca Falavigna (dktrkranz) wrote :

Thank you for the hint.

Emmet Hikory (persia) on 2007-06-09
Changed in vlc:
importance: Undecided → Medium
Emmet Hikory (persia) on 2007-06-10
Changed in vlc:
assignee: nobody → persia
status: Confirmed → In Progress
Emmet Hikory (persia) wrote :

Thanks for the updated debdiff. This doesn't build for me with gutsy today. At first glance, it looks like an issue with the libflac7 -> libfla8 transition (which would also be solved by this upload). Could you please take a look at this transition as well for vlc? Thank you.

Changed in vlc:
assignee: persia → dktrkranz
status: In Progress → Needs Info
Matti Lindell (mlind) wrote :

Hiya, here's a patch extracted from upstream trunk I'm using to build vlc with newer libflac8.

The original upstream bug: http://trac.videolan.org/vlc/ticket/921
The upstream patch: http://trac.videolan.org/vlc/changeset/18855?format=diff&new=18855

I'll attach a debdiff for the libflac transition part.

Emmet Hikory (persia) on 2007-06-12
Changed in vlc:
assignee: dktrkranz → persia
status: Needs Info → In Progress
Emmet Hikory (persia) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 10 Jun 2007 17:06:18 +0300
Source: vlc
Binary: wxvlc vlc-plugin-sdl vlc-plugin-ggi vlc-plugin-alsa vlc-plugin-glide vlc
-plugin-esd mozilla-plugin-vlc vlc libvlc0 vlc-plugin-arts vlc-nox vlc-plugin-sv
galib libvlc0-dev
Architecture: source
Version: 0.8.6.release-0ubuntu5
Distribution: gutsy
Urgency: low
Maintainer: Ubuntu MOTU Developers <email address hidden>
Changed-By: Matti Lindell <email address hidden>
Description:
 libvlc0 - multimedia player and streamer library
 libvlc0-dev - development files for VLC
 mozilla-plugin-vlc - multimedia plugin for web browsers based on VLC
 vlc - multimedia player and streamer
 vlc-nox - multimedia player and streamer (without X support)
 vlc-plugin-alsa - dummy transitional package
 vlc-plugin-arts - aRts audio output plugin for VLC
 vlc-plugin-esd - Esound audio output plugin for VLC
 vlc-plugin-ggi - GGI video output plugin for VLC
 vlc-plugin-glide - Glide video output plugin for VLC
 vlc-plugin-sdl - SDL video and audio output plugin for VLC
 vlc-plugin-svgalib - SVGAlib video output plugin for VLC
 wxvlc - dummy transitional package
Changes:
 vlc (0.8.6.release-0ubuntu5) gutsy; urgency=low
 .
   * debian/patches/020_flac.diff:
    - Patch from upstream trunk to fix FTBFS with libflac8
      (http://trac.videolan.org/vlc/changeset/18855)
Files:
 c034e6a2a90d37c33f4126f9ba3cdbe8 2147 graphics optional vlc_0.8.6.release-0ubun
tu5.dsc
 04b26cd9719bc5421cec28d1c4267411 35513 graphics optional vlc_0.8.6.release-0ubu
ntu5.diff.gz
Original-Maintainer: Sam Hocevar (Debian packages) <email address hidden>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGbyni58vd3QD9QFcRAqIyAKDJAXYFpxYznB01TQxrF33eMEdcdQCgjgue
ZTRASTJUa7v+AuiDcZJMHOE=
=xyWC
-----END PGP SIGNATURE-----

Changed in vlc:
status: In Progress → Fix Committed
Matti Lindell (mlind) wrote :

Thanks, build failed on sparc though. For some reason configure didn't find libnotify even though the package seemed to install okay. Dunno what's wrong with it.

Matti Lindell (mlind) wrote :

This is probably caused by bug #120241. New gtk+2.0 was just released before sparc version was built.

Luca Falavigna (dktrkranz) wrote :

It has been compiled for sparc too.
See here for further details: https://launchpad.net/+builds/+build/347931.

Changed in vlc:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers