VLC 2.0.5 won't work with Opus. Please include libopus0 from n-muench PPA

Bug #1099003 reported by Teg on 2013-01-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Recently VLC for Precise has been updated to 2.0.5, which is the latest version available. One of the big draws of VLC 2.0.4 and above was the inclusion of Opus audio support, yet the libraries to play them are not available in the Precise repositories. Opening any Opus file gives an error that there is no suitable decoder. Currently the Opus package (libopus0) is only in Quantal and above.

The 2.0.5 version of VLC seems to be based off of the PPA at https://launchpad.net/~n-muench/+archive/vlc which includes libopus0 backported for Precise. I have used 2.0.4 from this PPA in the past and Opus files and audio streams worked perfectly.

Another issue I have is when I updated to 2.0.5 from the Precise repositories with libopus0 installed from the n-muenich PPA, Opus playback no longer worked. I am guessing the 2.0.5 version built for Ubuntu doesn't take Opus into consideration when the 2.0.4 version from the n-muenich PPA did.

Since this is a big issue with this version of VLC, it is VERY important to include libopus0 in the main Precise repositories so VLC is no longer broken.

Benjamin Drung (bdrung) wrote :

The official VLC package can only use libraries that are part of the official archive. The opus library from that PPA is not available for the official VLC package on build time and therefore VLC can't be linked against the opus library.

Sadly, the official VLC package from precise won't support opus, because the opus library is not in the precise archive. Once Ubuntu is released, only bug and security fixes are allowed, but no new features. Adding a new library is considered a feature and therefore is not allowed. That's why I will mark this bug as Won't fix. You either need to use a non-official VLC build or upgrade to 12.10 or later if you want Opus support.

Changed in vlc (Ubuntu):
status: New → Won't Fix
Teg (tegskywalker) wrote :

I think that is very unfair considering that VLC advertises Opus as an included codec and the Ubuntu repository version that auto updates through apt does not include it. People will have to be forced to hold back their updates or manually select a version of VLC from a PPA. Opus works fine on Precise and that PPA is proof. On top of that, can't this be added to the precise-backports repository? That repo is there for a reason and Opus is a great candidate if you refuse to put it into the main.

What is the real harm in adding a few packages to the repository? Seriously.

How can VLC be advertised as an all-in-one media player if the Ubuntu team handicaps it intentionally? Especially if it is to be supported for 5 years and decisions like this can potentially handicap an open and patent free audio codec's adoption.

Micah Gersten (micahg) wrote :

If that functionality wasn't in the release version, then there's no guarantee it should be in any updates. However, I'd be open to backporting both opus and vlc from quantal to precise if someone would be willing to do the reverse dependency testing and commit to testing the binaries of a new backport when there's a security update.

Teg (tegskywalker) wrote :

I think including in precise-backports would be a good start in helping the adoption of this excellent and important codec for users and especially developers and AV professionals. Firefox 15 and above includes native playback of the codec and Chromium/Google Chrome will support it in an upcoming release.

It is also the audio codec in the WebRTC standard and it can't hurt having it available in backports just in case an app wants to use it. Precise is supported for 5 years and it is imperative that we don't slow down its adoption as a potential Vorbis replacement.

Heck, you could even import the packages and sources from https://launchpad.net/~opus-developers/+archive/stable into precise-backports and call it a day.

dwpbike (dwpbike) wrote :

may i add a word from a kubuntu user? this sux.

Gromobir (gromobir) wrote :

This affects me as well. I get the following error message:
"No suitable decoder module:
VLC does not support the audio or video format "Opus". Unfortunately there is no way for you to fix this."

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers