[FFE] Build udeb for vlan

Bug #530468 reported by Mathias Gug
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vlan (Ubuntu)
Wishlist
Mathias Gug

Bug Description

Binary package hint: vlan

I'd like to ask for a FFE to build a udeb version of the vlan package. The goal is to be able to configure vlans from the installer. Doing so requires the vconfig binary.

I've locally built a vlan-udeb file that has only the vconfig binary in /sbin/ and tested that it works correctly from the installer (using an early_command in the preseed to wget the udeb file and setup vlans afterwards).

The size of the vlan udeb file is 5.1 K which would be included on the isos.

Revision history for this message
Mathias Gug (mathiaz) wrote :

Here is the size of the content of the vlan-udeb:

mathiaz@mathiaz-srv:~/src/vlan$ dpkg -c ./vlan-udeb_1.9-3ubuntu1_amd64.udeb
drwxr-xr-x root/root 0 2010-03-01 22:54 ./
drwxr-xr-x root/root 0 2010-03-01 22:54 ./sbin/
-rwxr-xr-x root/root 10440 2010-03-01 22:54 ./sbin/vconfig

Revision history for this message
Mathias Gug (mathiaz) wrote :
Revision history for this message
Mathias Gug (mathiaz) wrote :

Colin did a quick review:

1. add "XB-Installer-Menu-Item: 99999" so that it's listed in anna
2. depend on whatever-modules (depending on where the kernel modules go) - see bug 530459.

Mathias Gug (mathiaz)
Changed in vlan (Ubuntu):
assignee: nobody → Mathias Gug (mathiaz)
importance: Undecided → Low
importance: Low → Wishlist
status: New → Triaged
Revision history for this message
Martin Pitt (pitti) wrote :

The new vlan-udeb looks fine, this is approved. Does that also entail changes to the installer itself to integrate support for vlans, or is this merely meant to enable "anna-install vlan" to be able to install them on a shell prompt?

Revision history for this message
Mathias Gug (mathiaz) wrote : Re: [Bug 530468] Re: [FFE] Build udeb for vlan

On Wed, Mar 03, 2010 at 05:48:43PM -0000, Martin Pitt wrote:
> Does that also entail
> changes to the installer itself to integrate support for vlans, or is
> this merely meant to enable "anna-install vlan" to be able to install
> them on a shell prompt?
>

The latter. We'll look into installer support vlan in the next release cycle.
For lucid supporting "anna-install vlan" from in the early_command script is
enough.

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlan - 1.9-3ubuntu1

---------------
vlan (1.9-3ubuntu1) lucid; urgency=low

  * debian/control, debian/vlan-udeb.install: Create vlan-udeb package to
    be able to install the vconfig command line in the installer.
    (LP: #530468)
 -- Mathias Gug <email address hidden> Mon, 01 Mar 2010 18:20:18 -0500

Changed in vlan (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers