soprano-virtuoso.log eats up hard disk space

Bug #883222 reported by Bernie Bernstein on 2011-10-28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
virtuoso-opensource (Ubuntu)

Bug Description

After noticing my home directory partition had suddenly filled up, I eventually discovered the culprit:
~/.kde/share/apps/nepomuk/repository/main/data/virtuosobackend/soprano-virtuoso.log had grown to a rather large 125GB.

The contents of this file consisted essentially of 1 line repeated over and over (and over. . .):
14:01:16 Reference to page with free remap dp = 1490, remap = 1490

I had to remove the log file and kill the virtuoso-t process that was writing it.

Frédéric Nass (nass) wrote :

We also have numbers of clients that are affected by this bug.

As mentioned here :

"It would be nice if a single error condition that doesn't appear to be
affecting the functionality of my desktop in any way didn't cause my hard drive
to fill up with nearly 900 GB of a single repeated error message. "

Hope this get resolved quickly. This deserves an urgent tag.


More of very recent reports for the same bug :

Bernie Bernstein (bernie9998) wrote :

I am having particular trouble with this bug for a number of reasons:

1-- I have attempted to disable this service in 3 different ways, and yet this bug still keeps popping up on me-- I've tried disabling the nepomuk search module from the kde services config module, then tried disabling indexing from the nepomuk file indexing controller, and finally disabling from the desktop search config module. Despite all this, nepomuk still starts up and kills all of my hard disk space.

2-- I have encrypted home directories enabled on my system, and after this issue occurs, my system becomes completely unusable. Not only can I not login from the X console, but my text console gets completely swamped with ecryptfs kernel messages, making them unusable.

This has become far more than just a mere annoyance.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtuoso-opensource (Ubuntu):
status: New → Confirmed
Tim Pederick (pederick) wrote :

Nothing yet? This seems pretty darn urgent to me. Virtuoso is eating my hard disk space, my processor time, my power, and ultimately the usability of my computer. If bug #894841 isn't directly related, then it's coincidentally happening to me as well. I've also noted that Nepomuk is constantly (i.e. after every boot) wanting to do its "initial" indexing. Related?

Workaround (maybe): I've kill -9'd virtuoso-t, stopped Nepomuk ("qdbus org.kde.NepomukServer /nepomukserver quit"), and deleted soprano-virtuoso.log (actually I nuked its directory from orbit, just to be sure). And now I've turned off Nepomuk from System Settings. I suppose only time (and/or my next reboot) will tell whether it will stay dormant until it can be fixed.

roameo (jerome-p-oconnor) wrote :

Exactly the same problem here. This is a killer as it is making my computer unusable, yet i need nepomuk's indexing for text searches all the time. Bug repeated itself on a fresh kubuntu install.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.