package sysv-rc 2.88dsf-59.2ubuntu2.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1542453 reported by Senia on 2016-02-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
virtuoso-opensource (Ubuntu)
Low
Dimitri John Ledkov
Precise
High
Unassigned
Trusty
Low
Unassigned
Vivid
Low
Unassigned
Wily
Low
Unassigned

Bug Description

[Impact]

 * An obsolete initscript conffile, from a transitional package in precise has invalid headers.

 * It is a bogus initscript that we have previously attempted to remove in lucid and failed.

 * It causes upgrade failures, when valid initscripts are required (vivid and up or some such.)

[Test Case]

 * on precise, install updated package

 * when it is setup, obsolete initscript should be removed from disk:

Setting up virtuoso-nepomuk (6.1.4+dfsg1-0ubuntu1.1) ...
Removing obsolete conffile /etc/init.d/virtuoso-nepomuk ...

 * Verify that with

# ls -latr /etc/init.d/virtuoso-nepomuk
ls: cannot access /etc/init.d/virtuoso-nepomuk: No such file or directory

[Regression Potential]

 * Changes are only done, to the otherwise empty transitional package.

[Other Info]

 * Not sure how to fix this in other releases. I guess virtuoso-minimal may wants to remove the conffile in a similar fashion in all other releases.

Error while updating 14.04 to 15.10 using do-release-upgrade

ProblemType: Package
DistroRelease: Ubuntu 15.10
Package: sysv-rc 2.88dsf-59.2ubuntu2.1
ProcVersionSignature: Ubuntu 3.13.0-77.121-generic 3.13.11-ckt32
Uname: Linux 3.13.0-77-generic i686
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: i386
Date: Fri Feb 5 22:30:32 2016
DuplicateSignature: package:sysv-rc:2.88dsf-59.2ubuntu2.1:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2010-08-07 (2008 days ago)
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.2ubuntu5.1
 apt 1.0.10.2ubuntu1
SourcePackage: sysvinit
Title: package sysv-rc 2.88dsf-59.2ubuntu2.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to wily on 2016-02-05 (0 days ago)

Senia (seniapsm) wrote :
tags: removed: need-duplicate-check
Steve Langasek (vorlon) wrote :

The error in your log is:
Setting up sysv-rc (2.88dsf-59.2ubuntu2.1) ...
info: Reordering boot system, log to /var/lib/insserv/run-20160205T2230.log
error: Something failed while migrating.

error: Unable to migrate to dependency based boot sequencing.

See http://wiki.debian.org/LSBInitScripts/DependencyBasedBoot for
more information about dependency based boot sequencing. To
reattempt the migration process run 'dpkg --configure sysv-rc'.

dpkg: error processing package sysv-rc (--configure):
 subprocess installed post-installation script returned error exit status 1

Please attach /var/lib/insserv/run-20160205T2230.log from the affected system.

Changed in sysvinit (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
status: New → Incomplete
Senia (seniapsm) wrote :

Required log is in attachment.

Looks like similar problem: https://lists.ubuntu.com/archives/ubuntu-users/2014-November/278525.html

I removed /etc/init.d/virtuoso-nepomuk
then
sudo dpkg --configure -a
sudo apt-get purge virtuoso-nepomuk
sudo apt-get install -f
sudo apt-get upgrade

For now upgrade is in progress.

Senia (seniapsm) wrote :

The system is not bootable now. Kernel panic on start.
I have no direct access to this machine. File with last ssh lines before disconnect is in attachment.

Senia (seniapsm) on 2016-02-09
Changed in sysvinit (Ubuntu):
status: Incomplete → New
Dimitri John Ledkov (xnox) wrote :

Well that package has been removed / transitioned to virtuoso-minimal in precise. I'll check if that still has broken scripts. And I guess conffile removal logic is missing.

affects: sysvinit (Ubuntu) → virtuoso-opensource (Ubuntu)
Dimitri John Ledkov (xnox) wrote :

Aha:

virtuoso-opensource (6.1.0-0ubuntu3) lucid; urgency=low

  * Remove debian/init.d file which errornously added an init script to
    virtuoso-nepomuk

Dimitri John Ledkov (xnox) wrote :

apart from that didn't really happen.

Dimitri John Ledkov (xnox) wrote :

Uploading precise SRU, which has the only clear way to fix this.
Not sure what to do about other releases, as the buggy package in question has been removed in all other releases.

description: updated
Changed in virtuoso-opensource (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
Changed in virtuoso-opensource (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Low
Changed in virtuoso-opensource (Ubuntu Vivid):
status: New → Triaged
importance: Undecided → Low
Changed in virtuoso-opensource (Ubuntu Wily):
status: New → Triaged
importance: Undecided → Low
Changed in virtuoso-opensource (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in virtuoso-opensource (Ubuntu Precise):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in virtuoso-opensource (Ubuntu Precise):
assignee: Dimitri John Ledkov (xnox) → nobody

Hello Senia, or anyone else affected,

Accepted virtuoso-opensource into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtuoso-opensource/6.1.4+dfsg1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in virtuoso-opensource (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Mathew Hodson (mathew-hodson) wrote :

Looking at https://code.launchpad.net/ubuntu/+source/virtuoso-opensource , it seems that debian/init.d has already been removed from Trusty, Vivid , and Wily, so I think we can just remove those tasks from this bug.

Changed in virtuoso-opensource (Ubuntu):
status: Triaged → Fix Released
Mathew Hodson (mathew-hodson) wrote :

I may have misunderstood. Can this bug affect Trusty systems that still have etc/init.d/virtuoso-nepomuk even though its been removed from source?

Changed in virtuoso-opensource (Ubuntu):
status: Fix Released → Triaged
Joseph Heenan (joseph-6) wrote :

I just today (12th April 2016) ran into this bug upgrading 14.04 LTS to 15.10. I applied all available updates to 14.04 before starting the do-release-upgrade.

The upgrade failed, and pointed me to this bug. So it seems like this bug isn't fixed yet.

Dimitri John Ledkov (xnox) wrote :

the work around is to $ sudo rm -f /etc/init.d/virtuoso-nepomuk

That file has been obsolete for many releases now, but we forgot to remove it properly. It only affects systems that have been upgrading since forever and did not do a clean install in recent years.

Changed in virtuoso-opensource (Ubuntu Vivid):
status: Triaged → Won't Fix
Changed in virtuoso-opensource (Ubuntu Wily):
status: Triaged → Won't Fix

The version of virtuoso-opensource in the proposed pocket of Precise that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

Changed in virtuoso-opensource (Ubuntu Precise):
status: Fix Committed → Won't Fix
Martin Pitt (pitti) wrote :

The version of virtuoso-opensource in the proposed pocket of Precise that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers