linux-image-$ver packages leave cruft behind

Bug #374105 reported by Rolf Leggewie on 2009-05-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Precise by Rolf Leggewie
Nominated for Saucy by Rolf Leggewie
tp-smapi (Ubuntu)
Undecided
Unassigned
Nominated for Precise by Rolf Leggewie
Nominated for Saucy by Rolf Leggewie
virtualbox (Ubuntu)
Undecided
Unassigned
Nominated for Precise by Rolf Leggewie
Nominated for Saucy by Rolf Leggewie

Bug Description

$ ll /lib/modules/
total 6,0K
drwxr-xr-x 8 root root 1,0K 2009-03-10 02:41 2.6.24-23-386
drwxr-xr-x 2 root root 1,0K 2009-03-23 05:13 2.6.28-10-generic
drwxr-xr-x 5 root root 1,0K 2009-04-20 08:55 2.6.28-11-generic
drwxr-xr-x 2 root root 1,0K 2009-03-17 05:54 2.6.28-4-386
drwxr-xr-x 3 root root 1,0K 2009-03-15 04:12 2.6.28-8-generic
drwxr-xr-x 3 root root 1,0K 2009-03-12 02:18 2.6.28-9-generic

$ dpkg -l linux-image*|grep ii
ii linux-image 2.6.28.11.15 Generic Linux kernel image.
ii linux-image-2.6.24-23-386 2.6.24-23.48 Linux kernel image for version 2.6.24 on i38
ii linux-image-2.6.28-11-generic 2.6.28-11.42 Linux kernel image for version 2.6.28 on x86
ii linux-image-generic 2.6.28.11.15 Generic Linux kernel image

$ dpkg -S /lib/modules/*/modules.seriomap
linux-image-2.6.24-23-386: /lib/modules/2.6.24-23-386/modules.seriomap
dpkg: /lib/modules/2.6.28-10-generic/modules.seriomap not found.
dpkg: /lib/modules/2.6.28-11-generic/modules.seriomap not found.

2.6.28-10-generic looks like a superseded package that did not properly clean up after itself

Rolf Leggewie (r0lf) wrote :

Still an issue for the karmic kernel.

$ ll /lib/modules/2.6.31-[234]-generic/lib/modules/2.6.31-2-generic:
total 1,2M
-rw-r--r-- 1 root root 515K 2009-07-15 02:02 modules.alias.bin
-rw-r--r-- 1 root root 362K 2009-07-15 02:02 modules.dep.bin
-rw-r--r-- 1 root root 260K 2009-07-15 02:02 modules.symbols.bin

/lib/modules/2.6.31-3-generic:
total 1,2M
-rw-r--r-- 1 root root 517K 2009-07-24 23:10 modules.alias.bin
-rw-r--r-- 1 root root 363K 2009-07-24 23:10 modules.dep.bin
-rw-r--r-- 1 root root 264K 2009-07-24 23:10 modules.symbols.bin

/lib/modules/2.6.31-4-generic:
total 1,2M
-rw-r--r-- 1 root root 518K 2009-08-04 07:13 modules.alias.bin
-rw-r--r-- 1 root root 366K 2009-08-04 07:13 modules.dep.bin
-rw-r--r-- 1 root root 265K 2009-08-04 07:13 modules.symbols.bin

All of the kernel listed above had been purged from my system.

tags: added: karmic
Jeremy Foshee (jeremyfoshee) wrote :

Hi Rolf,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid.

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 374105

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Rolf Leggewie (r0lf) wrote :

come on, this is easy enough to test for yourself. No need for automatic messages to see that this still exists.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Rolf Leggewie (r0lf) wrote :

I don't quite see the point of opening a new bug rather than reopening this one. Neither 2.6.32-20-generic nor 2.6.32-21-generic are installed on my computer any longer. Maybe this is a problem in the backports-modules package?

find /lib/modules/2.6.32-2[01]-generic -type f
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath/ath.ko
/lib/modules/2.6.32-20-generic/updates/compat/compat_firmware_class.ko
/lib/modules/2.6.32-20-generic/updates/compat/compat.ko
/lib/modules/2.6.32-20-generic/updates/net/mac80211/mac80211.ko
/lib/modules/2.6.32-20-generic/updates/net/wireless/cfg80211.ko
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath/ath.ko
/lib/modules/2.6.32-21-generic/updates/compat/compat_firmware_class.ko
/lib/modules/2.6.32-21-generic/updates/compat/compat.ko
/lib/modules/2.6.32-21-generic/updates/net/mac80211/mac80211.ko
/lib/modules/2.6.32-21-generic/updates/net/wireless/cfg80211.ko

Changed in linux (Ubuntu):
status: Won't Fix → Confirmed
Rolf Leggewie (r0lf) wrote :

Yes, very much looks like the linux-backports-modules-wireless packages are to blame. When trying to purge them I get

dpkg: warning: while removing linux-backports-modules-wireless-2.6.32-20-generic, directory '/lib/modules/2.6.32-20-generic/updates' not empty so not removed.

Purging them fails anyhow, that will be another bug to report.

Rolf Leggewie (r0lf) wrote :

It seems like something else is at play here also.

$ ll /lib/modules/*/build ; ll /boot/vmlinuz-*
lrwxrwxrwx 1 root root 40 2011-11-01 07:45 /lib/modules/2.6.32-23-generic/build -> /usr/src/linux-headers-2.6.32-23-generic
lrwxrwxrwx 1 root root 40 2011-11-01 07:45 /lib/modules/2.6.32-33-generic/build -> /usr/src/linux-headers-2.6.32-33-generic
lrwxrwxrwx 1 root root 40 2011-10-25 03:55 /lib/modules/2.6.32-35-generic/build -> /usr/src/linux-headers-2.6.32-35-generic
lrwxrwxrwx 1 root root 40 2011-12-04 23:47 /lib/modules/2.6.32-36-generic/build -> /usr/src/linux-headers-2.6.32-36-generic
lrwxrwxrwx 1 root root 40 2011-12-24 02:54 /lib/modules/2.6.32-37-generic/build -> /usr/src/linux-headers-2.6.32-37-generic
lrwxrwxrwx 1 root root 40 2012-03-10 19:52 /lib/modules/2.6.32-39-generic/build -> /usr/src/linux-headers-2.6.32-39-generic
lrwxrwxrwx 1 root root 40 2012-03-26 06:24 /lib/modules/2.6.32-40-generic/build -> /usr/src/linux-headers-2.6.32-40-generic
lrwxrwxrwx 1 root root 40 2012-04-24 14:42 /lib/modules/2.6.32-41-generic/build -> /usr/src/linux-headers-2.6.32-41-generic
lrwxrwxrwx 1 root root 39 2012-05-02 11:25 /lib/modules/3.0.0-19-generic/build -> /usr/src/linux-headers-3.0.0-19-generic
lrwxrwxrwx 1 root root 39 2012-06-13 09:05 /lib/modules/3.0.0-21-generic/build -> /usr/src/linux-headers-3.0.0-21-generic
-rw-r--r-- 1 root root 4049152 2012-03-06 08:38 /boot/vmlinuz-2.6.32-40-generic
-rw-r--r-- 1 root root 4049824 2012-04-28 11:39 /boot/vmlinuz-2.6.32-41-generic
-rw------- 1 root root 4618896 2012-03-10 05:07 /boot/vmlinuz-3.0.0-17-generic
-rw------- 1 root root 4621552 2012-04-20 22:55 /boot/vmlinuz-3.0.0-19-generic
-rw------- 1 root root 4621392 2012-05-02 23:30 /boot/vmlinuz-3.0.0-20-generic
-rw------- 1 root root 4700816 2011-11-30 17:31 /boot/vmlinuz-3.2.0-999-generic

All the /lib/modules/2.6.3?-41-generic/ directories are basically empty except for that single link. More leftover cruft despite those kernel image packages being purged.

Rolf Leggewie (r0lf) wrote :

$ sudo find /lib/modules/2.6.32-2*
/lib/modules/2.6.32-20-generic
/lib/modules/2.6.32-20-generic/modules.alias
/lib/modules/2.6.32-20-generic/modules.symbols
/lib/modules/2.6.32-20-generic/modules.ofmap
/lib/modules/2.6.32-20-generic/modules.isapnpmap
/lib/modules/2.6.32-20-generic/modules.usbmap
/lib/modules/2.6.32-20-generic/modules.inputmap
/lib/modules/2.6.32-20-generic/modules.ieee1394map
/lib/modules/2.6.32-20-generic/modules.symbols.bin
/lib/modules/2.6.32-20-generic/modules.pcimap
/lib/modules/2.6.32-20-generic/modules.seriomap
/lib/modules/2.6.32-20-generic/updates
/lib/modules/2.6.32-20-generic/updates/drivers
/lib/modules/2.6.32-20-generic/updates/drivers/net
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath/ath9k
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
/lib/modules/2.6.32-20-generic/updates/drivers/net/wireless/ath/ath.ko
/lib/modules/2.6.32-20-generic/updates/compat
/lib/modules/2.6.32-20-generic/updates/compat/compat_firmware_class.ko
/lib/modules/2.6.32-20-generic/updates/compat/compat.ko
/lib/modules/2.6.32-20-generic/updates/net
/lib/modules/2.6.32-20-generic/updates/net/mac80211
/lib/modules/2.6.32-20-generic/updates/net/mac80211/mac80211.ko
/lib/modules/2.6.32-20-generic/updates/net/wireless
/lib/modules/2.6.32-20-generic/updates/net/wireless/cfg80211.ko
/lib/modules/2.6.32-20-generic/modules.dep
/lib/modules/2.6.32-20-generic/modules.alias.bin
/lib/modules/2.6.32-20-generic/modules.dep.bin
/lib/modules/2.6.32-20-generic/modules.ccwmap
/lib/modules/2.6.32-21-generic
/lib/modules/2.6.32-21-generic/updates
/lib/modules/2.6.32-21-generic/updates/drivers
/lib/modules/2.6.32-21-generic/updates/drivers/net
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath/ath9k
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath/ath9k/ath9k_common.ko
/lib/modules/2.6.32-21-generic/updates/drivers/net/wireless/ath/ath.ko
/lib/modules/2.6.32-21-generic/updates/compat
/lib/modules/2.6.32-21-generic/updates/compat/compat_firmware_class.ko
/lib/modules/2.6.32-21-generic/updates/compat/compat.ko
/lib/modules/2.6.32-21-generic/updates/net
/lib/modules/2.6.32-21-generic/updates/net/mac80211
/lib/modules/2.6.32-21-generic/updates/net/mac80211/mac80211.ko
/lib/modules/2.6.32-21-generic/updates/net/wireless
/lib/modules/2.6.32-21-generic/updates/net/wireless/cfg80211.ko

The 2.6.32-2* kernels apparently left some stuff behind due to linux-backports-modules-wireless packages as previously mentioned.

Rolf Leggewie (r0lf) wrote :

Still the same in precise.

$ find /usr/src/linux-headers-3.0.0-13-generic/
/usr/src/linux-headers-3.0.0-13-generic/
/usr/src/linux-headers-3.0.0-13-generic/include
/usr/src/linux-headers-3.0.0-13-generic/include/linux
/usr/src/linux-headers-3.0.0-13-generic/include/linux/asm-offsets.h
/usr/src/linux-headers-3.0.0-13-generic/include/linux/bounds.h
/usr/src/linux-headers-3.0.0-13-generic/include/linux/autoconf.h
/usr/src/linux-headers-3.0.0-13-generic/include/linux/utsrelease.h
/usr/src/linux-headers-3.0.0-13-generic/include/linux/generated

Rolf Leggewie (r0lf) wrote :

from my latest aptitude run

===
Removing linux-backports-modules-cw-3.3-3.2.0-53-generic-pae ...
update-initramfs: Generating /boot/initrd.img-3.2.0-53-generic-pae
Purging configuration files for linux-backports-modules-cw-3.3-3.2.0-53-generic-pae ...
update-initramfs: Generating /boot/initrd.img-3.2.0-53-generic-pae
dpkg: warning: while removing linux-backports-modules-cw-3.3-3.2.0-53-generic-pae, directory '/lib/modules/3.2.0-53-generic-pae/updates' not empty so not removed.
Removing linux-headers-3.2.0-53-generic-pae ...
Removing linux-headers-3.2.0-53 ...
Removing linux-headers-lbm-3.2.0-54-generic-pae ...
(Reading database ... 370695 files and directories currently installed.)
===

$ find /lib/modules/3.2.0-53-generic-pae/updates/dkms/
/lib/modules/3.2.0-53-generic-pae/updates/dkms/
/lib/modules/3.2.0-53-generic-pae/updates/dkms/tp_smapi.ko
/lib/modules/3.2.0-53-generic-pae/updates/dkms/thinkpad_ec.ko
/lib/modules/3.2.0-53-generic-pae/updates/dkms/vboxnetadp.ko
/lib/modules/3.2.0-53-generic-pae/updates/dkms/vboxnetflt.ko
/lib/modules/3.2.0-53-generic-pae/updates/dkms/vboxpci.ko
/lib/modules/3.2.0-53-generic-pae/updates/dkms/hdaps.ko
/lib/modules/3.2.0-53-generic-pae/updates/dkms/vboxdrv.ko

Rolf Leggewie (r0lf) wrote :

a problem with the dkms implementation of tp-smapi-dkms and virtualbox-ose-dkms?

dino99 (9d9) on 2013-10-27
tags: added: precise saucy
removed: karmic
Rolf Leggewie (r0lf) wrote :

Still present on trusty and it seems to be a problem with tp-smapi-dkms.

$ find /lib/modules/3.13.0-65-generic/
/lib/modules/3.13.0-65-generic/
/lib/modules/3.13.0-65-generic/updates
/lib/modules/3.13.0-65-generic/updates/dkms
/lib/modules/3.13.0-65-generic/updates/dkms/thinkpad_ec.ko
/lib/modules/3.13.0-65-generic/updates/dkms/tp_smapi.ko
/lib/modules/3.13.0-65-generic/updates/dkms/hdaps.ko
/lib/modules/3.13.0-65-generic/updates/dkms/vboxdrv.ko
/lib/modules/3.13.0-65-generic/updates/dkms/vboxnetadp.ko
/lib/modules/3.13.0-65-generic/updates/dkms/vboxnetflt.ko
/lib/modules/3.13.0-65-generic/updates/dkms/vboxpci.ko
/lib/modules/3.13.0-65-generic/modules.dep
/lib/modules/3.13.0-65-generic/modules.dep.bin
/lib/modules/3.13.0-65-generic/modules.alias
/lib/modules/3.13.0-65-generic/modules.alias.bin
/lib/modules/3.13.0-65-generic/modules.softdep
/lib/modules/3.13.0-65-generic/modules.symbols
/lib/modules/3.13.0-65-generic/modules.symbols.bin
/lib/modules/3.13.0-65-generic/modules.builtin.bin
/lib/modules/3.13.0-65-generic/modules.devname
$ ll /boot/*65*
ls: cannot access /boot/*65*: No such file or directory

Changed in tp-smapi (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

still not fixed.

$ sudo find /lib/modules/4.4.0-53-generic/
/lib/modules/4.4.0-53-generic/
/lib/modules/4.4.0-53-generic/build

$ file /lib/modules/4.4.0-53-generic/build /lib/modules/4.4.0-53-generic/
/lib/modules/4.4.0-53-generic/build: symbolic link to `/usr/src/linux-headers-4.4.0-53-generic'
/lib/modules/4.4.0-53-generic/: directory

Rolf Leggewie (r0lf) wrote :

found this on the console when removing a kernel package:
dpkg: warning: while removing linux-image-4.4.0-81-generic, directory '/lib/modules/4.4.0-81-generic' not empty so not removed

$ find /lib/modules/4.4.0-81-generic/
/lib/modules/4.4.0-81-generic/
/lib/modules/4.4.0-81-generic/modules.dep
/lib/modules/4.4.0-81-generic/modules.dep.bin
/lib/modules/4.4.0-81-generic/modules.alias
/lib/modules/4.4.0-81-generic/modules.alias.bin
/lib/modules/4.4.0-81-generic/modules.softdep
/lib/modules/4.4.0-81-generic/modules.symbols
/lib/modules/4.4.0-81-generic/modules.symbols.bin
/lib/modules/4.4.0-81-generic/modules.builtin.bin
/lib/modules/4.4.0-81-generic/modules.devname

tags: added: trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers