virtualbox package incompatible with 5.10 kernel

Bug #1947041 reported by Fletcher Porter

This bug report will be marked for expiration in 53 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Undecided
Unassigned

Bug Description

The virtualbox package provided by apt at version 5.2.42 is not compatible with the kernel (version 5.10) also provided by apt. There's something with vboxdrv not being able to compile.

A workaround is to install a newer version of virtualbox, such as with these instructions https://computingforgeeks.com/install-virtualbox-6-on-ubuntu-debian-linux/

## Reproduction

Precondition: have a system with linux-headers-5.10.0-051000 and linux-headers-5.10.0-051000-generic installed

1. `sudo apt install virtualbox`
2. Launch virtualbox
3. Create a simple VM
4. Launch the VM from virtualbox
5. Receive an error saying that you must `modprobe vboxdrv`
6. `modprobe vboxdrv` leads to `modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/5.10.0-051000-generic`

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: apt 1.6.14
Uname: Linux 5.10.0-051000-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.26
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Oct 13 13:02:58 2021
InstallationDate: Installed on 2021-01-04 (281 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: apt
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Fletcher Porter (fpdotmonkey) wrote :
Revision history for this message
Julian Andres Klode (juliank) wrote :

Are you saying that the virtualbox-dkms fails to compile for the 5.10 kernel? Your reproduction comment is not helpful; if you haven't compiled and installed the module, it sure isn't working.

affects: apt (Ubuntu) → virtualbox (Ubuntu)
Changed in virtualbox (Ubuntu):
status: New → Incomplete
Revision history for this message
Fletcher Porter (fpdotmonkey) wrote :

> Are you saying that the virtualbox-dkms fails to compile for the 5.10 kernel?

Yes, correct

Revision history for this message
Fletcher Porter (fpdotmonkey) wrote :

To be clear, installing with the above PPA to get VirtualBox 6.1 leads to no issues; the only package manually installed was VirtualBox.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers