20.04 not compatible with virtualbox-guest-x11: Fails changing display

Bug #1873922 reported by Hadmut Danisch
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Hi,

I just tested the latest Lubuntu 20.04 daily build within Virtual Box 6.0.10 (and upgraded to 6.1, which didn't help) running on MacOS.

After just the basic installation from iso-image, I've installed virtualbox-guest-utils and virtual-guest-x11.

Now, resizing the screen doesn't work. When I enlarge the outer window frame, usually the Linux guest follows with enlarging the screen within 1-2 seconds.

Now it goes into an endless loop of showing error messages like

VBoxClient: Failure Waiting for event, rc=VERR_INVALID_HANDLE
and
VBoxClient: Failed to get display change request, , rc=VERR_INVALID_HANDLE

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
Revision history for this message
Karol „Zal” Zalewski (kzzalews) wrote :

I have the same issue with Windows 10 (as host), VirtualBox 6.1.6 r137129m, VirtualBox Guest Utils 6.1.6 and Ubuntu 20.04 LTS official release (as guest, upgraded with `do-release-upgrade -d` from 18.04 LTS).

Revision history for this message
Hadmut Danisch (hadmut) wrote :

BTW, copy-paste between host and client (checked that enabled in config) doesn't work either.

Revision history for this message
Robert McQueen (robot101) wrote :
Revision history for this message
John Healy (johnthealy3) wrote :

Had this issue on an Xbubuntu 20.04 guest. Fixed it by removing the guest additions. Reinstalling the 6.0.8 guest additions was successful. https://download.virtualbox.org/virtualbox/6.0.8/

Revision history for this message
Hadmut Danisch (hadmut) wrote :

I managed to get it running but *not* using the guest packages coming with ubuntu, but installing the latest (recently release) version of virtualbox on the host (Mac) and using it to insert it's drivers as a virtual cdrom to use the latest drivers.

Revision history for this message
Freedom Bacon (freedombacon) wrote :

I'm having the same issue. Both host and guest are 20.04 and Virtualbox 6.1.10 packages from Ubuntu repo. I'm not able to change the guest's resolution *at all,* which makes it unusable for anything with a GUI because nothing written in the last 10 years gracefully downgrades to 800x600. I've tried different display drivers, 3D on/off, more RAM.

Thanks to #4 I found a work around at https://www.virtualbox.org/ticket/19496#comment:32. Running `VBoxClient --vmsvga` in the guest allows the display to by dynamically resized. Unfortunately, it does not survive guest reboot.

Revision history for this message
Forest Darling (fdarling) wrote :

I am running Xubuntu 20.04 as both my host and guest, and I ran into this same issue. The root cause is that GCC is missing in the guest, which is required to build the kernel modules. You can install it using this command:

sudo apt-get install build-essential

Once it's installed, you need to at least attempt rebuilding the kernel modules:

sudo /sbin/rcvboxadd quicksetup all

NOTE: previous versions of VirtualBox used the following command instead:

sudo /sbin/vboxconfig

If trying to rebuild the modules doesn't work, try reinstalling VirtualBox Guest Additions entirely (run these inside of the mounted Guest Additions ISO directory):

cd /media/*/*/
sudo ./VBoxLinuxAdditions.run

Here are my software versions for reference:

On the host (Xubuntu 20.04):

lsb_release -r
Release: 20.04

dpkg -l virtualbox virtualbox-guest-additions-iso
virtualbox 6.1.16-dfsg-6~ubuntu1.20.04.1
virtualbox-guest-additions-iso 6.1.16-1~ubuntu1.20.04.1

VirtualBox version from Help->About Dialog:
6.1.16_Ubuntu r140961

On the guest (Xubuntu 20.04):

lsb_release -r
20.04

VBoxClient --version
6.1.16r140961

gcc --version
9.3.0

Revision history for this message
Dimitar Aleksiev (daleksiev) wrote :

Hi, guys,
had the same issue - shutting the VB and restarting the host machine - solved it ;)
BR,
Dimo

Revision history for this message
Freedom Bacon (freedombacon) wrote :

This doesn't seem to have anything to do with gcc for me. That's installed and the module builds.

Revision history for this message
James Martin Sigler II (jmsigler2) wrote :

I am facing the same bug.

VirtualBox Graphical User Interface
Version 6.1.34 r150636 (Qt5.6.2)
Copyright © 2022 Oracle Corporation and/or its affiliates. All rights reserved
with
Ubuntu 20.04.2.0 LTS
on
Windows 10 Pro, Version 10.0.18362 Build 18362

I reloaded the VirtualBox Guest Additions which came as an ISO file with Version 6.1.34. I did download the same version from another mirror, but I have not installed that separately.

Should we consider updating Ubuntu beyond this supposedly stable version of Ubuntu 20.04? Assuming that a prior version of VirtualBox worked with Ubuntu 20.04, the bug is most likely on the VirtualBox side. I just hate the idea of a rollback at this point. I should have created a restore point before updating VirtualBox, so I could rollback. Shutting down VirtualBox and restarting it did not fix the problem for me either.

If I go to VirtualBox with the display setting VMSVGA, I just get a black screen on my DELL Latitude E6420. VBoxVGA is my typical mode, but it keeps popping up the event error. I can change the display setting in the VBoxVGA more. I think I have had unstable results with VBoxSVGA mode, but I might try that again. Maybe, I need to up the display memory to 128MB for that to work; I have display memory set to 96MB right now.

Revision history for this message
James Martin Sigler II (jmsigler2) wrote (last edit ):

I think this bug has been report to VirtualBox as the following:
https://www.virtualbox.org/report/15
Ticket: 20916
Summary: "Corrupted extensions pack file"
Host Type: Windows
Version: "VirtualBox 6.1.34"
Created: 04/26/2022
Modified: 04/28/2022

Revision history for this message
James Martin Sigler II (jmsigler2) wrote (last edit ):
Download full text (5.4 KiB)

I checked to see if I had any restore points for Virtual Box. I had two restore points for Oracle Virtual Box. I did a system restore back to the latest previous version. I have one more older restore point for Oracle Virtual Box which would restore me back to the version I have before Version 6.1.32; but so far my Ubuntu system now seems stable.

VirtualBox Graphical User Interface
Version 6.1.32 r149290 (Qt5.6.2)
Copyright © 2022 Oracle Corporation and/or its affiliates. All rights reserved.

My terminal screen inside Ubuntu-20.04.2.0 says the following:

jmsigler2@JMSigler2-VirtualBox:~$ lsmod | grep vboxguest
vboxguest 368640 6 vboxsf

jmsigler2@JMSigler2-VirtualBox:~$ /usr/sbin/VBoxService --version
6.1.34r150636

jmsigler2@JMSigler2-VirtualBox:~$ lsb_release -r
Release: 20.04

jmsigler2@JMSigler2-VirtualBox:~$ VBoxClient --version
6.1.34r150636

jmsigler2@JMSigler2-VirtualBox:~$ gcc --version
gcc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0
Copyright (C) 2019 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

So, at this point, a have a newer version of VirtualBox Guest Additions inside Ubuntu-20.04.2.0 even though I am running VirtualBox Graphical User Interface Version 6.1.32. I may try to resync/reload the VirtualBox Guest Additions in Ubuntu to match the VirtualBox Graphical User Interface,
Version 6.1.32 r149290 (Qt5.6.2). I have not decided whether to do that or not. I have loaded VirtualBox Guest Additions a number of times now to know that the it unloads the old version and then loads the new version in Ubuntu. Right now, all seems stable, regardless. I think I will leave it alone for now, and seem what happens. For now, the unstable error messages for VirtualBox 6.1.34r150636 are gone.

----------------------------------------------------
 My System - DELL Latitude E6420
----------------------------------------------------
OS Name Microsoft Windows 10 Pro
Version 10.0.18362 Build 18362
OS Manufacturer Microsoft Corporation
System Manufacturer Dell Inc.
System Model Latitude E6420
System Type x64-based PC
Processor Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz, 2801 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date Dell Inc. A24, 5/12/2017
SMBIOS Version 2.6
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer Dell Inc.
BaseBoard Product 032T9K
BaseBoard Version A02
Platform Role Mobile
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.18362.1171"
Time Zone Central Daylight Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 8.11 GB
Total Virtual Memory 31.9 GB
Available Virtual Memory 17.9 GB
Page File Space 16.0 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Running
Virtualization-based security Required Security Properties
Virtualization-based security Available Security Properties Base V...

Read more...

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.