systemd SEGV freezing on install of virtualbox

Bug #1807286 reported by kinghat on 2018-12-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
systemd
Fix Released
Unknown
systemd (Ubuntu)
Undecided
Unassigned
virtualbox (Ubuntu)
Undecided
Unassigned

Bug Description

most of the information has been reported at VBox here: https://forums.virtualbox.org/viewtopic.php?f=7&t=90643

when installing VBox this happens:
_________________________________________________________________________
sudo ./VirtualBox-5.2.23-126798-Linux_amd64.run
[sudo] password for kinghat:
Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.............
VirtualBox Version 5.2.23 r126798 (2018-11-20T16:12:47Z) installer
Installing VirtualBox to /opt/VirtualBox
Python found: python, installing bindings...

Broadcast message from systemd-journald@kinghat-kubuntu (Thu 2018-12-06 16:33:50 CST):

systemd[1]: Caught <SEGV>, dumped core as pid 5201.

Broadcast message from systemd-journald@kinghat-kubuntu (Thu 2018-12-06 16:33:50 CST):

systemd[1]: Freezing execution.

Failed to enable unit: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
Failed to enable unit: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
Failed to enable unit: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
Failed to enable unit: Connection timed out
Failed to start vboxdrv.service: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)
See system logs and 'systemctl status vboxdrv.service' for details.
Failed to start vboxballoonctrl-service.service: Connection timed out
See system logs and 'systemctl status vboxballoonctrl-service.service' for details.
Failed to start vboxautostart-service.service: Connection timed out
See system logs and 'systemctl status vboxautostart-service.service' for details.
Failed to start vboxweb-service.service: Connection timed out
See system logs and 'systemctl status vboxweb-service.service' for details.

VirtualBox has been installed successfully.

You will find useful information about using VirtualBox in the user manual
  /opt/VirtualBox/UserManual.pdf
and in the user FAQ
  http://www.virtualbox.org/wiki/User_FAQ

We hope that you enjoy using VirtualBox.
_________________________________________________________________________

VB then starts fine. after reboot none of the VMs fail to launch. ive had weird install issues with VBox on 18.10 for many months.

Description: Ubuntu 18.10
Release: 18.10

VirtualBox-5.2.23-126798-Linux_amd64.run

http://paste.debian.net/hidden/ee22b12a/

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: virtualbox (not installed)
ProcVersionSignature: Ubuntu 4.18.0-12.13-generic 4.18.17
Uname: Linux 4.18.0-12-generic x86_64
ApportVersion: 2.20.10-0ubuntu13.1
Architecture: amd64
CurrentDesktop: KDE
Date: Thu Dec 6 17:21:15 2018
InstallationDate: Installed on 2018-08-20 (108 days ago)
InstallationMedia: Kubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
SourcePackage: virtualbox
UpgradeStatus: Upgraded to cosmic on 2018-10-10 (57 days ago)

kinghat (kinghat) wrote :
Gordon Lack (gordon-lack) wrote :

Happens to me to.

First seen when trying to install 5.2.22.
I abandoned that, cleared things up and re-installed 5.2.20 - which worked OK.

I've just tried installing 6.0.3-BETA3. That suffered this issue too.
I cleared things up (didn't wait for the install to "finish") and tried re-installing 5.2.20. This is also now suffering this issue.

Gordon Lack (gordon-lack) wrote :

FYI: The 6.0 final installs OK. See:
   https://forums.virtualbox.org/viewtopic.php?f=7&t=90239#p436126
(and it worked for me...).

However, there IS still a BUG in systemd (which is where this bug should be moved - it isn't a virtualbox bug) as it shouldn't be possible for a package installation to crash systemd!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Changed in virtualbox (Ubuntu):
status: New → Confirmed
Karl-Philipp Richter (krichter) wrote :

A backtrace on Ubuntu 18.10 on Linux 4.18.0-13-generic with 5.2.20 r125813:

```
(gdb) bt
#0 0x00007f08c4693357 in kill () at ../sysdeps/unix/syscall-template.S:78
#1 0x0000559d23710606 in crash (sig=11) at ../src/core/main.c:183
#2 <signal handler called>
#3 __strlen_avx2 () at ../sysdeps/x86_64/multiarch/strlen-avx2.S:62
#4 0x00007f08c449fef7 in message_append_basic (m=m@entry=0x559d24121590,
    type=<optimized out>, p=0x100000000, stored=stored@entry=0x0)
    at ../src/basic/string-util.h:36
#5 0x00007f08c44a04eb in sd_bus_message_append_basic (
    m=m@entry=0x559d24121590, type=<optimized out>, p=<optimized out>)
    at ../src/libsystemd/sd-bus/bus-message.c:1565
#6 0x00007f08c44a0959 in sd_bus_message_appendv (m=0x559d24121590,
    types=<optimized out>, ap=ap@entry=0x7fffedec2ef0)
    at ../src/libsystemd/sd-bus/bus-message.c:2358
#7 0x00007f08c44a0f39 in sd_bus_message_append (m=<optimized out>,
    types=<optimized out>) at ../src/libsystemd/sd-bus/bus-message.c:2473
#8 0x0000559d2368caff in send_removed_signal (bus=0x559d23fff380,
    userdata=0x559d240a0f20) at ../src/core/job.c:1565
#9 0x0000559d236fcf8f in bus_foreach_bus (m=0x559d23ee83f0, subscribed2=0x0,
    send_message=0x559d2368ca50 <send_removed_signal>, userdata=0x559d240a0f20)
    at ../src/core/dbus.c:1187
#10 0x0000559d2368ecd8 in bus_job_send_removed_signal (j=<optimized out>,
    j=<optimized out>) at ../src/core/dbus-job.c:225
#11 0x0000559d2370e1de in manager_flush_finished_jobs (m=<optimized out>)
--Type <RET> for more, q to quit, c to continue without paging--
    at ../src/core/manager.c:3359
#12 manager_reload (m=0x559d23ee83f0) at ../src/core/manager.c:3477
#13 invoke_main_loop (m=0x559d23ee83f0, ret_reexecute=0x7fffedec31ca,
    ret_retval=0x7fffedec31cc, ret_shutdown_verb=<optimized out>,
    ret_fds=0x7fffedec31d0, ret_switch_root_dir=0x7fffedec31f8,
    ret_switch_root_init=0x7fffedec31f0, ret_error_message=0x7fffedec31e0)
    at ../src/core/main.c:1661
#14 0x0000559d2366f610 in main (argc=<optimized out>, argv=0x7fffedec34a8)
    at ../src/core/main.c:2415
```

Karl-Philipp Richter (krichter) wrote :

The `systemd` bug is reported and fixed upstream apparently (see bug-watch).

Changed in systemd:
status: Unknown → Fix Released

should be fixed in the systemd in disco

Changed in virtualbox (Ubuntu):
status: Confirmed → Fix Released
Changed in systemd (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.