[SRU] virtualbox-dkms 5.2.10-dfsg-6ubuntu18.04.1: virtualbox kernel module failed to build [error: implicit declaration of function ‘pci_get_bus_and_slot’]

Bug #1796543 reported by Abel Losada Esperante on 2018-10-07
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Undecided
Gianfranco Costamagna
Bionic
Undecided
Unassigned
virtualbox-ext-pack (Ubuntu)
Undecided
Gianfranco Costamagna
Bionic
Undecided
Unassigned
virtualbox-guest-additions-iso (Ubuntu)
Undecided
Gianfranco Costamagna
Bionic
Undecided
Unassigned
virtualbox-hwe (Ubuntu)
Undecided
Gianfranco Costamagna
Bionic
Undecided
Unassigned

Bug Description

[Impact]
* As usual, new hwe screwed up vbox.
  new java, new binutils, new graphic drivers, new kernel

[Test Case]
* Install bionic, install hwe and hwe-edge, check if everything is good again

[ autopkgtests ]
* this package has a really huge autopkgtest suite performed by upstream on each release, and this is the reason for me using the new release as-is instead of patching old versions.

[Regression Potential]
* This is part of virtualbox on Debian and Ubuntu since cosmic

Job for virtualbox.service failed because the control process exited with error code.
See "systemctl status virtualbox.service" and "journalctl -xe" for details.
invoke-rc.d: initscript virtualbox, action "restart" failed.
● virtualbox.service - LSB: VirtualBox Linux kernel module
   Loaded: loaded (/etc/init.d/virtualbox; generated)
   Active: failed (Result: exit-code) since Sun 2018-10-07 11:02:54 CEST; 14ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 4481 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)

oct 07 11:02:54 bionichell systemd[1]: Starting LSB: VirtualBox Linux kernel module...
oct 07 11:02:54 bionichell virtualbox[4481]: * Loading VirtualBox kernel modules...
oct 07 11:02:54 bionichell virtualbox[4481]: * No suitable module for running kernel found
oct 07 11:02:54 bionichell virtualbox[4481]: ...fail!
oct 07 11:02:54 bionichell systemd[1]: virtualbox.service: Control process exited, code=exited status=1
oct 07 11:02:54 bionichell systemd[1]: virtualbox.service: Failed with result 'exit-code'.
oct 07 11:02:54 bionichell systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: virtualbox-dkms 5.2.10-dfsg-6ubuntu18.04.1
ProcVersionSignature: Ubuntu 4.18.0-8.9~18.04.1-generic 4.18.7
Uname: Linux 4.18.0-8-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
DKMSKernelVersion: 4.18.0-8-generic
Date: Sun Oct 7 11:02:23 2018
DuplicateSignature: dkms:virtualbox-dkms:5.2.10-dfsg-6ubuntu18.04.1:/var/lib/dkms/virtualbox/5.2.10/build/vboxpci/linux/VBoxPci-linux.c:92:40: error: implicit declaration of function ‘pci_get_bus_and_slot’; did you mean ‘pci_get_domain_bus_and_slot’? [-Werror=implicit-function-declaration]
InstallationDate: Installed on 2018-10-06 (0 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
PackageArchitecture: all
PackageVersion: 5.2.10-dfsg-6ubuntu18.04.1
Python3Details: /usr/bin/python3.6, Python 3.6.6, python3-minimal, 3.6.5-3ubuntu1
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.5
SourcePackage: virtualbox
Title: virtualbox-dkms 5.2.10-dfsg-6ubuntu18.04.1: virtualbox kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

tags: removed: need-duplicate-check
summary: virtualbox-dkms 5.2.10-dfsg-6ubuntu18.04.1: virtualbox kernel module
- failed to build
+ failed to build [error: implicit declaration of function
+ ‘pci_get_bus_and_slot’]
summary: - virtualbox-dkms 5.2.10-dfsg-6ubuntu18.04.1: virtualbox kernel module
- failed to build [error: implicit declaration of function
+ [SRU] virtualbox-dkms 5.2.10-dfsg-6ubuntu18.04.1: virtualbox kernel
+ module failed to build [error: implicit declaration of function
‘pci_get_bus_and_slot’]
Changed in virtualbox (Ubuntu):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
status: New → Triaged

this fixes the kernel issues, as well as the new java9-10-11 incompatibilities, CVE fixes and new binutils fixes, and should go in bionic together with the proposed kernel, to avoid people complains.

I could copy-paste the very same template as the previous SRU microreleases, in this case the delta is not even that huge (lots of merged patches)

Changed in virtualbox-ext-pack (Ubuntu):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
Changed in virtualbox-guest-additions-iso (Ubuntu):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
Changed in virtualbox-hwe (Ubuntu):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
Changed in virtualbox-ext-pack (Ubuntu):
status: New → Triaged
Changed in virtualbox-guest-additions-iso (Ubuntu):
status: New → In Progress
Changed in virtualbox-hwe (Ubuntu):
status: New → In Progress
Changed in virtualbox-ext-pack (Ubuntu):
status: Triaged → In Progress
Changed in virtualbox (Ubuntu):
status: Triaged → In Progress
description: updated
Changed in virtualbox-ext-pack (Ubuntu):
status: In Progress → Fix Released
Changed in virtualbox (Ubuntu):
status: In Progress → New
status: New → Confirmed
status: Confirmed → Incomplete
status: Incomplete → New
status: New → In Progress
Changed in virtualbox-guest-additions-iso (Ubuntu):
status: In Progress → Fix Released
Changed in virtualbox (Ubuntu):
status: In Progress → Fix Released
Changed in virtualbox-hwe (Ubuntu):
status: In Progress → Fix Released
Changed in virtualbox (Ubuntu Bionic):
status: New → In Progress
Changed in virtualbox-ext-pack (Ubuntu Bionic):
status: New → In Progress
Changed in virtualbox-guest-additions-iso (Ubuntu Bionic):
status: New → In Progress
Changed in virtualbox-hwe (Ubuntu Bionic):
status: New → In Progress

Hello Abel, or anyone else affected,

Accepted virtualbox into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox/5.2.18-dfsg-2~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in virtualbox (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in virtualbox-hwe (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Abel, or anyone else affected,

Accepted virtualbox-hwe into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-hwe/5.2.18-dfsg-3~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in virtualbox-ext-pack (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Abel, or anyone else affected,

Accepted virtualbox-ext-pack into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-ext-pack/5.2.18-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in virtualbox-guest-additions-iso (Ubuntu Bionic):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Abel, or anyone else affected,

Accepted virtualbox-guest-additions-iso into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-guest-additions-iso/5.2.18-1~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

the packages seems to be correctly installed and runnable..
Get:14 http://archive.ubuntu.com/ubuntu bionic-proposed/multiverse amd64 virtualbox amd64 5.2.18-dfsg-2~ubuntu18.04.1 [17.0 MB]
Get:15 http://archive.ubuntu.com/ubuntu bionic-proposed/multiverse amd64 virtualbox-ext-pack all 5.2.18-1~ubuntu18.04.1 [10.2 kB]

Abel, can you please do some testing on top of mine?
thanks!

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

Also the guest-additions-iso are correctly installed and placed in the right place.

It works correctly, I can even start a VM inside the bionic-VM I created to test, with kernel 4.18 from hwe-edge

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers