virtualbox 5.2.16-dfsg-3build1 ADT test failure with linux 4.18.0-5.6

Bug #1787441 reported by Seth Forshee on 2018-08-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Seth Forshee (sforshee) wrote :
tags: added: kernel-adt-failure
Seth Forshee (sforshee) wrote :

I don't see any failure in the log.

Changed in virtualbox (Ubuntu):
status: New → Invalid
Seth Forshee (sforshee) wrote :
Download full text (3.3 KiB)

I don't know why there are two make.log files attached, but the second one definitely has errors.

/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c: In function ‘sf_init_inode’:
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:165:28: error: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type [-Werror=incompatible-pointer-types]
     sf_ftime_from_timespec(&inode->i_atime, &info->AccessTime);
                            ^~~~~~~~~~~~~~~
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:53:53: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
                                    ~~~~~~~~~~~~~~~~~^~
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:166:28: error: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type [-Werror=incompatible-pointer-types]
     sf_ftime_from_timespec(&inode->i_ctime, &info->ChangeTime);
                            ^~~~~~~~~~~~~~~
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:53:53: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
                                    ~~~~~~~~~~~~~~~~~^~
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:167:28: error: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type [-Werror=incompatible-pointer-types]
     sf_ftime_from_timespec(&inode->i_mtime, &info->ModificationTime);
                            ^~~~~~~~~~~~~~~
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:53:53: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
                                    ~~~~~~~~~~~~~~~~~^~
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c: In function ‘sf_setattr’:
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:377:54: error: passing argument 2 of ‘sf_timespec_from_ftime’ from incompatible pointer type [-Werror=incompatible-pointer-types]
             sf_timespec_from_ftime(&info.AccessTime, &iattr->ia_atime);
                                                      ^~~~~~~~~~~~~~~~
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:63:69: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_timespec_from_ftime(RTTIMESPEC *ts, struct timespec *tv)
                                                    ~~~~~~~~~~~~~~~~~^~
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:379:60: error: passing argument 2 of ‘sf_timespec_from_ftime’ from incompatible pointer type [-Werror=incompatible-pointer-types]
             sf_timespec_from_ftime(&info.ModificationTime, &iattr->ia_mtime);
                                                            ^~~~~~~~~~~~~~~~
/var/lib/dkms/virtualbox-guest/5.2.16/build/vboxsf/utils.c:63:69: note: expected ‘struct timespec *’ but argument is of type ‘struc...

Read more...

Changed in virtualbox (Ubuntu):
status: Invalid → Confirmed

Can you please try vbox from my ppa?
https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/locutusofborg-ppa/+packages

5.2.18 is already out since some days!

Seth Forshee (sforshee) wrote :
Download full text (3.6 KiB)

Sorry, I guess I missed the last comment. Seems to still be failing with 5.2.18-dfsg-1 from cosmic-release though.

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/amd64/v/virtualbox/20180824_183905_b1337@/log.gz
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-unstable/cosmic/amd64/v/virtualbox/20180824_183905_b1337@/artifacts.tar.gz

/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c: In function ‘sf_init_inode’:
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c:165:28: error: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type [-Werror=incompatible-pointer-types]
     sf_ftime_from_timespec(&inode->i_atime, &info->AccessTime);
                            ^~~~~~~~~~~~~~~
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c:53:53: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
                                    ~~~~~~~~~~~~~~~~~^~
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c:166:28: error: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type [-Werror=incompatible-pointer-types]
     sf_ftime_from_timespec(&inode->i_ctime, &info->ChangeTime);
                            ^~~~~~~~~~~~~~~
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c:53:53: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
                                    ~~~~~~~~~~~~~~~~~^~
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c:167:28: error: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type [-Werror=incompatible-pointer-types]
     sf_ftime_from_timespec(&inode->i_mtime, &info->ModificationTime);
                            ^~~~~~~~~~~~~~~
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c:53:53: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
                                    ~~~~~~~~~~~~~~~~~^~
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c: In function ‘sf_setattr’:
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c:377:54: error: passing argument 2 of ‘sf_timespec_from_ftime’ from incompatible pointer type [-Werror=incompatible-pointer-types]
             sf_timespec_from_ftime(&info.AccessTime, &iattr->ia_atime);
                                                      ^~~~~~~~~~~~~~~~
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c:63:69: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_timespec_from_ftime(RTTIMESPEC *ts, struct timespec *tv)
                                                    ~~~~~~~~~~~~~~~~~^~
/var/lib/dkms/virtualbox-guest/5.2.18/build/vboxsf/utils.c:379:60: error: passing argument 2 of ‘sf_timespec_from_ftime’ from incompatible pointer type [...

Read more...

Seth Forshee (sforshee) wrote :

All the kernel modules contained in the virtualbox-guest-dkms from the ppa built fine with 4.18. Thanks!

lets upload in the archive!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox - 5.2.18-dfsg-2

---------------
virtualbox (5.2.18-dfsg-2) unstable; urgency=medium

  * debian/patches/kernel-4.18.patch:
    - Fix build with kernel 4.18 (LP: #1787441)

 -- Gianfranco Costamagna <email address hidden> Fri, 17 Aug 2018 17:02:22 +0200

Changed in virtualbox (Ubuntu):
status: Confirmed → Fix Released

Hello Seth, or anyone else affected,

Accepted virtualbox into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox/5.2.18-dfsg-2~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in virtualbox (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Seth, or anyone else affected,

Accepted virtualbox-hwe into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-hwe/5.2.18-dfsg-3~ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments