SRU virtualbox resume fails

Bug #1766304 reported by Simon IJskes on 2018-04-23
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
virtualbox (Debian)
Fix Released
Unknown
virtualbox (Ubuntu)
High
Gianfranco Costamagna

Bug Description

[Impact]
* Some images fail to resume

[ Test Case ]
* install 18.04 in virtualbox
* start vm
* stop vm, with save state
* start vm -> result: crash

[Regression Potential]
* Really low, this one line patch comes from upstream

[ other info ]
other linux based images like mate16.04 also fail to resume properly. windows 10 images resume ok.

syslog:
kernel: [268618.075493] EMT[31520]: segfault at 7f64ebf95970 ip 00007f64a8bfdaca sp 00007f64cb7fba10 error 7 in VBoxDD.so[7f64a8b97000+1b3000]

virtualbox gui shows:
The VM session was aborted.

Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
SessionMachine
Interface:
ISession {7844aa05-b02e-4cdd-a04f-ade4a762e6b7}

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: virtualbox-qt 5.2.10-dfsg-2
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
ApportVersion: 2.20.9-0ubuntu6
Architecture: amd64
CurrentDesktop: MATE
Date: Mon Apr 23 18:49:12 2018
InstallationDate: Installed on 2017-01-11 (467 days ago)
InstallationMedia: Ubuntu-Server 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: virtualbox
UpgradeStatus: No upgrade log present (probably fresh install)

Simon IJskes (sim-nyx) wrote :
description: updated
Simon IJskes (sim-nyx) wrote :

problem also occurs with new linux-image-4.15.0-19-generic 4.15.0-19.20

Simon IJskes (sim-nyx) wrote :

running in the client VM:

dist-upgrade, removing vbox related kernel modules, update-initramfs -c

does not fix the problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
Simon IJskes (sim-nyx) wrote :

also occurs on 4.15.0-20-generic #21

Hello, can you please try this vbox?
https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/locutusofborg-ppa/
5.2.10-dfsg-5ubuntu1
thanks!

Changed in virtualbox (Ubuntu):
status: Confirmed → Incomplete
Simon IJskes (sim-nyx) wrote :

and it works! thanks for all the work. also thanks for the quick response.

closing bug (if i can).

Changed in virtualbox (Ubuntu):
status: Incomplete → Fix Committed
status: Fix Committed → In Progress

please do not close it, we need it to be published in updates.

summary: - virtualbox resume fails
+ SRU virtualbox resume fails
Changed in virtualbox (Ubuntu):
importance: Undecided → High
description: updated
Changed in virtualbox (Ubuntu):
assignee: nobody → LocutusOfBorg (costamagnagianfranco)
Changed in virtualbox (Debian):
status: Unknown → Fix Released

This went in release with the sync of tonight

Changed in virtualbox (Ubuntu):
status: In Progress → Fix Released
Changed in virtualbox (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → LocutusOfBorg (costamagnagianfranco)
importance: Undecided → Medium

bionic is already ok

Changed in virtualbox (Ubuntu Bionic):
status: In Progress → Invalid
no longer affects: virtualbox (Ubuntu Bionic)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.