Xorg freeze

Bug #1748729 reported by BertN45 on 2018-02-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Low
Unassigned

Bug Description

Host: Ubuntu 18.04, Virtualbox 5.2.6
Guest: Ubuntu GNOME 17.10 and 18.04, using Oracle Guest Additions 5.2.4, or 5.2.7

The problem is the guest's screen almost freezes completely as soon as I maximise any window in the guest. Any mouse click takes 10-60 seconds before the system reacts to it. I am not using Oracle Guest Additions 5.2.6 as the guest won't boot.

Windows 7 and 10 work without any problem.

WORKAROUND: Disable 3D acceleration.

WORKAROUND: Use as a guest Ubuntu Mate or Xubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu4
ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
Uname: Linux 4.13.0-32-generic x86_64
ApportVersion: 2.20.8-0ubuntu8
Architecture: amd64
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sun Feb 11 06:31:52 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GpuHangFrequency: Continuously
GpuHangReproducibility: Yes, I can easily reproduce it
GpuHangStarted: Immediately after installing this version of Ubuntu
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
InstallationDate: Installed on 2017-12-22 (50 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20171219)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: innotek GmbH VirtualBox
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-32-generic root=UUID=f3311827-9a0c-490d-a707-d4d037152c4d ro quiet splash
Renderer: Software
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.family: Virtual Machine
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.89-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.3.3-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.3.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

BertN45 (lammert-nijhof) wrote :
BertN45 (lammert-nijhof) wrote :

I see the bug report talks about software rendering, but I do use 3D acceleration and the problem only occurs when I select 3D acceleration. With 3D acceleration disabled everything work fine.

description: updated
Changed in xorg (Ubuntu):
importance: Undecided → Low
BertN45 (bertnijhof) wrote :

For me the problem is kind of important, since I moved all my work to specialised Virtual Machines;
a. one for the normal office and web browsing work,
b. one for banking and other financial apps,
c. one to try out new and unknown apps,
d. one to try out Ubuntu 18.04.

The work around I use now, is:
a. Peppermint 8 with 3D acceleration;
b. For banking I can live with software rendering and Ubuntu 17.10;
c. Xubuntu 17.10 with 3D acceleration.

I would politely propose to increase the priority of the bug, since I expect, it will be relatively simple to solve. Besides a desktop that freezes, if you maximise a window, looks a little bit like the past of e.g. Ubuntu 6.06 :)

BertN45, given 3D acceleration is a WORKAROUND, Low is in line with its definition noted in https://wiki.ubuntu.com/Bugs/Importance . To advise, the potential difficulty in solving a bug has no impact on Importance.

Despite this:

1) What version of VirtualBox are you using on the host?

2) Did this issue start happening in the guest after an update from either the guest, or host? If so, which specifically?

3) In your last comment, it appears you are indicating that this only happens in 17.10 GNOME, but not with 17.10 Xubuntu. Could you please clarify?

4) Does installing in the guest the package virtualbox-guest-x11 and rebooting improve the situation?

Changed in xorg (Ubuntu):
status: New → Incomplete
BertN45 (bertnijhof) wrote :

1. The host is using 5.2.6. I kept the guests at 5.2.4, because 5.2.6 did freeze during login or did enter a login loop dependent on the distro. I filed a bug report with Oracle and many persons had the same issue during login. The beta version 5.2.7 did solve the 5.2.6 login issues.

Today I also tried the 'beta' version of 5.2.7 with Ubuntu 18.04 with respect to maximising the window, but without success.

2. I did keep Guest additions 5.2.4 installed for all distros, but I do not remember how 5.2.2 behaved. Probably I was still using Ubuntu 16.04 for both host and guest during that time.

3. I only have the window maximising problem with Ubuntu Gnome 17.10 and 18.04, but NOT with Ubuntu Mate 17.10; Xubuntu 17.10; Peppermint 8 nor with Linux Mint 18.3.

4; That package had not been installed, but after installing that package and 1 or 2 dependencies, the system hung during reboot directly after starting the Gnome Display Manager. It looks like the bug of point 1 had been re-introduced, but now for both 3D enabled and 3D disabled. I will try to remove the package again through ctrl+alt+F2 or restore a back-up.

description: updated

BertN45:

1)
>"I kept the guests at 5.2.4"

To clarify, using a host with 5.2.6, if you use the Oracle guest additions from version 5.2.4 this problem is not reproducible in Ubuntu GNOME?

2)
>" I filed a bug report with Oracle"

Did you file a bug report with Oracle regarding the scope of this report? If so, could you please provide the URL?

3)
>"Today I also tried the 'beta' version of 5.2.7 with Ubuntu 18.04"

To clarify, you have 5.2.7 on a Ubuntu 18.04 host, and then install the 5.2.7 guest additions in Ubuntu GNOME 18.04?

4)
>"That package had not been installed, but after installing that package"

To advise, you wouldn't have both the Oracle Guest Additions installed and then install this package. If you did this, that will cause this issue. virtualbox-guest-x11 is the guest additions that is made for Ubuntu.

BertN45 (bertnijhof) wrote :

1)
One month ago I upgraded Virtualbox from 5.2.4 to 5.2.6. While I was upgrading Vbox Guest Additions in my VMs to 5.2.6, I detected that that 5.2.6 Guest additions introduced a serious boot/login problem for all my VMs. So as a work-around I kept all my VMs at Guest Additions 5.2.4. I reported that problem to Oracle here:
https://www.virtualbox.org/ticket/17463
In that long discussion between various persons about the problem, other work-arounds had been proposed too. I detected yesterday that other people used "beta" 5.2.7 to solve the problem.

2)
We are dealing with 2 separate problems:
- one is the boot/login problem of the Vbox Guest Additions 5.2.6, reported to Oracle one month ago. That problem occurs in all my VMs and all my distros. My work-around was stick to Guest Additions 5.2.4.
- the other is the window maximising problem with Vbox Guest Additions 5.2.4 reported to you only occurring in Ubuntu Gnome 17.10 and 18.04. Work-arounds are stop using 3D acceleration, if you do not need the performance improvement of that 3D acceleration. If you need the performance improvement of that 3D acceleration use any other distro, since the problem only occurs in Ubuntu Gnome.

3)
I detected today that Vbox Guest Additions 5.2.7 was available. So I thought maybe I get lucky and it also solves the window maximising problem, so I tried it. It did not solve that problem. All the time my Host remained at Vbox 5.2.6.

4)
I removed virtualbox-guest-x11. I did not realise, that it was the Ubuntu version of Vbox Guest Additions. I always install Vbox Guest Additions through its ISO file, since it then also nicely removes the currently installed version. In general Ubuntu is a full release behind with respect to Virtualbox. Ubuntu's current Vbox release for Ubuntu 17.10 is 5.1.30, while Ubuntu 18.04 uses Vbox 5.2.6. I tried your advice at Ubuntu 18.04. That installed Vbox Guest Additions 5.2.6, so it is completely understandable, that the login problem reported to Oracle a month ago reappeared.

As Ubuntu you have learned I think four things from this confusion:
- Avoid Vbox Guest Additions 5.2.6 in Ubuntu 18.04. Stick to Vbox 5.2.4 or push Oracle for 5.2.8.
- I would talk to Oracle about the quality of their regression testing in the light of your new philosophy with respect to more integration of the Vbox Guest Additions as reported by e.g. OMG Ubuntu.
- Maybe you should only update the host versions in your repository and leave the update of the Guest to the current Oracle mechanisms. They store the correct guest ISO file somewhere in the Linux file system of the host and make it available to the guest through the Host devices menu "Insert Guest Additions CD image". They warn you about outdated guests through notification, but leave the upgrade decision to you. I love that mechanism.
- You still have a separate "windows maximising" problem in Ubuntu Gnome.

I will download the 5.1.30 Guest Additions ISO file and try that one in Ubuntu 17.10.

description: updated

BertN45:

1) To advise, the scope of this bug report is only how the guest screen freezes after maximizing a window when 3D acceleration is enabled. It is not about the booting issue using Oracle Guest Additions 5.2.6. It is helpful if you file a new report about the booting issue in a terminal:
ubuntu-bug xorg

Please feel free to subscribe me to it.

2) So developers may review, could you please undo the WORKAROUND, reproduce the problem in Ubuntu GNOME 18.04, and then attach dmesg and xorg?

BertN45 (bertnijhof) wrote :

1) Agreed, I will file another bug report.

2) I did already provide that information to you in the original bug-report using Vbox Guest Additions (VGA) 5.2.4. It did take a lot of time to produce it, because the system took 10-60 seconds to react to any mouse click.

Remember the problem occurs only in Ubuntu Gnome, both in 17.10 and 18.04. I tried 17.10 with VGA 5.1.30, 5.2.4 and 5.2.7. I tried 18.04 with VGA 5.2.4 and 5.2.7.

I can't use 5.2.6 for testing, see the next statement on the Download page of the Virtualbox website:
------------------------------------------
Important: The Guest Additions which come with VirtualBox 5.2.6 and 5.1.32 do not work properly on Linux guests with 3D enabled. Here are updated versions for 5.2.6 and 5.1.32.
------------------------------------------
That updated version is VGA 5.2.7.

BertN45, thanks for the clarification.

Given Oracle upstream has indicated on their website the root cause of this issue is due to their Guest Additions version, and the fix is to upgrade only the Guest Additions version, I'll reassign to virtualbox for review:
https://www.virtualbox.org/wiki/Downloads

Potential solutions would be:
1) The virtualbox package in 18.04 is updated when Oracle provides the next maintenance release of 5.2.x.
2) Update just virtualbox-guest-x11 to use 5.2.7 Guest Additions while keeping all the other packages the same.

affects: xorg (Ubuntu) → virtualbox (Ubuntu)
Changed in virtualbox (Ubuntu):
status: Incomplete → Triaged

5.2.7 iso will go in bionic later today, and I'll fix virtualbox-guest* after.

Changed in virtualbox (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.