virtualbox-guest kernel module failed to build

Bug #1575070 reported by David Pires on 2016-04-26
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Undecided
Unassigned

Bug Description

 Error: command ['sh', '-c', 'find /lib/modules/`uname -r` -name "vbox*" | xargs -r modinfo'] failed with exit code 123: modinfo: ERROR: Module /lib/modules/4.4.0-21-generic/kernel/ubuntu/vbox not found.
 modinfo: ERROR: Module /lib/modules/4.4.0-21-generic/kernel/ubuntu/vbox/vboxvideo not found.
 modinfo: ERROR: Module /lib/modules/4.4.0-21-generic/kernel/ubuntu/vbox/vboxsf not found.
 modinfo: ERROR: Module /lib/modules/4.4.0-21-generic/kernel/ubuntu/vbox/vboxguest not

ProblemType: Package
DistroRelease: Ubuntu 16.10
Package: virtualbox-guest-dkms 5.0.18-dfsg-2build1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
DKMSKernelVersion: 4.4.0-22-generic
Date: Tue Apr 26 09:48:09 2016
DuplicateSignature: dkms:virtualbox-guest-dkms:5.0.18-dfsg-2build1:/var/lib/dkms/virtualbox-guest/5.0.18/build/vboxguest/VBoxGuest-linux.c:1:0: error: code model kernel does not support PIC mode
InstallationDate: Installed on 2016-04-21 (4 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
PackageVersion: 5.0.18-dfsg-2build1
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1
 apt 1.2.10ubuntu1
SourcePackage: virtualbox
Title: virtualbox-guest-dkms 5.0.18-dfsg-2build1: virtualbox-guest kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

David Pires (slickymaster) wrote :
tags: removed: need-duplicate-check

known issue, yakkety is not even open for development, it will be fixed in the next few days

Changed in virtualbox (Ubuntu):
status: New → Invalid
David Pires (slickymaster) wrote :

Yes, I know that it's not yet open for development. The idea behind the report was more of a heads up.

Changed in virtualbox (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers