virtualbox-guest-dkms 4.3.10-dfsg-1ubuntu5: virtualbox-guest kernel module failed to build [error: ‘struct file’ has no member named ‘f_dentry’]

Bug #1457780 reported by Sqoorch on 2015-05-22

This bug report was converted into a question: question #270332: virtualbox-guest-dkms 4.3.10-dfsg-1ubuntu5: virtualbox-guest kernel module failed to build [error: ‘struct file’ has no member named ‘f_dentry’].

108
This bug affects 21 people
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Undecided
Unassigned

Bug Description

Update from linux-generic-lts-utopic 3.16.0.38.30 to linux-generic-lts-vivid 3.19.0.18.5

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: virtualbox-guest-dkms 4.3.10-dfsg-1ubuntu5
ProcVersionSignature: Ubuntu 3.16.0-37.51~14.04.1-generic 3.16.7-ckt9
Uname: Linux 3.16.0-37-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.11
Architecture: amd64
DKMSKernelVersion: 3.19.0-18-generic
Date: Fri May 22 09:35:00 2015
DuplicateSignature: dkms:virtualbox-guest-dkms:4.3.10-dfsg-1ubuntu5:/var/lib/dkms/virtualbox-guest/4.3.10/build/vboxsf/dirops.c:129:29: error: ‘struct file’ has no member named ‘f_dentry’
PackageArchitecture: all
PackageVersion: 4.3.10-dfsg-1ubuntu5
SourcePackage: virtualbox
Title: virtualbox-guest-dkms 4.3.10-dfsg-1ubuntu5: virtualbox-guest kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

Sqoorch (sqoorch) wrote :
tags: removed: need-duplicate-check
summary: virtualbox-guest-dkms 4.3.10-dfsg-1ubuntu5: virtualbox-guest kernel
- module failed to build
+ module failed to build [error: ‘struct file’ has no member named
+ ‘f_dentry’]
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
John D (johnniedoo) wrote :

i never installed-rather attempted to remove package through synaptic. it was attached to some other install and i never saw it come in through details. so many lines came past so fast, i missed this one, and others maybe. but it was trying to install when i killed it(package in removal of foreign packages)

Josef DS (josefdelossantos) wrote :

any assistance is welcome, mostly those based on experiential resolution.

Changed in virtualbox (Ubuntu):
status: Confirmed → Invalid
Wayne (wayne-okuma) on 2015-08-20
Changed in virtualbox (Ubuntu):
status: Invalid → Confirmed
Vincent Gerris (vgerris) wrote :

See possible workaround here:
https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1457776/comments/9
Probably a related bug.

Nicholas (nperusse) wrote :

I have been trying to get VboxManage installed onto my unbuntu but whenever i try it doesnt install the package and everything. ive tried a few of the other solutions. plus ive been trying to do it for the display because its so small that i cant work on vbox with such a small box HELP

Dennis Rassmann (showp1984) wrote :

@ #5

This should do it as well, if virtualbox-5.0 is in your distro's repo. (It is in the ubuntu 14.04.3 repo)

sudo apt-get remove virtualbox-4.3 && sudo apt-get install virtualbox-5.0

Hi all

I'm in the process of SRUing virtualbox to 4.3.34.

can you please give my ppa a test?

talking about bug LP: #1517161 and
 https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/costamagnagianfranco-ppa/+packages

this should be fixed with latest updates.

Changed in virtualbox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers