gnome-session-check-accelerated-helper crashed with SIGSEGV in __GI___pthread_mutex_lock()

Bug #1281223 reported by Sven.Frings on 2014-02-17
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Medium
Unassigned

Bug Description

Hey dear bug team i found this bug after i login to my desktop in virtualbox i use Ubuntu gnome remixe 14.04 64 bit

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: gnome-session-bin 3.9.90-0ubuntu7
ProcVersionSignature: Ubuntu 3.12.0-2.7-generic 3.12.0
Uname: Linux 3.12.0-2-generic x86_64
ApportVersion: 2.13.2-0ubuntu4
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon Feb 17 19:03:35 2014
ExecutablePath: /usr/lib/gnome-session/gnome-session-check-accelerated-helper
InstallationDate: Installed on 2013-11-10 (99 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20131109)
ProcCmdline: /usr/lib/gnome-session/gnome-session-check-accelerated-helper
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fe687304414 <__GI___pthread_mutex_lock+4>: mov 0x10(%rdi),%esi
 PC (0x7fe687304414) ok
 source "0x10(%rdi)" (0x000020d8) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-session
StacktraceTop:
 __GI___pthread_mutex_lock (mutex=0x0) at ../nptl/pthread_mutex_lock.c:66
 ?? () from /usr/lib/x86_64-linux-gnu/dri/vboxvideo_dri.so
 ?? () from /usr/lib/x86_64-linux-gnu/dri/vboxvideo_dri.so
 ?? () from /usr/lib/x86_64-linux-gnu/dri/vboxvideo_dri.so
 start_thread (arg=0x7fe684af2700) at pthread_create.c:312
Title: gnome-session-check-accelerated-helper crashed with SIGSEGV in __GI___pthread_mutex_lock()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Sven.Frings (svenkirk) wrote :

StacktraceTop:
 __GI___pthread_mutex_lock (mutex=0x0) at ../nptl/pthread_mutex_lock.c:66
 stubSyncThreadProc (ThreadSelf=0x15d28f0, pvUser=<optimized out>) at /build/buildd/virtualbox-4.3.6-dfsg/src/VBox/Additions/common/crOpenGL/load.c:898
 rtThreadMain (pThread=0x15d28f0, NativeThread=<optimized out>, pszThreadName=<optimized out>) at /build/buildd/virtualbox-4.3.6-dfsg/src/VBox/Runtime/common/misc/thread.cpp:712
 rtThreadNativeMain (pvArgs=0x15d28f0) at /build/buildd/virtualbox-4.3.6-dfsg/src/VBox/Runtime/r3/posix/thread-posix.cpp:324
 start_thread (arg=0x7fe684af2700) at pthread_create.c:312

Changed in gnome-session (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
affects: gnome-session (Ubuntu) → virtualbox (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers