vboxvideo_drv.so: undefined symbol: vgaHWFreeHWRec

Bug #1280292 reported by Loïc Minier on 2014-02-14
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

Since 4.3.6-dfsg-1, the vboxvideo_drv Xorg module doesn't load anymore; I get in my Xorg log:
vboxvideo_drv.so: undefined symbol: vgaHWFreeHWRec

(See full logs for details)

Downgrading virtualbox-guest-utils and -guest-x11 to 4.3.2-dfsg-1ubuntu2 fixes loading.

The libvgahw.so module should be providing these symbols, and it should be loaded by vbox_video on startup; I don't know why that's not occurring anymore.

Cheers,

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: virtualbox-guest-x11 4.3.6-dfsg-1
ProcVersionSignature: Ubuntu 3.13.0-8.27-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Feb 14 14:42:36 2014
SourcePackage: virtualbox
UpgradeStatus: No upgrade log present (probably fresh install)

Loïc Minier (lool) wrote :
Loïc Minier (lool) wrote :

NB: host is 64-bits OSX mavericks with VBox 4.3.6

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox - 4.3.6-dfsg-2

---------------
virtualbox (4.3.6-dfsg-2) unstable; urgency=medium

  * Disable bindnow in hardening-wrapper. This fixes loading the x11 driver.
    (LP: #1280292)

 -- Felix Geyer <email address hidden> Sat, 15 Feb 2014 11:02:21 +0100

Changed in virtualbox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers