vm will not launch if network is set to bridge

Bug #1220724 reported by Jorge Rama on 2013-09-04
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Virtualbox
Fix Released
Unknown
virtualbox (Debian)
Fix Released
Unknown
virtualbox (Ubuntu)
Undecided
Unassigned

Bug Description

I have a virtual machine in Virtualbox with a network adapter in bridge mode and it will not start since updating to Ubuntu 13.10 showing the following error:

Failed to open/create the internal network 'HostInterfaceNetworking-eth0' (you might need to modprobe vboxnetflt to make it accessible) (VERR_INTNET_FLT_IF_NOT_FOUND).
Failed to attach the network LUN (VERR_INTNET_FLT_IF_NOT_FOUND).

The error tells me to run modprobe vboxnetflt in terminal but the error persists even after running the command.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: virtualbox 4.2.16-dfsg-2
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
Date: Wed Sep 4 14:31:15 2013
InstallationDate: Installed on 2013-08-30 (4 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130827)
MarkForUpload: True
SourcePackage: virtualbox
UpgradeStatus: No upgrade log present (probably fresh install)

Jorge Rama (jorgehsrama) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
David Baumann (davidbaumann) wrote :

Dito - same here. Newest VirtualBox, Ubuntu 13.10 x64, bridged guest.

Jorge Rama (jorgehsrama) wrote :

As a test I tried installing the deb file available at the virtualbox website: http://download.virtualbox.org/virtualbox/4.2.18/virtualbox-4.2_4.2.18-88780~Ubuntu~raring_amd64.deb

I managed to install it without issue at confirmed that my vm will run correctly.

@jorgehsrama: Not sure about the bug reporter, but I'm experiencing this when using the latest VirtualBox from the standard Ubuntu repositories. I didn't try the upstream packages, but that might explain why it does work for you and not for me?

Jorge Rama (jorgehsrama) wrote :

@marten-de-vries I am the bug reporter, but I tried using the version available on the virtualbox website and it works properly.

@jorgehsrama: Ah, forgot checking that, sorry. Then we're saying the same. :)

Søren Holm (sgh) wrote :

I also suffer from this. I can confirm that it does not work in brdged mode. Further-more I can add that the problem is also present when having a network adapter set to "Host-only adapter"

Changed in virtualbox (Debian):
status: Unknown → New
Changed in virtualbox:
status: Unknown → Fix Released
shankao (shankao) wrote :

I can use the latest virtualbox by running a 3.10 kernel. AFAIK, this is a problem in the 3.11 series (check the upstream bug reports)

Changed in virtualbox (Debian):
status: New → Fix Released
Eric B (ebischoff) wrote :

Still no joy in this morning's 3.11.0-8 kernel (saucy) with stock virtualbox 4.2.16.

shankao (shankao) wrote :

Note that the virtualbox package needs to be upgraded to upstream version 4.2.18, or the specific patch applied to Ubuntu's package.
AFAIK, that's in debian and, in order to solve this problem, it needs to be synchronized from them into ubuntu.

Phil Wyett (u-k-i-t) wrote :

Sync request for package in debian to fix this bug 1228569.

Felix Geyer (debfx) wrote :

Fixed with virtualbox 4.2.16-dfsg-3

Changed in virtualbox (Ubuntu):
status: Confirmed → Fix Released
Eric B (ebischoff) wrote :

Confirmed, fixed in today's virtualbox packages. Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.