Ubuntu

network name lookups broken in NAT network adaptors

Reported by karl anliot on 2012-09-10
156
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Virtualbox
Fix Released
Unknown
virtualbox (Ubuntu)
Low
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu quantal (development branch)
Release: 12.10

2) apt-cache policy virtualbox
virtualbox:
  Installed: 4.1.18-dfsg-1ubuntu1
  Candidate: 4.1.18-dfsg-1ubuntu1
  Version table:
 *** 4.1.18-dfsg-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/universe i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen is when one starts VMs that worked in Precise:

+ Microsoft Windows Vista Business
6.0.6002 Service Pack 2 Build 6002

+ lsb_release -rd
Description: Ubuntu quantal (development branch)
Release: 12.10

one may open a browser (IE or Firefox) and it successfully connects to the internet.

4) What happens instead is it does not.
This was also tested with brand new virtualbox VMS.

One may still ping ip addresses when connected with a NAT virtual NIC, but not do DNS lookup.

WORKAROUND: Execute at a terminal:
VBoxManage modifyvm VMNAME --natdnshostresolver1 on

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: virtualbox 4.1.18-dfsg-1ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
Date: Mon Sep 10 15:38:16 2012
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905.1)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: virtualbox
UpgradeStatus: No upgrade log present (probably fresh install)

karl anliot (kanliot) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
epii (epii) wrote :

This bug is also reported in upstream (https://www.virtualbox.org/ticket/10864).

Pointing to the correct DNS server's IP address by editing /etc/resolv.conf solved this problem for me.

Marking Status Triaged due to easy reproducibility, and Importance Low due to easily implemented WORKAROUND.

description: updated
tags: added: i386 regression-release
Changed in virtualbox (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in virtualbox:
status: Unknown → New
Changed in virtualbox:
status: New → Fix Released

I think this bug's priority in Ubuntu Virtualbox should be bumped, cause although there is an easy workaround, it is very core functionality which AFAIK I did not encounter when using the Virtualbox downloaded from vietualbox.org

Alistair Buxton (a-j-buxton) wrote :

The workaround does not work for me.

Savio (abhijeet) wrote :

Alistair Buxton try adding your host dns into Guest machine. This will fix your problem for sure.

Thanks

Colin D Bennett (colinb) wrote :

I can confirm both the bug and the workaround on Xubuntu 12.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.