network name lookups broken in NAT network adaptors

Bug #1048783 reported by karl anliot
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Fix Released
virtualbox (Ubuntu)
Fix Released

Bug Description

1) lsb_release -rd
Description: Ubuntu quantal (development branch)
Release: 12.10

2) apt-cache policy virtualbox
  Installed: 4.1.18-dfsg-1ubuntu1
  Candidate: 4.1.18-dfsg-1ubuntu1
  Version table:
 *** 4.1.18-dfsg-1ubuntu1 0
        500 quantal/universe i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen is when one starts VMs that worked in Precise:

+ Microsoft Windows Vista Business
6.0.6002 Service Pack 2 Build 6002

+ lsb_release -rd
Description: Ubuntu quantal (development branch)
Release: 12.10

one may open a browser (IE or Firefox) and it successfully connects to the internet.

4) What happens instead is it does not.
This was also tested with brand new virtualbox VMS.

One may still ping ip addresses when connected with a NAT virtual NIC, but not do DNS lookup.

WORKAROUND: Execute at a terminal:
VBoxManage modifyvm VMNAME --natdnshostresolver1 on

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: virtualbox 4.1.18-dfsg-1ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
Date: Mon Sep 10 15:38:16 2012
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905.1)
 PATH=(custom, user)
SourcePackage: virtualbox
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
karl anliot (kanliot) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
Revision history for this message
epii (epii) wrote :

This bug is also reported in upstream (

Pointing to the correct DNS server's IP address by editing /etc/resolv.conf solved this problem for me.

Revision history for this message
penalvch (penalvch) wrote :

Marking Status Triaged due to easy reproducibility, and Importance Low due to easily implemented WORKAROUND.

description: updated
tags: added: i386 regression-release
Changed in virtualbox (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in virtualbox:
status: Unknown → New
Changed in virtualbox:
status: New → Fix Released
Revision history for this message (yeosuanaik) wrote :

I think this bug's priority in Ubuntu Virtualbox should be bumped, cause although there is an easy workaround, it is very core functionality which AFAIK I did not encounter when using the Virtualbox downloaded from

Revision history for this message
Alistair Buxton (a-j-buxton) wrote :

The workaround does not work for me.

Revision history for this message
Savio (abhijeet) wrote :

Alistair Buxton try adding your host dns into Guest machine. This will fix your problem for sure.


Revision history for this message
Colin D Bennett (colinb) wrote :

I can confirm both the bug and the workaround on Xubuntu 12.10.

Revision history for this message
Venkateswarlu Vudatala (srivenkat2) wrote :

I struggled for 3 days to solve this issue and even the work around command did not solve the issue.

But the issue solved after pointing nameserver address in /etc/resolv.conf of virtualbox vm to hosts dns address.

Thanks Savio (abhijeet)


Revision history for this message
penalvch (penalvch) wrote :

As per upstream, the issue scoped to this report has been fixed since 4.2.2. As this isn't reproducible with latest version from Ubuntu repositories, marking Fix Released.

Changed in virtualbox (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.