Unable to add shared folder in Ubuntu 12.10 alpha inside a virtualbox.

Bug #1032055 reported by Vishnu Padmanabhan
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

I tried adding a shared folder to Ubuntu 12.10 running in a VirtualBox environment. I was unable to do so and the system also crashed once while trying. There is some mounting issue. Not sure if this is because 12.10 is an alpha release. I tried installing Guest addons, but for some reason this was not successful. It said:

"Building the VirtualBox Guest Additions kernel modules
The headers for the current running kernel were not found. If the following
module compilation fails then this could be the reason.

Building the main Guest Additions module ...fail!
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions ...done.
Installing the Window System drivers
Installing X.Org Server 1.12 modules ...done.
Setting up the Window System to use the Guest Additions ...done.
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services components ...done.
Press Return to close this window..."

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: virtualbox 4.1.18-dfsg-1build1
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic i686
ApportVersion: 2.4-0ubuntu5
Architecture: i386
Date: Thu Aug 2 12:31:40 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
ProcEnviron:
 LANGUAGE=en_IN:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: virtualbox
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Vishnu Padmanabhan (vishnupadmanabhan) wrote :
Revision history for this message
Sasa Paporovic (melchiaros) wrote :

Hi Vishnu,

this is with high propability not a bug.

First you have not installed the latest kernel. You have Uname: Linux 3.5.0-6-generic i686.

In moment 3.5.0.7 is actual. So please install the latest updates for the whole system.

Second, as far as I remember all Ubuntu guest install guest additions from Canonical repositories by default(which not support shared folders).

When you do a manuall install with .iso you have to first remove the automatic installed additions.

And for investigation of what it is exactly it would be correct from you to do:

"(Look at /var/log/vboxadd-install.log to find out what went wrong)"

as you get from your system.

Sometimes some needed packages are missing and you can find it in this log.

I set it to invalid, because it is more likely that it is a case of missing packages/configurations.

You may whant to use

https://answers.launchpad.net/ubuntu

when you have questions on installing guest additions correctly.

When you disagree with my opinion feel free to reopen this report, but make sure that you have investigated the logfile before and give informations about. Please point out what exactly went wrong. And also please upgrade your system first on terminal:

sudo apt-get update

sudo apt-get dist-upgrade

Feel free to report any other bug you find. Thank you.

Changed in virtualbox (Ubuntu):
status: New → Invalid
Revision history for this message
Vishnu Padmanabhan (vishnupadmanabhan) wrote :

Hi melchiaros,

Thank you for your detailed response. I shall update my system again and see if the problem occurs. I shall make sure all packages are upgraded.

Thanks again.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers