vboxvideo kernel module fails to build with kernel 2.6.37

Bug #671883 reported by toobuntu on 2010-11-06
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
virtualbox-ose (Ubuntu)
Undecided
Felix Geyer

Bug Description

Binary package hint: virtualbox-ose

$ tail /var/lib/dkms/virtualbox-ose-guest/3.2.10/build/make.log
  LD /var/lib/dkms/virtualbox-ose-guest/3.2.10/build/vboxvideo/built-in.o
  CC [M] /var/lib/dkms/virtualbox-ose-guest/3.2.10/build/vboxvideo/vboxvideo_drm.o
/var/lib/dkms/virtualbox-ose-guest/3.2.10/build/vboxvideo/vboxvideo_drm.c:81:2: error: unknown field ‘get_map_ofs’ specified in initializer
/var/lib/dkms/virtualbox-ose-guest/3.2.10/build/vboxvideo/vboxvideo_drm.c:81:17: error: ‘drm_core_get_map_ofs’ undeclared here (not in a function)
/var/lib/dkms/virtualbox-ose-guest/3.2.10/build/vboxvideo/vboxvideo_drm.c:82:2: error: unknown field ‘get_reg_ofs’ specified in initializer
/var/lib/dkms/virtualbox-ose-guest/3.2.10/build/vboxvideo/vboxvideo_drm.c:82:17: error: ‘drm_core_get_reg_ofs’ undeclared here (not in a function)
make[2]: *** [/var/lib/dkms/virtualbox-ose-guest/3.2.10/build/vboxvideo/vboxvideo_drm.o] Error 1
make[1]: *** [/var/lib/dkms/virtualbox-ose-guest/3.2.10/build/vboxvideo] Error 2
make: *** [_module_/var/lib/dkms/virtualbox-ose-guest/3.2.10/build] Error 2
make: Leaving directory `/usr/src/linux-headers-2.6.37-2-generic'

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: virtualbox-ose-guest-dkms 3.2.10-dfsg-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-2.10-generic 2.6.37-rc1
Uname: Linux 2.6.37-2-generic x86_64
Architecture: amd64
Date: Sat Nov 6 12:41:58 2010
ErrorMessage: virtualbox-ose-guest kernel module failed to build
PackageArchitecture: all
PackageVersion: 3.2.10-dfsg-1ubuntu1
SourcePackage: virtualbox-ose
Title: package virtualbox-ose-guest-dkms 3.2.10-dfsg-1ubuntu1 failed to install/upgrade: virtualbox-ose-guest kernel module failed to build

Revision history for this message
toobuntu (toobuntu) wrote :
Felix Geyer (debfx) on 2010-11-06
summary: - package virtualbox-ose-guest-dkms 3.2.10-dfsg-1ubuntu1 failed to
- install/upgrade: virtualbox-ose-guest kernel module failed to build on
- 2.6.37-2
+ vboxvideo kernel module fails to build with kernel 2.6.37
Changed in virtualbox-ose (Ubuntu):
status: New → Confirmed
Revision history for this message
Aaron Haviland (aaron-haviland) wrote :

This appears to be fixed in current SVN: http://www.virtualbox.org/changeset/33754

Felix Geyer (debfx) on 2010-11-22
Changed in virtualbox-ose (Ubuntu):
assignee: nobody → Felix Geyer (debfx)
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose - 3.2.10-dfsg-2ubuntu1

---------------
virtualbox-ose (3.2.10-dfsg-2ubuntu1) natty; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Add Apport hook.
      - debian/virtualbox-ose.files/source_virtualbox-ose.py
      - debian/virtualbox-ose.install
    - Drop *-source packages.
    - Add ubuntu-01-fix-build-gcc45.patch to fix FTBFS due to uninitalized
      variables.
  * Fixes: vboxvideo module fails to build with kernel 2.6.37. (LP: #671883)
  * Fix FTBFS with --as-needed.
     - Add ubuntu-02-as-needed.patch from Gentoo.

virtualbox-ose (3.2.10-dfsg-2) unstable; urgency=low

  * Added two patches from virtualbox-ose SVN/bug tracking to fix some
    issues with kernels > 2.6.36. (Closes: #604259)
  * Moved program to utilities where it belongs.
  * Fixed typo in desktop file
 -- Felix Geyer <email address hidden> Mon, 22 Nov 2010 17:56:12 +0100

Changed in virtualbox-ose (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers