Please merge virtualbox-ose 3.1.6-dfsg-2 (universe) from Debian unstable (main)

Bug #549588 reported by eris23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virtualbox-ose (Ubuntu)
Fix Released
Wishlist
Daniel Hahler

Bug Description

Binary package hint: virtualbox-ose

VirtualBox 3.1.6 (released 2010-03-25)

This is a maintenance release. The following items were fixed and/or added:

    * Linux hosts: fixed timing issue on hosts with Linux kernels 2.6.31 or later with certain CPUs (asynchronous timer mode; bug #6250)
    * Linux hosts: properly handle host suspend/resume events on Linux kernels 2.6.30 or later (bug #5562)
    * Mac OS X hosts: fixed VBoxSVC crash while enumerating the host network interfaces under certain circumstances
    * Snapshots: fixed image corruption after snapshot merge under certain circumstances (bug #6023)
    * Snapshots: fixed crash with VBoxHeadless / OSE
    * VMM: fixed reference counting guru meditation (bug #4940)
    * VMM: improved guest SMP stability
    * VMM: fixed VT-x hardware debug issues (bugs #477 & #5792)
    * VMM: fixed PGMDynMapHCPage guru meditation (Mac OS X; VT-x only; bug #6095)
    * VMM: fixed pgmPoolTrackFlushGCPhysPTInt guru meditations (Mac OS X; VT-x only; bugs #6095 & #6125)
    * VMM: Fixed host crash when running PAE guests in VT-X mode (Mac OS X only; bug #5771).
    * GUI: fix displaying of error message (bug #4345)
    * GUI: fix inability to enter seamless mode (bugs #6185, #6188)
    * 3D support: fixed assertion and flickering when guest application uses several windows with a single OpenGL context (bug #4598)
    * 3D support: fixed host crashes when using GL_EXT_compiled_vertex_array and array element calls (bug #6165)
    * 3D support: fixed runtime linker errors with OpenGL guest libs (bug #5297)
    * 3D support: fixed OpenGL extension viewer crash on startup (bug #4962)
    * NAT: fixed a 3.1.4 regression on Windows hosts where graceful connection termination was broken (bug #6237)
    * NAT: alternative network setting was not stored persistent (bug #6176)
    * NAT: fixed memory corruption during ICMP traffic under certain circumstances
    * Network: allow to switch the host interface or the internal network while a VM is running (bug #5781)
    * VHD: fix for images with a block size different than 2MB
    * USB: fixed filtered device attach regression (bug #6251)
    * USB: fixed crash in OHCI under rare circumstances (bug #3571)
    * VRDP: fixed hang under rare circumstances when attaching USB devices
    * ACPI: prevent guest freezes when accessing /proc/acpi for determining the state of the host battery and the AC adapter (Linux hosts only; bug #2836)
    * PulseAudio: fixed guest freezes under certain conditions (3.1.4 regression; bug #6224)
    * BIOS: increased space for DMI strings
    * BIOS: fixed interrupt routing problem for certain configurations (I/O-APIC enabled, ACPI not used; bug #6098)
    * iSCSI: be more robust when handling the INQUIRY response
    * iSCSI: be more robust when handling sense data
    * BusLogic: fixed FreeBSD guests
    * webservice: vboxwebsrv is now multithreaded
    * Solaris Installer: fixed netmask to stay persistent across reboots for Host-only interface (bug #4590)
    * Linux installer: removed external dependency to libpng12.so (bug #6243)
    * Solaris Additions: fixed superfluous kernel logging (bug #6181)
    * Linux Additions: fixed hang when starting the X server in Fedora12 guests and in guests with Linux 2.6.33 or later (bug #6198)
    * Linux Additions: support Mandriva speedboot runlevel (bug #5484)
    * Linux Additions: fixed SELinux security context of mount.vboxsf (bug #6362)
    * Linux Additions: support Ubuntu 10.04 (bug #5737)
    * Web service: update PHP bindings to fix problems with enums and collections

Revision history for this message
Felix Geyer (debfx) wrote :

I'm working on merging the new version.

Changed in virtualbox-ose (Ubuntu):
assignee: nobody → Felix Geyer (debfx)
status: New → In Progress
Revision history for this message
Felix Geyer (debfx) wrote :

Please merge virtualbox-ose 3.1.6-dfsg-1 from Debian.
The Debian package has been uploaded but Debian's incoming queue is currently not processed.
The source package is available from http://people.debian.org/~meskes/virtualbox-ose_3.1.6-dfsg-1.dsc

Changelog entries since last upload to Ubuntu:

virtualbox-ose (3.1.6-dfsg-1ubuntu1) lucid; urgency=low

  * Merge from Debian unstable (LP: #549588), remaining changes:
    - VirtualBox should go in Accessories, not in System tools (LP: #288590)
      - debian/virtualbox-ose-qt.files/virtualbox-ose.desktop
    - Add Apport hook
      - debian/virtualbox-ose.files/source_virtualbox-ose.py
      - debian/virtualbox-ose.install
    - Add Launchpad integration
      - debian/control
      - debian/lpi-bug.xpm
      - debian/patches/u02-lp-integration.dpatch
    - Replace *-source packages with transitional packages for *-dkms

 -- Felix Geyer <email address hidden> Sat, 27 Mar 2010 18:06:35 +0100

virtualbox-ose (3.1.6-dfsg-1) unstable; urgency=low

  * New upstream version.
  * Drop 02-r27248.dpatch as it's applied upstream.
  * Use dh_lintian to install overrides.

 -- Felix Geyer <email address hidden> Fri, 26 Mar 2010 11:25:46 +0100

virtualbox-ose (3.1.4-dfsg-3) unstable; urgency=low

  [ Felix Geyer ]
  * Move virtualbox-ose-guest-x11 to section x11.
  * Replace 18-xorg-1.6.dpatch with a new patch that allows to easily
    switch to a different X Server version.
  * Remove /usr/share/virtualbox/x11config15.pl as we are at X Server 1.7.

  [ Michael Meskes ]
  * Apply upstream changeset 27248 to make virtualbox guest additions
    work with drm code in kernels 2.6.33+. (Closes: #574662)
  * Applied patch by nutzteil <email address hidden> to make init script
    consistent in (Closes: #574831)

 -- Michael Meskes <email address hidden> Tue, 23 Mar 2010 15:54:49 +0100

summary: - New upstream version available (3.1.6)
+ Please merge virtualbox-ose 3.1.6-dfsg-1 (universe) from Debian unstable
+ (main)
Changed in virtualbox-ose (Ubuntu):
assignee: Felix Geyer (debfx) → nobody
status: In Progress → Confirmed
Revision history for this message
Felix Geyer (debfx) wrote : Re: Please merge virtualbox-ose 3.1.6-dfsg-1 (universe) from Debian unstable (main)

Updated merge to version 3.1.6-dfsg-2 to use the new xserver xorg.conf.d/inputclass driver detection (bug #546933).
Debian package is available from http://people.debian.org/~meskes/virtualbox-ose_3.1.6-dfsg-2.dsc

Changelog entries since last upload to Ubuntu:

virtualbox-ose (3.1.6-dfsg-2ubuntu1) lucid; urgency=low

  * Merge from Debian unstable (LP: #549588), remaining changes:
    - VirtualBox should go in Accessories, not in System tools (LP: #288590)
      - debian/virtualbox-ose-qt.files/virtualbox-ose.desktop
    - Add Apport hook
      - debian/virtualbox-ose.files/source_virtualbox-ose.py
      - debian/virtualbox-ose.install
    - Add Launchpad integration
      - debian/control
      - debian/lpi-bug.xpm
      - debian/patches/u02-lp-integration.dpatch
    - Replace *-source packages with transitional packages for *-dkms
  * Mention the transitional status of the *-source packages in the long
    description to fix lintian warning empty-binary-package.

 -- Felix Geyer <email address hidden> Thu, 01 Apr 2010 14:42:00 +0200

virtualbox-ose (3.1.6-dfsg-2) unstable; urgency=low

  * Improve 20-hide-help-buttons.dpatch so all help buttons are hidden.
  * Set source format version explicitly to "1.0".
  * Adapt to xserver 1.8 input driver detection. (LP: #546933)
    - Add 10-vboxmouse.conf
    - Update virtualbox-ose-guest-x11.udev

 -- Felix Geyer <email address hidden> Wed, 31 Mar 2010 15:15:44 +0200

virtualbox-ose (3.1.6-dfsg-1) unstable; urgency=low

  * New upstream version.
  * Drop 02-r27248.dpatch as it's applied upstream.
  * Use dh_lintian to install overrides.

 -- Felix Geyer <email address hidden> Fri, 26 Mar 2010 11:25:46 +0100

virtualbox-ose (3.1.4-dfsg-3) unstable; urgency=low

  [ Felix Geyer ]
  * Move virtualbox-ose-guest-x11 to section x11.
  * Replace 18-xorg-1.6.dpatch with a new patch that allows to easily
    switch to a different X Server version.
  * Remove /usr/share/virtualbox/x11config15.pl as we are at X Server 1.7.

  [ Michael Meskes ]
  * Apply upstream changeset 27248 to make virtualbox guest additions
    work with drm code in kernels 2.6.33+. (Closes: #574662)
  * Applied patch by nutzteil <email address hidden> to make init script
    consistent in (Closes: #574831)

 -- Michael Meskes <email address hidden> Tue, 23 Mar 2010 15:54:49 +0100

summary: - Please merge virtualbox-ose 3.1.6-dfsg-1 (universe) from Debian unstable
+ Please merge virtualbox-ose 3.1.6-dfsg-2 (universe) from Debian unstable
(main)
Felix Geyer (debfx)
Changed in virtualbox-ose (Ubuntu):
assignee: nobody → Daniel Hahler (blueyed)
Daniel Hahler (blueyed)
Changed in virtualbox-ose (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Wishlist
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose - 3.1.6-dfsg-2ubuntu1

---------------
virtualbox-ose (3.1.6-dfsg-2ubuntu1) lucid; urgency=low

  * Merge from Debian unstable (LP: #549588), remaining changes:
    - VirtualBox should go in Accessories, not in System tools (LP: #288590)
      - debian/virtualbox-ose-qt.files/virtualbox-ose.desktop
    - Add Apport hook
      - debian/virtualbox-ose.files/source_virtualbox-ose.py
      - debian/virtualbox-ose.install
    - Add Launchpad integration
      - debian/control
      - debian/lpi-bug.xpm
      - debian/patches/u02-lp-integration.dpatch
    - Replace *-source packages with transitional packages for *-dkms
  * Mention the transitional status of the *-source packages in the long
    description to fix lintian warning empty-binary-package.
 -- Felix Geyer <email address hidden> Thu, 01 Apr 2010 14:42:00 +0200

Changed in virtualbox-ose (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers