Ubuntu

can't resume a state which was saved with the Jaunty version of virtualbox

Reported by Zooko Wilcox-O'Hearn on 2009-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Virtualbox
Fix Released
Unknown
virtualbox-ose (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: virtualbox-ose

I had the version of virtualbox-ose in Jaunty and created a virtual machine and installed Windows XP as guest and used it for along time. I always save the state when I'm done and resume from that state the next day.

Now that I've upgraded to Karmic I can't resume the state. When I try the progress bar marches up to 100% and then it says:

Failed to start the virtual machine wxp.
Unable to restore the virtual machine's saved state from '/home/zooko/.VirtualBox/Machines/wxp/Snapshots/{aaa9de2e-7d47-4baf-98f2-6726b3533cb4}.sav'. It may be damaged or from an older version of VirtualBox. Please discard the saved state before starting the virtual machine (VERR_SSM_LOAD_CONFIG_MISMATCH).

Details:

Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
Console
Interface:
IConsole {0a51994b-cbc6-4686-94eb-d4e4023280e2}

ProblemType: Bug
Architecture: amd64
Date: Fri Oct 9 14:53:20 2009
DistroRelease: Ubuntu 9.10
Package: virtualbox-ose 3.0.6-dfsg-1ubuntu1
ProcEnviron:
 LANGUAGE=
 LC_CTYPE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-2.17-generic
SourcePackage: virtualbox-ose
Uname: Linux 2.6.31-2-generic x86_64
VirtualBoxOse.DpkgList:
 ii virtualbox-ose 3.0.6-dfsg-1ubuntu1 x86 virtualization solution - base binaries
 ii virtualbox-ose-qt 3.0.6-dfsg-1ubuntu1 x86 virtualization solution - Qt based user
 ii virtualbox-ose-source 3.0.6-dfsg-1ubuntu1 x86 virtualization solution - kernel module

Zooko Wilcox-O'Hearn (zooko) wrote :
Changed in virtualbox:
status: Unknown → New
Zooko Wilcox-O'Hearn (zooko) wrote :

Here is how I worked-around this. First I uninstalled all virtualbox packages -- virtualbox-ose, virtualbox-ose-source, virtualbox-ose-qt, and virtualbox-guest-additions, then I uninstalled dkms. Then I changed my /etc/apt/sources.list to point to jaunty again instead of karmic. Then I ran sudo apt-get update. Then I rebooted into the jaunty Kernel (linux-image-2.6.28-15-generic) (which happened to still be installed). Then I installed virtualbox, dkms, and linux 2.6.28 source from Jaunty. Then I ran virtualbox and it said that the config files were of a new version that it didn't know how to read. It gave the location of the config files, so I ls'ed the directory and found that virtualbox 3.0 had made a backup copy of the old config files when ugprading the config files so I cp'ed the old config files back into place. Now virtualbox 2 (from Jaunty) was able to run and resume my guest. I shutdown the guest and made a snapshot and quit.
Then I uninstalled all virtualbox packages and dkms, changed my /etc/apt/sources.list to point to karmic again, ran sudo apt-get update again, then rebooted into the karmic kernel (which is now linux-image-2.6.31-12-generic although it was linux-image-2.6.31-2-generic when I started this). Then I installed virtualbox, dkms, and the linux source from karmic. Now I can boot my guest and it works! Successful workaround.

Changed in virtualbox:
status: New → Fix Released

Thank you for posting this bug.

As per upstream bug, this issue is fixed. Marking as such.

Changed in virtualbox-ose (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.