X fails post jaunty->karmic upgrade in xubuntu/virtualbox

Bug #439551 reported by Steve Beattie on 2009-09-30
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
virtualbox-ose (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

After jaunty->karmic xubuntu upgrade within a virtualbox guest (without any virtualbox guest utilities installed), X is broken (and due to bug 431166, attempts to restart over and over forever).

The likely culprit is that /etc/X11/xorg.conf is a 0 length file; indeed, removing the file completely causes X to start working again.

ProblemType: Bug
Architecture: i386
CurrentDmesg: [ 54.212072] eth0: no IPv6 routers present
Date: Wed Sep 30 11:42:44 2009
DistroRelease: Ubuntu 9.10
Lsusb: Error: command ['lsusb'] failed with exit code 1:
MachineType: innotek GmbH VirtualBox
Package: xorg 1:7.4+3ubuntu5
PciDisplay:
 00:02.0 VGA compatible controller [0300]: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef]
  Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
  Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
  Latency: 0
  Region 0: Memory at e0000000 (32-bit, prefetchable) [size=16M]
ProcCmdLine: root=/dev/mapper/jk--x--ia32-root ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu6
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
SourcePackage: xorg
Uname: Linux 2.6.31-11-generic i686
XorgConf:

dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
fglrx: Not loaded
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-11-generic
xkbcomp:
 Error: command ['xkbcomp', ':0', '-w0', '-'] failed with exit code 1: Error: Cannot open display ":0"
                   Exiting

Steve Beattie (sbeattie) wrote :
Bryce Harrington (bryce) on 2009-10-01
Changed in xorg (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-10-01
affects: xorg (Ubuntu) → virtualbox-ose (Ubuntu)
affects: virtualbox-ose (Ubuntu) → xorg (Ubuntu)
Kees Cook (kees) on 2009-10-01
affects: xorg (Ubuntu) → virtualbox-ose (Ubuntu)
affects: virtualbox-ose (Ubuntu) → ubuntu
affects: ubuntu → vlc (Ubuntu)
affects: vlc (Ubuntu) → virtualbox-ose (Ubuntu)
affects: virtualbox-ose (Ubuntu) → ubuntu
Kees Cook (kees) on 2009-10-01
affects: ubuntu → virtualbox-ose (Ubuntu)
Felix Geyer (debfx) wrote :

Reassigning to xorg-server.
The issue is that xorg-server doesn't fall back to vesa if xorg.conf exists but is empty.

affects: virtualbox-ose (Ubuntu) → xorg-server (Ubuntu)
Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
tags: added: jaunty
Steve Beattie (sbeattie) wrote :

Whatever it was that was causing xorg.conf to get truncated to 0 bytes has been fixed (though I suspect X still doesn't like that); however, virtualbox guest upgrades from jaunty to karmic without the virtualbox guest tools/drivers installed are result in an X server that fails, despite the existence of a seemingly okay xorg.conf file; see bug 457433 for details. Again, the workaround of removing the xorg.conf entirely causes X to start successfully.

Bryce Harrington (bryce) wrote :

mvo recently added some code to the installer to remove xorg.conf if it is 0-bytes, so this situation should not crop up as frequently in ordinary use.

I don't seem to have permission to view bug 457433, but will assume it sufficiently covers the virtualbox failure on upgrade, that we can consider this report closed. Note that virtualbox provides its own binary X drivers, compiled against a specific X version so if you upgrade xserver to a new major version without also upgrading virtualbox, I could imagine it would cause X crashes - but that's going to be a virtualbox bug rather than Xorg, since virtualbox just probably needs its drivers to depend on Xorg versions properly or something.

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Steve Beattie (sbeattie) wrote :

Bryce, sorry, the other virtualbox bug number was tyoped, it should be bug 457443. In neither of the these bug reports was the virtualbox guest drivers installed; jockey should probably suggest that.

It'd also be nice to know what's causing xorg.conf to get truncated to 0, even if papering over it in update-manager is sufficient for release.

tags: added: iso-testing
Bryce Harrington (bryce) on 2010-01-05
affects: xorg-server (Ubuntu) → virtualbox-ose (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers