Microphone not working in Windows XP guest

Bug #390318 reported by Paulo J. S. Silva on 2009-06-21
This bug affects 8 people
Affects Status Importance Assigned to Milestone
virtualbox-ose (Ubuntu)

Bug Description

Binary package hint: virtualbox-ose

1) Ubuntu version:

pjssilva@leia:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

2) Package version:

  Instalado: 2.1.4-dfsg-1ubuntu3
  Candidato: 2.1.4-dfsg-1ubuntu3
  Tabela de versão:
 *** 2.1.4-dfsg-1ubuntu3 0
        500 http://archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

3) Expected behavior: microphone should work in Windows XP guest if virtualbox-ose is configured to use pulseaudio or alsa.

4) What happens: microphone sound is very garbled when using pulse audio. The voice is very truncated and it is very hard do understand. I tested using the windows voice recorder and skype (skype notes that the voice is garbled and simply cut off the microphone). If I use alsa, the sound is better but there are still click sounds and some noise.

Atanas Atanasov (thenasko) wrote :

I have a similar problem. Pulseaudio does not work at all (the microphone is silent), whereas ALSA gives a lot of noise. It is impossible to tell I am speaking when using ALSA. The microphone and audio setup in Linux works well with other applications (e.g. Skype).

Changed in virtualbox-ose (Ubuntu):
status: New → Confirmed
Nils (loewen-nils) wrote :

Host: 9.04 64 bit, Guest: Windows 7 32 bit

In Ubuntu sound and recording are fine. Windows 7: sound works fine but no recording, neither ALSA nor pulseaudio when chosen in virtualmachine sound settings.

VF (fviktor) wrote :

Host: Ubuntu 9.04 64 bit, 8Gbytes RAM, Intel Q6600 CPU (4 cores) @ 2.88GHz
VirtualBox 3.0.4 from its own repositories.
Guest: Windows Server 2003 with XP look and feel
Virtual sound card: ICH AC97
Guest Additions are installed.

Both sound and microphone is working fine in the host OS. Both ALSA and Pulseaudio are working fine.

With VirtualBox and the above guest ALSA gives me only garbled sound and a completely noisy, totally unusable microphone. Using Pulseaudio results in almost perfect sound, but the microphone is still unusable, cropped and almost as noisy as with ALSA.

I don't know what can be the problem in this case. Maybe the guest and the host do not agree in the size of sound samples (8 or 16 bit, mono or stereo) and the virtual DMA is set up the wrong way, I'm not sure. But it seems to be clearly a data format negotiation issue.

I haven't tried the virtual Sound Blaster 16 yet...

DChill (dchill42) wrote :

I found that the combination of OSS and ICH did the trick.

ALSA gave me lots of output glitches, as cited above.
PulseAudio provided no microphone.
SoundBlaster 16 did not work at all.

I am running Ubuntu 9.04 amd64 with VirtualBox 3.04 and Windows XP guest. With this setup, Rosetta Stone FINALLY worked without a hitch. :)

I hope this information helps someone else - I spent days trying to figure out how to fix this.

pernikovka (jichalou) wrote :

I have same problem on Ubuntu 9.10

With pulseaudio I have perfect sound in Virtualbox (windows XP), but microphone doesn't work properly.

uname -a
Linux perniknb 2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:54:29 UTC 2009 i686 GNU/Linux

Please let me know your suggestion for fix it.

Joar Jegleim (joar-jegleim) wrote :


had the same problem in Ubuntu 9.10 64bit .
Uninstalling pulseaudio and the mic is ok in my windows xp guest.

I had to do a
apt-get purge pulseaudio gstreamer0.10-pulseaudio + the rest of my packages related to pulse (found via dpkg -l | grep pulse),
except i still got libpulse-browse0 libpulse-mainloop-glib0 and libpulse0
Apt tells you it's removing ubuntu-desktop as well, which probably is because ubuntu-desktop got pulse as a dependency or something. I find that apt-get doesn't remove as much as aptitude wants to, so I used apt-get for this one.

I also installed gnome-alsamixer alsa alsa-firmware-loaders alsa-tools alsa-tools-gui
and reboot

note: volume control (in tray) and 'system -> preferences -> sound' in gnome is now broken, but I kan control sound via gnome-alsamixer

pernikovka (jichalou) wrote :

Hi Joar,
Thanks for your update.... but I would like to fix this issue with using pulseaudio. I think that Ubuntu will use pulseaudio in future and it's not clean way to uninstall pulseaudio and use "alsa".
I have one more notice. I tried to use USB microphone (web camera) and with one the problem was some, but with another one microphone works fine, so let me know if someone have the same experience? or is someone who know which USB device works fine generally?
Thanks for your advice.


DiGitalX (chmod) wrote :

DCHill, I've chose the combination of yours (OSS + ICH) but the mic still not working !
I'm on ubuntu 9.10 AMD64 + VirtualBox 3.0.8

pernikovka (jichalou) wrote :

DiGitalX, I have the same problem. For me also doesn't work combination (OSS + ICH).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers