Ubuntu

Dangling symlink /usr/src/vboxdrv-2.2.2 caused by installing virtualbox-2.2, virtualbox-ose-source, then virtualbox-ose

Reported by Daniel Hahler on 2009-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Virtualbox
New
Unknown
virtualbox-ose (Debian)
Fix Released
Unknown
virtualbox-ose (Ubuntu)
Undecided
Daniel Hahler

Bug Description

Binary package hint: virtualbox-ose

I've installed virtualbox-2.2, which removed virtualbox-ose and apparently it created (or only touched) a dangling/wrong symlink:
  /usr/src/vboxdrv-2.2.2 -> ../share/virtualbox/src/vboxdrv

There might be something in the removal process of one of the 2.2.2-dfsg-2ubuntu1 packages or in the installation of virtualbox-2.2 (from virtualbox.org), which created (or only touched) this (and caused later problems when installing virtualbox-ose/virtualbox-ose-source again, which uses that directory for installation (and caused DKMS to fail)).

I have unfortunately already removed the link and have no seconds for its timestamp.

I could reproduce this as follows:
1. Remove virtualbox-ose-source
2. Install virtualbox-2.2, this will install a symlink: /usr/src/vboxdrv-2.2.2 -> ../share/virtualbox/src/vboxdrv
3. "dpkg -i" virtualbox-ose-source, virtualbox-ose, virtualbox-ose-qt
4. This will install virtualbox-ose-source, _then_ remove virtualbox-2.2 (which leads to the problem)

Proposed solution:
Make virtualbox-ose-source conflict with the virtualbox.org virtualbox-x packages.

/var/log/dpkg.log:
2009-05-24 01:04:32 startup packages remove
2009-05-24 01:04:32 status installed virtualbox-ose-qt 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 remove virtualbox-ose-qt 2.2.2-dfsg-2ubuntu1 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status half-configured virtualbox-ose-qt 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status half-installed virtualbox-ose-qt 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status triggers-pending menu 2.1.41ubuntu1
2009-05-24 01:04:33 status half-installed virtualbox-ose-qt 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status triggers-pending desktop-file-utils 0.15-2ubuntu1
2009-05-24 01:04:33 status half-installed virtualbox-ose-qt 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status triggers-awaited menu 2.1.41ubuntu1
2009-05-24 01:04:33 status config-files virtualbox-ose-qt 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status config-files virtualbox-ose-qt 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status installed virtualbox-ose 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 remove virtualbox-ose 2.2.2-dfsg-2ubuntu1 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status half-configured virtualbox-ose 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status half-installed virtualbox-ose 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status config-files virtualbox-ose 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 status config-files virtualbox-ose 2.2.2-dfsg-2ubuntu1
2009-05-24 01:04:33 trigproc menu 2.1.41ubuntu1 2.1.41ubuntu1
2009-05-24 01:04:33 status half-configured menu 2.1.41ubuntu1
2009-05-24 01:04:35 status installed menu 2.1.41ubuntu1
2009-05-24 01:04:35 trigproc desktop-file-utils 0.15-2ubuntu1 0.15-2ubuntu1
2009-05-24 01:04:35 status half-configured desktop-file-utils 0.15-2ubuntu1
2009-05-24 01:04:35 status installed desktop-file-utils 0.15-2ubuntu1
2009-05-24 01:04:37 startup archives unpack
2009-05-24 01:04:38 install virtualbox-2.2 <keine> 2.2.2-46594_Ubuntu_jaunty
2009-05-24 01:04:38 status half-installed virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty
2009-05-24 01:04:49 status triggers-pending desktop-file-utils 0.15-2ubuntu1
2009-05-24 01:04:49 status half-installed virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty
2009-05-24 01:04:51 status unpacked virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty
2009-05-24 01:04:51 status unpacked virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty
2009-05-24 01:04:51 trigproc desktop-file-utils 0.15-2ubuntu1 0.15-2ubuntu1
2009-05-24 01:04:51 status half-configured desktop-file-utils 0.15-2ubuntu1
2009-05-24 01:04:51 status installed desktop-file-utils 0.15-2ubuntu1
2009-05-24 01:04:53 startup packages configure
2009-05-24 01:04:53 configure virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty 2.2.2-46594_Ubuntu_jaunty
2009-05-24 01:04:53 status unpacked virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty
2009-05-24 01:04:56 status unpacked virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty
2009-05-24 01:04:56 status half-configured virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty
2009-05-24 01:06:24 status installed virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty

ProblemType: Bug
Architecture: i386
Date: Sun May 24 03:18:16 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: virtualbox-ose 2.2.2-dfsg-2ubuntu2
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-5.6-generic
SourcePackage: virtualbox-ose
Uname: Linux 2.6.30-5-generic i686
UnreportableReason: Das Paket stammt nicht von Ubuntu.
VirtualBoxOse.DpkgList:
 ic virtualbox-2.2 2.2.2-46594_Ubuntu_jaunty Sun VirtualBox
 ii virtualbox-ose 2.2.2-dfsg-2ubuntu2 x86 virtualization solution - base binaries
 ii virtualbox-ose-qt 2.2.2-dfsg-2ubuntu2 x86 virtualization solution - Qt based user
 ii virtualbox-ose-source 2.2.2-dfsg-2ubuntu2 x86 virtualization solution - kernel module
modified.conffile..etc.vbox.vbox.cfg: [deleted]

Daniel Hahler (blueyed) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose - 2.2.2-dfsg-2ubuntu2

---------------
virtualbox-ose (2.2.2-dfsg-2ubuntu2) karmic; urgency=low

  [ Felix Geyer ]
  * Install virtualbox-ose-source udev rules
    - debian/rules
  * Add missing vboxuser udev rule and fix permissions for
    vboxadd (Closes: #530302)
    - debian/virtualbox-ose-guest-source.udev
  * Auto-detect mouse driver by installing HAL device information
    (Closes: #530299)
    - debian/virtualbox-ose-guest-x11.install

  [ Daniel Hahler ]
  * Remove usage/references to /etc/vbox/vbox.cfg (as handled
    upstream) (LP: #280973).
    This prevents "Could not find VirtualBox installation.
    Please reinstall." error, after having installed the
    upstream debian package.
    - debian/virtualbox-ose.files/VBox.sh: do not source
      vbox.cfg anymore.
    - Delete debian/virtualbox-ose.files/vbox.cfg
    - debian/virtualbox-ose.preinst: remove vbox.cfg on
      upgrades.
  * Move debian/virtualbox-ose.udev => virtualbox-ose-source.udev,
    to complement virtualbox-ose-guest-source.udev.
  * virtualbox-ose-source: conflict with virtualbox.org packages
    (LP: #379878).
    - debian/control

 -- Daniel Hahler <email address hidden> Sun, 24 May 2009 02:22:17 +0200

Changed in virtualbox-ose (Ubuntu):
status: New → Fix Released
Daniel Hahler (blueyed) wrote :

This fix was dumb, sorry: we should not conflict with something we provide ourself.
Since virtualbox-ose-source does not really provide virtualbox etc, I've looked into "Replaces" instead, but which did not work (same result; probably due to the symlink).

I'm going to rollback the Conflicts and file an upstream bug instead, that they should "Provide: virtualbox-source" (which they actually are doing).

Another way out of this might be to remove the "Provides" for virtualbox-2* (I'm unsure about if that makes actually much sense, and/or gives any benefit) and re-add the conflict. To be discussed.

Changed in virtualbox-ose (Ubuntu):
assignee: nobody → Daniel Hahler (blueyed)
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose - 2.2.2-dfsg-2ubuntu3

---------------
virtualbox-ose (2.2.2-dfsg-2ubuntu3) karmic; urgency=low

  * Rollback my last change in the last upload: do not conflict
    with packages we're providing ourselves (LP: #379878).
    - debian/control

 -- Daniel Hahler <email address hidden> Mon, 25 May 2009 01:02:11 +0200

Changed in virtualbox-ose (Ubuntu):
status: In Progress → Fix Released
Changed in virtualbox:
status: Unknown → New
Changed in virtualbox-ose (Debian):
status: Unknown → New
Changed in virtualbox-ose (Debian):
status: New → Incomplete
Changed in virtualbox-ose (Debian):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.