Pulling Xorg virtualbox support by default

Bug #348497 reported by Loïc Minier on 2009-03-25
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
virtualbox-ose (Ubuntu)
Wishlist
Unassigned
xorg (Ubuntu)
Wishlist
Unassigned
xorg-server (Ubuntu)
Wishlist
Unassigned

Bug Description

Hi,

Out of the box, Ubuntu images have support for the vmware video driver; I wish we would have support for virtualbox mouse and video output as well.

I think this involves splitting the Xorg drivers out into their own packages and pulling them in xserver-xorg-video-all.

Bye

Related branches

Matt Zimmerman (mdz) on 2009-03-25
Changed in virtualbox-ose (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Felix Geyer (debfx) wrote :

This would require splitting the guest additions into 5 packages:
virtualbox-ose-guest-utils - shared folders, time syncing [depends on virtualbox-ose-guest-source]
virtualbox-ose-guest-x11 - shared clipboard, seamless mode, auto-resize [depends on virtualbox-ose-guest-source]
virtualbox-ose-guest-source - kernel module (dkms)
xserver-xorg-video-virtualbox-ose / xserver-xorg-video-vbox - X.Org video driver
xserver-xorg-input-virtualbox-ose / xserver-xorg-input-vbox - X.Org mouse driver

Also virtualbox-ose would have to be moved to main.

Should I work on implementing this change or are there objections/required changes?

Jonathan Marsden (jmarsden) wrote :

I'd say go for it! Like you, I'd be very happy to see the virtualbox video driver in the default image.

Bryce Harrington (bryce) wrote :

Hi lool,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xorg (Ubuntu):
status: New → Incomplete
Felix Geyer (debfx) wrote :

This isn't really a bug in X.Org :-)
What's your opinion on including VirtualBox in the packages xserver-xorg-input-all and xserver-xorg-video-all?

Changed in xorg (Ubuntu):
status: Incomplete → New
tags: removed: needs-lspci-vvnn needs-xorglog
Bryce Harrington (bryce) wrote :

Setting to wishlist, else the scripts will keep asking for those files... ;-)

Changed in xorg (Ubuntu):
importance: Undecided → Wishlist
Bryce Harrington (bryce) wrote :

(which I know Loic loves)

Bryce Harrington (bryce) wrote :

> What's your opinion on including VirtualBox in the packages xserver-xorg-input-all and xserver-xorg-video-all?

I'm not opposed to it, as long as someone will care for maintaining the drivers and bug reports filed against them.

Felix Geyer (debfx) wrote :

I just noticed that the mouse driver doesn't work without the kernel module.
The video driver runs in "compatibility mode", which means that seamless mode, auto-resizing and graphics acceleration don't work.

Bryce Harrington (bryce) wrote :

There is an xserver task here in that xserver needs to automatically detect and use the 'vboxvideo' driver when VirtualBox Graphics Adapter [80ee:beef] is present. I'll have a patch for this bit in shortly.

Changed in xorg-server (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Felix Geyer (debfx) wrote :

I already filed bug #417616 that contains a patch for this.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.6.3-1ubuntu4

---------------
xorg-server (2:1.6.3-1ubuntu4) karmic; urgency=low

  * Add 184_virtual_devices_autodetect.patch: Automatic driver detection
    for vbox and kvm for non-cirrus devices.
    (LP: #338219, #348497)

 -- Bryce Harrington <email address hidden> Mon, 24 Aug 2009 14:58:22 -0700

Changed in xorg-server (Ubuntu):
status: Triaged → Fix Released
Loïc Minier (lool) wrote :

Failed to build but just given back

Bryce Harrington (bryce) on 2009-11-02
Changed in xorg (Ubuntu):
status: New → Triaged
tags: added: iso-testing
Bryce Harrington (bryce) wrote :

I talked with Dustin about this at UDS. KVM is the preferred standard default for virtualization. virtualbox is currently a universe component, and it would need to be included in main before we could consider including support for it for X by default.

Further, giving the large number of vbox X bug reports we've seen, I would want to see a vbox person identified to handle all these bug reports as I unfortunately wouldn't have time to give them adequate attention myself.

Changed in xorg (Ubuntu):
status: Triaged → Won't Fix
Felix Geyer (debfx) wrote :

I don't think there is much benefit in including the vbox video driver without the kernel module.
However in oneiric Jockey will detect the virtualbox guest additions.

Changed in virtualbox-ose (Ubuntu):
status: Triaged → Won't Fix
Jonathan Marsden (jmarsden) wrote :

I think kvm and virtualbox support rather different use cases:

  * kvm for serious server virtualization by people who know what they are doing

  * virtualbox for easy desktop virtualization for end users who do not care about how it works underneath and will probably only want one or two simultaneous VMs per host machine.

If Ubuntu is effectively rejecting virtualbox in favor of kvm, work needs to be done to make kvm much easier to set up and use for common desktop/GUI VM use. Is there a blueprint for a GUI for kvm that is at least as easy to use for end users on a desktop machine as virtualbox? Or does such a GUI exist already?

Felix Geyer (debfx) wrote :

The problem is that the vbox guest kernel modules are not part of the mainline kernel which means they can't be installed by default.
However for oneiric I'll try to get them installed when you select the third-party software checkbox in the installer.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers