virtualbox-ose checks for updates from virtualbox website, not from repositories

Bug #272212 reported by Hew on 2008-09-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virtualbox-ose (Debian)
Fix Released
Unknown
virtualbox-ose (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: virtualbox-ose

File -> Preferences -> Update is a section that checks for virtualbox updates from the virtualbox website itself, and is enabled by default. This section and functionality should be removed since Ubuntu handles updates through the repositories.

virtualbox-ose/intrepid uptodate 2.0.2-dfsg-0ubuntu2

-Zeus- (matthew-momjian) wrote :

Confirmed. setting status.

Changed in virtualbox-ose:
status: New → Confirmed
Daniel Hahler (blueyed) on 2008-09-19
Changed in virtualbox-ose:
assignee: nobody → blueyed
importance: Undecided → Medium
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose - 2.0.2-dfsg-0ubuntu3

---------------
virtualbox-ose (2.0.2-dfsg-0ubuntu3) intrepid; urgency=low

  * debian/patches/13-disable-update-action.dpatch:
    Disable update action menu entry (LP: #272212)

 -- Daniel Hahler <email address hidden> Fri, 19 Sep 2008 23:33:32 +0200

Changed in virtualbox-ose:
status: In Progress → Fix Released
-Zeus- (matthew-momjian) wrote :

well, that was a fast bug fix. Thanks for the report, and thank you for the fix, Daniel.

Hew (hew) wrote :

This is not fixed. I just started virtualbox-ose and it prompted me to upgrade to 2.0.4! It is unacceptable to have users prompted to replace software from the Ubuntu repository with other versions from an external source. The update section needs to be entirely removed from the virtualbox preferences.

I assume what the last fix did was to clear the updates checkbox for new installations. My upgraded installation was not fixed, and the tick remains. Setting importance to High since many, if not all virtualbox-ose users could experience this problem which may break virtualbox if the upgrade is performed.

Changed in virtualbox-ose:
importance: Medium → High
status: Fix Released → New
Daniel Hahler (blueyed) wrote :

Well, I had only disabled the menu item for manual updates.
I'll look into improving the patch to disable the "check for updates" procedure altogether.

Changed in virtualbox-ose:
status: New → In Progress
Daniel Hahler (blueyed) wrote :

Fix included in the debdiff for bug 288957 (waiting for FF exception).

Changed in virtualbox-ose:
assignee: blueyed → nobody
status: In Progress → Triaged
Hew (hew) wrote :

The fix works well, the section is greyed out and the checking is disabled. Ideally the whole "Update" section just wouldn't exist, but this is good enough and stops people from grabbing external versions which is the big problem. Thanks again for your prompt fix, hopefully it will be accepted before release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose - 2.0.4-dfsg-0ubuntu1

---------------
virtualbox-ose (2.0.4-dfsg-0ubuntu1) intrepid; urgency=low

  [ Jonathan Ernst ]
  * Virtualbox should go in Accessories, not in System tools (LP: #288590)

  [ Daniel Hahler ]
  * New upstream version (LP: #288957)
    - Updated debian/patches/09-initscript.dpatch (one hunk rejected/obsolete)
  * Drop debconf question about losing snapshots because of upgrading: it is
    no longer relevant and the default (cancel upgrade) caused a lot of
    trouble (LP: #288178, #221736)
    - debian/virtualbox-ose.preinst.in, debian/virtualbox-ose.templates,
      debian/rules
  * Improve patch for disabling the "check for updates" dialog (LP: #272212)
    - debian/patches/13-disable-update-action.dpatch
  * Disable registration request at Sun (LP: #285684, #271603)
    - debian/patches/14-disable-registration-request.dpatch

 -- Daniel Hahler <email address hidden> Sun, 26 Oct 2008 02:23:42 +0100

Changed in virtualbox-ose:
status: Triaged → Fix Released
Changed in virtualbox-ose (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.