Ubuntu

virtualbox does not redraw background in seamless/compiz mode

Reported by Rocko on 2008-05-15
58
This bug affects 6 people
Affects Status Importance Assigned to Milestone
virtualbox-ose (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: virtualbox-ose

When

a) virtualbox is in seamless mode via the File / Seamless Mode option;

b) and compiz is enabled;

c) and all of virtualbox's windows are minimized so that only the task bar is shown;

then virtualbox does not redraw the screen background properly.

In this case, I am running windoze XP, and if I click on the XP start menu, it draws it, but when I click again to minimize it, the menu remains visible (although it has been minimized).

If I then click on the virtualbox icon, it displays a corrupted background (ie a combination of random pixels and windows that were being displayed earlier).

It works correctly if you have at least one (XP) window non-minimized.

Version info:

ubuntu 8.04 (amd64)
virtualbox 1.5.6-dfsg-6ubuntu1
compiz 1:0.7.4-0ubuntu6

Guido Conaldi (guido-conaldi) wrote :

I can confirm the issue on my 64bit hardy.

Tyler Fenby (schitso) wrote :

Confirmed on 32 bit Hardy using XP Pro.

Confirmed on 32 bit Hardy using XP Pro, and virtualbox 1.6

VladimirCZ (vlabla) wrote :

I can confirm the same with virtualbox-ose (1.5.6) on 64bit hardy.

In addition to it: When I minimize any MS Windows application its window stay on screen and its title bar is dim (windows is inactive). When I scroll to another workspace and then back the orphaned window residuum is not there anymore.

!!! After I switch off compiz effects the Virtualbox seamless mode works without problems. !!!

I have tried to switch off only some compiz elements via CompizConfig Settings Manager (like Fading Windows, Animations), but with no positive effects - I mean both above mentioned failure modes have not disappeared.

stinkinrich88 (stinkinrich88) wrote :

confirmed for the non-OSE version (Sun) 1.6.2 with Hardy 64bit. There is no problem if compiz is disabled.

Daniel T Chen (crimsun) on 2008-09-08
Changed in virtualbox-ose:
importance: Undecided → Low
status: New → Confirmed
VladimirCZ (vlabla) wrote :

I have found a work-around effective even though the Compiz is running.

The principle (for M$ Windows running in the seamless mode under VirtualBox):

"As long as you keep some M$ Windows application window open you can minimize and restore other Windows applications without any problems with their proper redrawing. "

To reproduce that you may try and install e.g. the following little analog clock into your Windows virtual machine:
 http://www.gljakal.com/clock/index.php
The clock will stay running and visible on the Gnome workspace where you have the seamless desktop. An all other apps windows will work right.

Perhaps, this can also help to track where this bug has its cause.

Rocko (rockorequin) wrote :

I've found using the non-OSE VirtualBox 2.0.2 amd64 version that:

* XP in a VM still has this problem, although if you move the mouse over the XP task bar, after a second the Ubuntu desktop returns (as soon as you move it away from the taskbar, the XP desktop background redraws itself).

* Vista in a VM works correctly in seamless mode with compiz on (so long as I don't have XP running in another VM). Vista of course is so slow as to be almost unusable compared to XP.

Balaji (balaji-ramasubramanian) wrote :

I confirm this bug in Ubuntu 8.10, with Compiz and VirtualBox 2.0.4 with Windows Xp. The same problem is also found in Ubuntu 8.04 with/without Compiz and VirtualBox 2.0.4 with Windows Xp.

What debug information should I provide?

Tibault Damman (tibault-damman) wrote :

I can also confirm this on intrepid, with VirtualBox_OSE 2.04.

There's a good workaround here: http://www.tr-studios.com/2008/05/gnome-compiz-virtualbox-seamless-window.html
Basically it's a "small .NET application that will force an open window into the upper left hand corner of the screen, with 1x1 pixel visible on the desktop, which seems to satisfy the seamless desktop functionality and allows things to function normally. The window does not provide any kind of functionality, and is not available through the taskbar, in order to kill it off you must kill the process through task manager."

Just put it in your startup folder and you're good to go.

It'd still be nice to get a proper fix though :-)

ToMikaa (tomikaa87) wrote :

I have the same problem with Intrepid i386 + Compiz + VBox OSE. The article you have mentioned is fine but the little application is not found on the server.

Can somebody give a link to the application?

Adam Guthrie (ispiked) wrote :

ToMikaa,

I'm attaching a copy I had saved locally.

Alistair Buxton (a-j-buxton) wrote :

The supplied workaround is not a complete fix because the same thing happens if the guest's desktop is completely obscured by windows.

Alistair Buxton (a-j-buxton) wrote :

For those who don't want to install .NET, I have rewritten the workaround in Win32/C: http://al.robotfuzz.com/~al/vbwc/

Silvio Sisto (sistoviejo) wrote :

I have a similar problem which is probably related to this bug. I'm running a Windows XP guest and an Ubuntu (with compiz) host. When I don't have any open windows on the guest, my gnome-panels aren't visible on the host. The same thing happens if I maximize a window on the guest.

I have to open a window in the guest (or "restore" any maximize windows) for the panels to reappear in the host. The proposed workaround only works when I don't have any maximized windows on the guest. Replacing the window manager with metacity solves the problem completely. Could this bug be related to compiz?

Silvio Sisto (sistoviejo) wrote :

The issue is present with metacity if you enable compositing.
Maybe it could be an incompatibility of virtualbox towards compositing window managers or 3d acceleration in general. Maybe it's specific to nvidia cards? I have an nvidia card.

This also happens with virtualbox 3.0.0 in Ubuntu 9.04, It is not specific to nvidia cards, it happens with ati cards too.

Milos M (milos-miljkovic) wrote :

I can confirm this. Ubuntu 9.04 64-bit, virtualbox 3.0.2, Compiz is off, NVIDIA Quadro FX 1700.

William Davis (hotshotdj) wrote :

Also can confirm this bug
 - Ubuntu 9.04 32 bit, Virtualbox 3.0.2 (from sun's Virtualbox repository
 - Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03).
 - Guest OS = Windows XP Pro
 - Compiz on

gidantribal (aedo999) wrote :

I can confirm this bug too...

gidantribal (aedo999) wrote :

I also have a redraw issue when a host application is in fullscreen mode...

gidantribal (aedo999) wrote :

i have a NVIDIA card too...

gidantribal (aedo999) wrote :

not solved in Koala Karmic x64

Rocko (rockorequin) wrote :

@gidantribal: I think it's not solved for you in Karmic because it's a VirtualBox guest driver issue rather than an Ubuntu issue. With the 3.0.10 or 3.1beta guest drivers installed in my XP box, seamless mode works properly now, ie as compared to the original bug report, meaning the screen is redrawn correctly if I close all the XP windows. I did notice some artifacts when moving windows around, though.

Alistair Buxton (a-j-buxton) wrote :

I no longer get this under Karmic. I didn't update the guest drivers or anything else except upgrade to Karmic and let the automatic converter update the VMs on first run. Still, I no longer get the fullscreen issue. I'm using an Nvidia card with their driver.

William Davis (hotshotdj) wrote :

This bug was fixed long ago upstream in VirtualBox. Probably safe to mark as fixed or invalid.

Felix Geyer (debfx) on 2010-06-20
Changed in virtualbox-ose (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers