Ubuntu

I can't use accents in guests installed on VirtualBox (Hardy)

Reported by STaRMaN on 2008-04-14
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Virtualbox
Fix Released
Unknown
virtualbox-ose (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: virtualbox-ose

Hello,

I had installed virtualbox-ose in hardy, from repositories

Architecture: i386
Version: 1.5.6-dfsg-6ubuntu1

But guests intalled can't use accents, in spanish keyboard, i can't use "á é ... or ` ", in linux guest and windows guest.
in virtualbox there is a Ticket about this ( http://www.virtualbox.org/ticket/599 ), maybe related with libqt dependences in hardy?

This problem in giving me headatche , i need the ` in my linux guest for bash scripting programing...

STaRMaN (jarizaro) wrote :

I solved this problem in Kubuntu Hardy selecting in KDE->System Configuration -> Language-> Keyboard : Keyboard spanish, es. And selecting the checkbox which says "Incluir diseño latino", in english will be "include latin design/layout".

Note: The checkbox only appears when you mark your language in right column.

All this for spanish of spain language, and virtualbox 1.5.6 included with hardy.

Appears working with german too.

For more info look this thread in virtualbox.org:
             http://www.virtualbox.org/ticket/599#comment:117

Daniel Hahler (blueyed) on 2008-04-17
Changed in virtualbox-ose:
importance: Undecided → Medium
status: New → Triaged
Changed in virtualbox:
status: Unknown → New

Same problem with a Brazilian ABNT2 keyboard: The keyboard works OK under Hardy but accents don't show on a WIndows XP guest on VBOX, no matter what the configuration on the guest is.

Trainclock (ivandpais) wrote :

And any solution for Gnome, please??

STaRMaN (jarizaro) wrote :

Try executing in console:
setxkbmap -model pc105 -layout es,us

"es" if for spanish (español), put you language instead "es". The trick is the last ",us" (i think).

If this work in gnome give us feedback :)

Trainclock (ivandpais) wrote :

Thank you for your answer, but it doesn't work in gnome. The problem continue...

Ricardo Pérez López (ricardo) wrote :

I've the same problem, and I can confirm that the STaRMaN's solution doesn't work for me.

Ricardo Pérez López (ricardo) wrote :

I forgot to say that I'm using GNOME, not KDE.

STaRMaN (jarizaro) wrote :

This solutions appears don't work with gnome... sorry.
It worked to me in kde.

corvis (asasilva) wrote :

In Gnome just go to System -> Administration -> Language Support and click on "Enable support to enter complex characters".
After a reboot it should work just fine.

STaRMaN (jarizaro) wrote :

It's great have a solution for gnome users too. Thanks corvis :)

efege (fjgomez) wrote :

I applied corvis's suggestion. And now all I got is... the keyboard has stopped working under my Windows guest! Not only accent keys, but *all* keys are "disabled".

Jose (josea.munoz) wrote :

In my case also. Keyboard is not working at all in my Windows guest :(

Jose (josea.munoz) wrote :

As a workaround, in the scim-gnome-applet, select exit before starting the virtualbox machine.

In my case I also select the option "Share the same input method among all applications" in SCIM under FrontEnd - Global Setup

Jose (josea.munoz) wrote :

After installing Package scim-qtimm, it works fine for me.

hdante (hdante) wrote :

I have the same problem here.

Tiago Pereira (tiago-bmp) wrote :

Hey, I think I have found a solution... it may seem really simple but it now works for me... When you are running the virtual machine if you press the right Ctrl key the accents start working. So I went to File->Preferences (in the main virtualbox window) then selected "entry" and checked out the box saying Auto-Capture Keyboard. Restarted the virtual machine.

After that it always works fine until you press the right Ctrl key... But if you press it again it will work fine again...

I am using Ubuntu 8.04 with a portuguese keyboard and virtualbox 1.6.2

Ivà Burgos (ivaburgos) wrote :

I can confirm that Tiago Pereira said. I'm using Ubuntu 8.04 with an spanish keyboard and virtualbox 1.6.2

gwi (george-willegers) wrote :

With the right Ctrl key (the default 'host key' as VirtualBox calls it) you are just switching between capturing and not capturing the keyboard inside the virtual machine.
VirtualBox's keyboard handling is buggy, and the dead keys problem is just one of them.
Another one: not capturing the keyboard really means 'capture some keys in the guest, but let the host handle some other keys'. Thanks to this bug you can use the dead keys in your guest: switch off keyboard capturing, and suddenly the guest handles the dead keys the way it should have done with the keyboard capturing switched on. To add to the confusion: with keyboard capture switched off, keys like alt-Tab and alt-F4 are handled by the host, while Tab is handled by the guest... are you still there?
So this is a VirtualBox problem, not an Ubuntu problem.

Muanis (muanis) wrote :

Confirmed here too.

Host: Ubuntu Hardy Heron 8.04 running VirtualBox 1.6.6
Guest: same 8.04

Can't use accents until disable "host key", after that works fine until you press it again.

Changed in virtualbox:
status: New → Fix Released

This is fixed in Jaunty. Thanks for reporting.

Changed in virtualbox-ose:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.