Ubuntu

virtualbox cannot initiate due to vboxdrv missing from kernel modules [x86/hardy]

Reported by Kristian Erik Hermansen on 2008-01-02
30
Affects Status Importance Assigned to Milestone
virtualbox-ose (Ubuntu)
High
Daniel Hahler

Bug Description

Binary package hint: virtualbox-ose

vboxdrv was present in the previous hardy alpha1 kernel...

root@khermans-laptop:~# find /lib/modules/2.6.22-14-generic/ | grep -i vbox
/lib/modules/2.6.22-14-generic/misc/vboxdrv.ko
root@khermans-laptop:~# find /lib/modules/2.6.24-2-generic/ | grep -i vbox
root@khermans-laptop:~# /etc/init.d/vboxdrv restart
 * Starting VirtualBox kernel module vboxdrv FATAL: Module vboxdrv not found.

 * Modprobe vboxdrv failed. Please use 'dmesg' to find out why.
root@khermans-laptop:~# dmesg | tail
[24380.981547] sd 6:0:0:0: [sdb] Write Protect is off
[24380.981551] sd 6:0:0:0: [sdb] Mode Sense: 68 00 00 08
[24380.981554] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[24380.983398] sd 6:0:0:0: [sdb] 39075372 2048-byte hardware sectors (80026 MB)
[24380.984425] sd 6:0:0:0: [sdb] Write Protect is off
[24380.984429] sd 6:0:0:0: [sdb] Mode Sense: 68 00 00 08
[24380.984431] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[24380.984435] sdb: sdb1 sdb2
[24381.104297] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[24381.104345] sd 6:0:0:0: Attached scsi generic sg2 type 0

Andreas Simon (andreas-w-simon) wrote :

Yes, the problem is Hardy's current version of virtualbox-ose is not compatible with the new default kernel (2.6.24).
Hardy's virtualbox-ose package needs an upgrade to version 1.5.4 to be able to build against hardy's kernel.

This is already being worked on, see bug #156210 .

Changed in virtualbox-ose:
status: New → Confirmed

Ah, cool. I didn't come up with anything in my launchpad searches. Good to see that it should be fixed once more recent virtualbox-ose package is available...

Emilio Pozuelo Monfort (pochu) wrote :

This will be fixed once bug 156210 is fixed.

Changed in virtualbox-ose:
milestone: none → ubuntu-8.04
importance: Undecided → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose - 1.5.4-dfsg-4ubuntu1

---------------
virtualbox-ose (1.5.4-dfsg-4ubuntu1) hardy; urgency=low

  * Sync with Debian (LP: #156210). Remaining changes are:
    - Move virtualbox-ose-modules from recommends
      to depends for virtualbox-ose. We can drop this change when Synaptic
      installs recommended packages by default.
    - Change Maintainer to Ubuntu MOTU Developers.

  * The new 1.5.4 release closes LP: #179807, #185628.

 -- Emilio Pozuelo Monfort <email address hidden> Sat, 26 Jan 2008 16:11:06 +0100

Changed in virtualbox-ose:
status: Triaged → Fix Released

I'm running a fresh update from 7.10 as of today (feb 9, 2008) and virtualbox-ose-modules still fails to load/build the vboxdrv module needed to use virtualbox. Is there any more updates on this?

On Feb 9, 2008 12:30 PM, Christer Edwards <email address hidden> wrote:
> I'm running a fresh update from 7.10 as of today (feb 9, 2008) and
> virtualbox-ose-modules still fails to load/build the vboxdrv module
> needed to use virtualbox. Is there any more updates on this?

I think you need to be running Hardy dude...
--
Kristian Erik Hermansen
"Know something about everything and everything about something."

Daniel Hahler (blueyed) wrote :

Christer, this bug was about Hardy. It should work in Gutsy, unless you're using another kernel, e.g. -386 or -rt. For this, the modules are only available now since hardy.

However, you can always build the module yourself, see /usr/share/doc/virtualbox-ose-source/README.Debian (package virtualbox-ose-source).
Anyway, please file a new bug in case of other problems with this...

I'm sorry if I wasn't clear. I am running hardy, recently upgraded from 7.10. (upgrade vs fresh-install is what I mean to say).

I am unable to get the modules to install properly even after reinstalling or trying to use module-assistant. Virtualbox worked fine in 7.10, now it wont load in 8.04 after the upgrade. I have uninstalled virtualbox-ose & virtualbox-ose-modules, reinstalled even specifying virtualbox-ose-modules-2.6.24-5-generic. Still have issues loading the kernel module vboxdrv.

Daniel Hahler (blueyed) wrote :

Sorry, Christer, for being ignorant. There is a new kernel in Hardy and the modules need to get rebuild for it. I'm uploading them in a minute.

Thorsten Rhau (thorre) wrote :
Download full text (4.2 KiB)

Virtualbox worked just fine under the 8.04 beta with kernel 2.6.24-8-generic. After a upgrade to the 2.6.24-10-generic kernel the module vboxdrv.ko is missing.

root@majestix:/lib/modules# find . | grep -i vboxdrv
./2.6.24-8-generic/misc/vboxdrv.ko
root@majestix:/lib/modules# ls
2.6.24-10-generic 2.6.24-8-generic
root@majestix:/lib/modules# aptitude search generic
p libdaemon-generic-perl - framework for starting, stopping, reconfiguring daemon-like pr
v libgenerics-dev -
p libgenerics-docs - general c++ utility library - documentation
p libgenerics0 - general c++ utility library - shared libraries
p libgenerics0-dev - general c++ utility library - development files
p libnetserver-generic-perl - A perl module for developing internet servers in perl
p linux-backports-modules-2.6.24-10-generic - Ubuntu supplied Linux modules for version 2.6.24 on x86/x86_64
p linux-backports-modules-2.6.24-8-generic - Ubuntu supplied Linux modules for version 2.6.24 on x86/x86_64
p linux-backports-modules-generic - Backported drivers for generic kernel image
p linux-backports-modules-hardy-generic - Backported drivers for generic kernel image
p linux-generic - Complete Generic Linux kernel
i A linux-headers-2.6.24-10-generic - Linux kernel headers for version 2.6.24 on x86/x86_64
i linux-headers-2.6.24-8-generic - Linux kernel headers for version 2.6.24 on x86/x86_64
i linux-headers-generic - Generic Linux kernel headers
i linux-image-2.6.24-10-generic - Linux kernel image for version 2.6.24 on x86/x86_64
i linux-image-2.6.24-8-generic - Linux kernel image for version 2.6.24 on x86/x86_64
p linux-image-debug-2.6.24-10-generic - Linux kernel debug image for version 2.6.24 on x86/x86_64
p linux-image-debug-generic - Linux kernel debug image for generic kernel image
i linux-image-generic - Generic Linux kernel image
i linux-restricted-modules-2.6.24-10-generic - Non-free Linux 2.6.24 modules on x86/x86_64
c linux-restricted-modules-2.6.24-5-generic - Non-free Linux 2.6.24 modules on x86/x86_64
i linux-restricted-modules-2.6.24-8-generic - Non-free Linux 2.6.24 modules on x86/x86_64
i linux-restricted-modules-generic - Restricted Linux modules for generic kernels
i linux-ubuntu-modules-2.6.24-10-generic ...

Read more...

Jeff Schroeder (sejeff) wrote :

REOPENING: With the latest kernel update to hardy this problem exists.

jeff@omni:~$ sudo modprobe vboxdrv
FATAL: Module vboxdrv not found.
jeff@omni:~$ dpkg -L virtualbox-ose-modules-2.6.24-8-386 | grep 'vboxdrv.ko$'
/lib/modules/2.6.24-8-386/misc/vboxdrv.ko
jeff@omni:~$ ls -l /lib/modules/`uname -r`/misc/
ls: cannot access /lib/modules/2.6.24-10-generic/misc/: No such file or directory

Changed in virtualbox-ose:
status: Fix Released → New
Daniel Hahler (blueyed) wrote :

Jeff and Thorsten: I've uploaded virtualbox-ose-modules yesterday.
It does not appear in the list from Thorsten, which indicates that it hadn't arrived for you yet. Has the module been automatically been updated in the meantime?

Jeff, the same questions for you: Is linux-restricted-modules-2.6.24-10-generic available to you and did it automatically get installed (replacing -8)?

Changed in virtualbox-ose:
assignee: nobody → blueyed
status: New → Incomplete
Daniel Hahler (blueyed) wrote :

Meanwhile I've uploaded a new virtualbox-ose-modules, which provides real meta packages. Once you've installed virtualbox-ose-generic, it should automatically track updates to new versions of this package.

Daniel Hahler (blueyed) wrote :

I'm marking this "Fix released", hoping that the new packages haved fixed this upgrade problem(?).
Please re-open and add more information, in case there's still a problem with this.
Thank you.

Changed in virtualbox-ose:
status: Incomplete → Fix Released
Daniel Hahler (blueyed) wrote :

For reference: the "Depends" on virtualbox-ose-modules has been moved back to a "Recommends", because it causes severe problems ("apt-get pulls in -386 kernel", see bug 188579).

This is caused by apt-get not choosing the best package which provides virtualbox-ose-modules, but the first one (virtualbox-ose-modules-X-386 in this case).

Workaround, which should take care of upgrades: install the meta package, e.g. virtualbox-ose-modules-generic for the generic kernel.

tech0007 (tech0007) wrote :

Issue persists on updated hardy.

tech0007@myubuntu:~# sudo /etc/init.d/vboxdrv restart
 * Starting VirtualBox kernel module vboxdrv FATAL: Module vboxdrv not found.
 * Modprobe vboxdrv failed. Please use 'dmesg' to find out why.

I had to sudo insmod /lib/modules/2.6.24-16-generic/misc/vboxdrv.ko as a workaround.

Daniel Hahler (blueyed) wrote :

tech007, please provide the output of the following commands:
1. uname -a
2. dpkg -l | grep virtualbox-ose
3. sudo modprobe -r vboxdrv; sudo modprobe vboxdrv
4. dmesg | tail | grep vbox

Vadim Peretokin (vperetokin) wrote :

Virtualbox OSE is working fine in the 8.04 RC for me (64bit).

rola (robert-lange-s1999) wrote :

I have the same problem as tech007, so let me comment on your questions:

1. uname -a
Linux keroro 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux

2. dpkg -l | grep virtualbox-ose
ii virtualbox-ose 1.5.6-dfsg-6ubuntu1 x86 virtualization solution - binaries
ii virtualbox-ose-modules-2.6.24-16-generic 24 virtualbox-ose module for linux-image-2.6.24-16-generic
ii virtualbox-ose-modules-generic 24 virtualbox-ose module for linux-image-generic

3. sudo modprobe -r vboxdrv; sudo modprobe vboxdrv
FATAL: Module vboxdrv not found.
FATAL: Module vboxdrv not found.

4. dmesg | tail | grep vbox
no output

Workaround "insmod /lib/modules/2.6.24-16-generic/misc/vboxdrv.ko" is OK in the meanwile

Daniel Hahler (blueyed) wrote :

tech0007 and rola:
Does "sudo /sbin/depmod" help to get "sudo modprobe vboxdrv" working?

tech0007, are you also using 64bit architecture?

Please note: this is not the same issue as initially reported and actually is a problem with the virtualbox-ose-modules source package.
Maybe the same issue as reported in bug 210127?

Gene Caldwell (gene-caldwell) wrote :

I can confirm this problem still exists in 8.04. I went thru all the above tests and trials all to no avail. vboxdrv is clearly not getting installed. With no VMWare available, I decided to try VBOX, my uname -r is : 2.6.24-17-generic which differs from the above which indicates kernel 2.6.24-16-generic not 17 which is what was updated on my hardy 64bit. so as of now, there are NO working VM's for hardy. Just so no one asks, yes, I did install the virtualbox-ose-modules despite the lack of any dependencies of this.

Daniel Hahler (blueyed) wrote :

Gene, you're using a kernel from hardy-proposed, but the virtualbox kernel module has only recently been uploaded to the -proposed archive.
It should have arrived there in the mean time. See bug 226753.

Please avoid hijacking "Fix released" bugs.

Gene Caldwell (gene-caldwell) wrote :

most sincere apologies, I had no clue but I do understand. Not to be making a big issue, but I do not consider a small minor revision change to be hi-jacking. Its these kinds of comments that turns off new linux users from reporting bugs. The more correct way of handling minor kernel change issues would be to explain why this was the wrong place to confirm that there was a missing dependacy for this package. honesly, I'm not really sure why such a small revision change would break vbox ? it does not break video drivers when the change is so minor, I'm asking why it would in one package and not another ? again, I'm not TRYing to hijack this bug, I'm just not sure how I was supposed to know there was a better bug to report to....

Gene Caldwell (gene-caldwell) wrote :

@Daniel
my tone above did not come out like I had intended, I can't edit, I understand, I was just hoping for more guidence for future posting, I really did/do think I was correctly posting for this bug. thanks for the link to the right bug tho :)

Daniel Hahler (blueyed) wrote :

Gene, I did not want to sound/answer rude. Sorry.
I thank you for reporting this.
The change is required, because the ABI (binary compatibility) version of the kernel was required to get increased (bug 188226). It's a bit frustrating, because I've tried to convince the kernel team for a long time, that it would be better to change this for final already.
Now, they change it for -updates, which requires all kernel module packages to get rebuild/upgraded, too.

Please note, that you are using the -proposed repository, which is for verification and not supposed to be used on production (because of issues like this one).

Please don't hesitate to report any other bugs you may find.

Gene Caldwell (gene-caldwell) wrote :

I was aware that I was using the proposed.........yes, my doing. This was the first time that it had actually bit me like this, I knew the risk...lol, I just did not know that my kernel version 17 came from that repo. it was no big deal for me 'cause I do mainly testing, however I see now that it was the reason for the hi-jack comment which is completely understandable in hindsight. my-bad. I shall endeavor to make sure that I keep the proposed separate from released, which was your point. we're on the same page.

Thiago Teixeira (tvst) wrote :

"Does "sudo /sbin/depmod" help to get "sudo modprobe vboxdrv" working?"
Daniel: Since nobody else replied, I'll do it myself! It works for me. Thanks!

So the whole process for me was:
1) sudo aptitude
select virtualbox-ose
unselect virtualbox-ose-modules-386 (selected automatically by virtualbox)
unselect linux-image-2.6.24-16-386 (selected automatically by virtualbox)
select virtualbox-ose-modules-generic
2) sudo /sbin/debmod
3) reboot

(I wrote this a few minutes after I got it working, so I may be missing some step...)

Jeff Schroeder (sejeff) wrote :

This happens again in hardy with the 2.6.24-18-generic kernel. The package for virtualbox-ose-modules does not even exist in the ubuntu repositories right now.

Jeff Schroeder (sejeff) wrote :

This happened again in the latest update in Hardy. Can whoever manages these modules coordinate things with the kernel and SRU team to have the packages ready before a new kernel is uploaded?

Changed in virtualbox-ose:
status: Fix Released → New
supercompman (supercompman) wrote :

This is a major problem. I work with an entire team of developers that regularly use VirtualBox and _need_ this to be working properly... This is really unacceptable for an LTS release that is geared toward production environments. It's ridiculous to have to tell members of this dev team "hey, don't install those security updates because you won't be able to get your work done if you do". Yes I know that all you need to do is reboot and select the previous kernel, and yes I know for a production environment, updates should probably be handled through a single local server where all updates are verified first before being released to the production systems. Even still, these seem like poor workarounds instead of just coordinating these kinds of updates properly.

Daniel Hahler (blueyed) wrote :

There's a workaround present in similar bug reports, e.g. bug 237278.
The virtualbox-ose and virtualbox-ose-modules packages are community maintained and it only happens that I'm the one who takes care of it, because nobody else seems to do.
I'm uploading a new module in the next minutes to hardy-proposed, please refer to bug 237278 for the verification and progress of it.

Changed in virtualbox-ose:
status: New → Fix Released
Jeff Schroeder (sejeff) wrote :

Daniel,

Please read through this thread in the Ubuntu kernel-team mailinglist archives:
https://lists.ubuntu.com/archives/kernel-team/2008-June/002526.html

I'll try working on moving virtualbox-ose-modules over to dkms this weekend.
If you have any questions, send me an email at the same email in my lp profile.

Moving the modules over to dkms would solve this problem entirely.

Daniel Hahler (blueyed) wrote :

Jeff, it would be great if that could get fixed, so that it won't break with every kernel abi bump - of course.
Please file a new bug for this and provide a patch, if possible. Thank you!

al_mckin (amckinley03) wrote :

This bug has appeared again with the kernel update to 2.6.24-22.

supercompman (supercompman) wrote :

Is anyone looking at correcting this bug or has this effort been entirely abandoned in favor of having everyone upgrade to 8.10?

kb5yia (pllinux) wrote :

I also am having this issue an so far have not been able to find a fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers