virtualbox-ose-modules broken AGAIN

Bug #303199 reported by Bipolar on 2008-11-28
This bug affects 7 people
Affects Status Importance Assigned to Milestone
virtualbox-ose-modules (Ubuntu)

Bug Description

Binary package hint: virtualbox-ose-modules-generic

My father called me this morning to tell me his virtual Windows XP installation wont start, just after he installed updates.
The kernel was updated to 2.6.24-22-generic from 2.6.24-21-generic. There is no matching virtualbox-ose-modules-2.6.24-22-generic package. This happened last time he upgraded. And the time before that. The module package always lags behind the kernel package, which completely breaks Virtualbox in the meantime. This is a LTS version. This should NEVER happen. If it was a one time thing, I could understand, but this points to a bigger problem with policy. I'm not exactly sure how to address it. At this point, even if this package gets fixed, it will break the next time the kernel gets a minor update.

Nick Barcet (nijaba) wrote :

I guess you've got the choice between staying on hardy, and having to wait a bit after each kernel update for the necessary rebuild/upload to occur, or you can upgrade to intrepid where, I believe, DKMS will nicely rebuild the module for you automatically each time the kernel is updated.

Now, claiming that this should not happen on an LTS version is a little weird, as virtualbox is not in main, and is therefore not covered by the long term support you are referring to.

Also, I am sure that Daniel Hahler, whom kindly spends his time having to recompile this module each time the kernel is updated is certainly more bothered by this than you are, so instead of complaining, maybe you should thank him?

Bipolar (bipolar) wrote :

I certainly appreciate the work of everyone that puts time into Ubuntu, including Daniel. However, if someone doesn't complain, how exactly would anything get fixed? Also, this doesn't help to correct the underlying issue. How does Daniel know that a kernel update is coming that is going to break the work hes done on his package? Does he get any lead time to build a module? Is there an automated system for building kernel module packages along with the kernel when it gets a minor update like this?
When installing security updates breaks packages repeatedly, the first reaction end users have to the issue is to stop installing security updates, because they break things. That is what needs fixing. If there are packages that require updates every time the kernel gets a minor upgrade, there needs to be an automated way of rebuilding them.
If Intrepid uses DKMS, then that will fix THIS package for Intrepid. But I worry that the underlying issue will still be there, ready to rear it's head with a different package in the future.

Daniel Hahler (blueyed) wrote :

I've uploaded a new version for 2.6.24-22 to hardy-proposed (which already has a -23 kernel itself, so it will break sometime again, when this gets to -updates).
I don't know about security releases beforehand or even new updates in hardy-proposed.
And yes, luckily this is fixed for Intrepid and changing to DKMS for Hardy has been rejected IIRC, but may get considered again, given the number of ABI bumps the kernel already had in Hardy (and its lifetime)!
I'm not using Hardy anymore on my desktop (where I would use virtualbox-ose) and it's very frustrating to keep this package up to date.

I recommend using the "real" virtualbox from, which is available in a repository, too, and does not have this issue, plus some extra features - but is not as free as the OSE version (but fine e.g. for personal usage).

Changed in virtualbox-ose-modules:
importance: Undecided → High
status: New → Triaged
bamojr (vandenberg-bj) wrote :

Any Idea when the new module will be out. I have some work stored in my VM that i have to access by this Monday and I'd rather not go back a kernel and have to recompile my graphics drivers. Anyone know any rough dates?


bamojr (vandenberg-bj) wrote :

So I was going to try to install the non-OSE version. However, when I went to clone my .vdi file,it still needs the new module for the new kernel to even clone the file... :( any work arounds for this?


Angel Sanchez (evelio80) wrote :

excuseme for spanish but my english is very bad I only read a litle bit english...... THIS IS A SOLUTION AT YOUR TROUBLE (PROBLEMA) ON VIRTUALBOX.

 estamos jodidos......

aunque yo no actualice, pues me lo suponia...


Bueno chicos, ya que estan metidos en el dilema, les digo que a mi me parece que cada vez que actualizas el kernel te queda una copia de respaldo del kernel anterior, entonces lo que tienen que hacer es que hacer el boot por uno de esos kernels mas viejo (el anterior y su maquina debe trabajar).

Donde esta eso????

pues en la lista de booteo de grub aparecen todos los kernel que hemos tenido antes, es solo cuestion de seleccionar uno de ellos antes de cargar nuestro ubuntu.

espero esta solucion les ayude

Angel Sanchez (evelio80) wrote :

Este es un ejemplo de mi grub para que lo tomen de referencia a ver si entienden de que les hablo....

do this:

sudo gedit /boot/grub/menu.lst

veran esto y lo podran modificar, pero cuidado.... esto no es necesario, es solo otro camino a la solucion, solo que lo considero mas complejo....

Muchas cosas omitidas al principio del archivo ya que no son de interés para ustedes
## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 8.04.1, kernel 2.6.24-21-generic
root (hd0,1)
kernel /boot/vmlinuz-2.6.24-21-generic root=UUID=30a514e4-63ea-4fe6-8181-67b15a0b6396 ro quiet splash
initrd /boot/initrd.img-2.6.24-21-generic

title Ubuntu 8.04.1, kernel 2.6.24-21-generic (recovery mode)
root (hd0,1)
kernel /boot/vmlinuz-2.6.24-21-generic root=UUID=30a514e4-63ea-4fe6-8181-67b15a0b6396 ro single
initrd /boot/initrd.img-2.6.24-21-generic

title Ubuntu 8.04.1, kernel 2.6.24-19-generic
root (hd0,1)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=30a514e4-63ea-4fe6-8181-67b15a0b6396 ro quiet splash
initrd /boot/initrd.img-2.6.24-19-generic

title Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root (hd0,1)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=30a514e4-63ea-4fe6-8181-67b15a0b6396 ro single
initrd /boot/initrd.img-2.6.24-19-generic

title Ubuntu 8.04.1, memtest86+
root (hd0,1)
kernel /boot/memtest86+.bin


# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Lamentablemente - ""Microsoft Windows XP Professional""
root (hd0,0)
chainloader +1


mhotze (m-hotze) wrote :

Hi Daniel,

Would it be an idea to make a *second* VirtualBox-OSE-Modules-Generic version, which does have the dependency set to the kernel modules? In that case the users can chose between either being in-dependent of Virtualbox and install the latest kernel once it's available (as it is now, but with the downside of "breaking"), or being dependent of Virtualbox (but with the downside of having to wait for the new kernel until the Virtualbox modules are updated)? Personally I would chose for the second option, once it's available. For systems more vulnerable, the first option would be preferred (default?) I guess.

Keep up the good work anyhow!

Ricardo Santos (rsantos) wrote :

I see the same problem.

Bipolar (bipolar) wrote :


  Thanks for your feedback on this issue. I'm going to switch my father to use the PUEL version of Virtualbox as a workaround to this problem. I'm kind of worried that you're not informed about incoming kernel updates though. I hope that in time a solution to that kind of problem will be implemented. I was able to use module-assistant to create a new module package to use though this version of the kernel. If only there was a way to do that in the build system automatically before a kernel update is pushed out. That way you wouldn't need to concern yourself with building a package at all.
  How is the Nvidia kernel module handled? A new version of that was pushed out with the new kernel, and it's non-free. They must have some tricks up their sleeve to handle it.

  Thanks again for your work!

Rodrigo Rodríguez (nomada) wrote :

To fix the problem, temporaly, you should reboot from the last kernel, in this case, the 2.6-24-21 until an update will be available. That's the solution that Angel Sanchez sugest.

Here's a link reporting the problem and puting the solution also in english:

Daniel Hahler (blueyed) wrote :

Subscribing ubuntu-archive:
Please approve my upload of the module to hardy-proposed (

I know that it does not match the kernel ABI in hardy-proposed, but it is meant to go into hardy-updates to match the version from hardy-security.

Roshan George (roshan-george) wrote :

Hi Daniel,

Thanks for all your work. I've followed your advice and switched to the version and everything works just fine even with the latest kernel.

Steve Langasek (vorlon) wrote :

Sorry, but linux has just bumped the ABI to -23 in hardy-proposed. Could you prepare a -23 build of virtualbox-ose-modules for SRU to replace it?

I don't think there's much point in accepting the current version.

Daniel Hahler (blueyed) wrote :

Steve, I don't know how long it will take this time until linux gets updated in -updates.
The current upload is meant to fix the current problem.

My plan was to prepare a new upload, when it's been propagated to -updates.

Anyway, I've uploaded 24.0.8 for the -23 kernel now.

While I have your attention: is there any way this procedure could get streamlined for Hardy? (e.g. by switching to DKMS or by notifying me in case the ABI gets bumped in -updates and -proposed - should I subscribe to hardy-changes maybe and filter for specific mails?)

luchomax (has250780) wrote :

Hola Angel Sanchez

la verdad que tus datos me han sido lo suficientemente claros, recientemente empece a usar kubuntu desde una version mucho anterior para evitar estos problemas de las actualizaciones de version y desconocia que las actualizaciones eran tan profundas.
Me salvaste la vida!!!
saludos desde argentina!!!

Angel Sanchez (evelio80) wrote :


no es que las actualizaciones sean profundas, la realidad es que es muy raro que haya problemas después de una actualización (aunque los casos se dan), en mi caso por ejemplo solo he visto problemas con este software y es por la forma en que esta desarrollado... pero aun te falle algo eso no importa porque aquí están las comunidades de usuarios que siempre están muy dispuestos a ayudar y guiarnos.... yo por ejemplo no he hecho la actualización porque en unos días tengo que entregar esas maquinas virtuales en la universidad como un proyecto final y no me gustaría tomarme mucho tiempo resolviendo cualquier problemita que pueda surgir (Ya sabes lo que se dice: "Lo que esta bueno, no se repara")

Así que no tengas miedo y pruebate una de las nuevas distribuciones que estan muy bien (por lo menos a mi me gustan bastante)



updates do not always tend to give problems are just isolated cases and the community always helps us to solve these problems, it is a matter of being patient.

Mario Splivalo (mariosplivalo) wrote :

One can build virtualbox kernel module package for the latest kernel using module assistant and virtualbox-ose-source package.

First, 'apt-get install virtualbox-ose-source', that would install module-assistant too if it's not allready installed.

Then, go to /usr/src, there will be virtualbox-ose.tar.bz2 file. Untar it, go to /usr/src/modules, and create symboilic link from virtualbox-ose to virtualbox:

ln -s virtualbox-ose virtualbox

Then use module assistant to build the kernel module package:

module-assistant build virtualbox

After that, in /usr/src you'll have a .deb package with the virtualbox kernel module for your installed kernel.

module-assistant install virualbox

and your package is installed.

Load the module:

modprobe vboxdrv

To check if the kernel module is loaded, use: lsmod | grep vbox. vboxdrv module should be listed.

Of course, then the next kernel update arrives this proces should be repeated.

Steven Willis (onlynone) wrote :

It's even simpler than that:

sudo apt-get install virtualbox-ose-source
sudo module-assistant auto-install virtualbox-ose-source
sudo /etc/init.d/vboxdrv start

(the last step basically just loads the module with modprobe, but it also does a little bit of house keeping)

And you might only need to run the last two steps from above; according the the module-assistant man page:

"auto-install is followed by one or more packages desired for installation. It will run prepare to configure your system to build packages, get the package source, try to build it for the current kernel and install it."

Clem (yorelc) wrote :

Thanks Steven, it works !

^AndreA^ (andrea-bola) wrote :

Hi all,

Steven I've done what you said and my VM is magically restarted but...

...but, unfortunately now, my CPU si always at 100% even when the VM is doing nothing...

Any possible solution?

is it because the generic module is not as good as the proper one?!?

Thanks anyway for you help!!!


Przemek K. (azrael) wrote :

I tried rebuilding the module for -22 but it refused to compile on amd64, and I can't use the PUEL version because I'm using VB for commercial purposes. So I'm stuck on -21 kernel :[

Martin Pitt (pitti) wrote :

Not an issue in jaunty and intrepid, those releases use DKMS.

Changed in virtualbox-ose-modules:
status: Triaged → Invalid
status: New → Invalid
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see for documentation how to enable and use -proposed. Thank you in advance!

Bipolar (bipolar) wrote :

  The PUEL does not forbid using it in a commercial project. It's a bit of a misnomer. From the licence:

§ 2 Grant of license. (1) Sun grants you a personal right to install and execute the Product on a Host Computer for Personal Use or Educational Use or for Evaluation. “Personal Use” requires that you use the product on the same Host Computer where you installed it yourself and that no more than one client connect to that Host Computer at a time for the purpose of displaying Guest Computers remotely.

So, if YOU installed it and YOU use it, it's covered under the PUEL. Enjoy!

^AndreA^ (andrea-bola) wrote :

I did not use virtualbox for a few days...

I restarted it yesterday... I used it for the whole day and today the same...

My CPU now seems to work properly... so I have to revise my previous comment.

The Steven's method works very well... maybe I had just to restart the pc before complaining... :-|

Thanks again Steven,


If anybody still needs it, I've build the modules for the -22 kernel in my PPA:

HughBranes (hughbranes) wrote :

Using module-assistant auto-install isn't working with the current virtualbox-ose-source package.

Auto-install is expecting to find the virtualbox sources under /usr/src and doesn't, so fails. The file list reveals that the sources are not being placed where auto-install expects them:

Here is the output I get:

# *** start output
Updated infos about 1 packages
Getting source for kernel version: 2.6.27-9-generic
Kernel headers available in /usr/src/linux-headers-2.6.27-9-generic
Creating symlink...
apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

The source tarball could not be found!
Package virtualbox-ose-source not installed?
Running "m-a -f get virtualbox-ose-source" may help.
"/usr/share/modass/packages/" build KVERS=2.6.27-9-generic KSRC=/usr/src/linux KDREV=2.6.27-9.19 kdist_image
find: `/usr/src/modules/virtualbox*': No such file or directory
# *** end output

There's an ncurses dialogue in the middle somewhere, allowing me to view a build log, which only has an entry telling me logging is being started in /var/cache/modass/virtualbox-ose-source.buildlog.2.6.27-9-generic.1230206467. I selected "Continue" in this case.

Something seems wrong here. Is there a safe workaround if a proper fix is not simple?

Hew (hew) wrote :

HughBranes, this bug report is not the same as your issue. This report applies only to Hardy, and a fix is awaiting testing in -proposed. If you believe your issue is a bug, you should file a separate bug report.

Fabián Rodríguez (magicfab) wrote :

I can confirm the proposed workaround works in an updated Ubuntu Hardy:

From a terminal window:
sudo apt-get install virtualbox-ose-source module-assistant
sudo module-assistant auto-install virtualbox-ose-source
sudo /etc/init.d/vboxdrv start

I believe this is needed for every kernel upgrade.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ose-modules - 24.0.8

virtualbox-ose-modules (24.0.8) hardy-proposed; urgency=low

  * Rebuild for 2.6.24-23 (LP: #303199)

 -- Daniel Hahler <email address hidden> Wed, 03 Dec 2008 00:43:18 +0100

Changed in virtualbox-ose-modules:
status: Fix Committed → Fix Released
Angel Sanchez (evelio80) wrote :

Que lio este!!!
bueno... veamos que tal mi ingles :D


1- unistall OSE version (complete)
  sudo aptitude purge virtualbox-source
  sudo aptitude purge virtualbox-ose
  sudo aptitude purge virtualbox-ose-source
  sudo aptitude purge virtualbox-ose-modules-xxxxxxxxxxxx
  sudo aptitude purge virtualbox-ose...xxxxxx...xxxx
 etc, etc, etc

2- add repository of virtualbox at source.list
  Debian-based Linux distributions: Add one of the following lines according to your distribution to your /etc/apt/sources.list

         deb intrepid non-free
         deb hardy non-free
         deb gutsy non-free
         deb dapper non-free
         deb lenny non-free
         deb etch non-free
         deb sarge non-free
         deb xandros4.0-xn non-free

sudo gedit /etc/apt/source.list

add repository according with your distribution
save and close gedit and continue

(Is like WEP or WPA in WIFI, is like security key for repository)

Use the command:
wget -q -O- | sudo apt-key add -

(More details and other distributions at:

3- Update the repository
sudo aptitude update

4- Install Software

sudo aptitude install dkms
sudo aptitude install virtualbox-2.1

5- Enjoy

After a kernel update (if virtualbox do not work properly) is necessary to recompile the kernel modules.
This task is simple:


 sudo /etc/init.d/vboxdrv setup

Then will show something like this:

 * Stopping VirtualBox kernel module
 * done.
 * Recompiling VirtualBox kernel module
 * done.
 * Starting VirtualBox kernel module
 * done.



Espero este les sirva de ayuda a todo aquel que ha tenido algún problema con virtualbox

Consulte la web de virtualbox en caso del algún error, por cambios de ultimo minuto o lo que sea, como por ejemplo en la llave para los repositorios o algo así (aunque dudo mucho que eso pase).

Brittany Dunlap (xdunlapx) wrote :

Awesome, thanks for providing a fix!! I confirm this fix works.

Brittany Dunlap (xdunlapx) wrote :

I meant the original fix, I have not tried any other 'fix'.

Angel Sanchez (evelio80) wrote :

I'm happy for you!!

gmck (gmck) wrote :

I had a related problem - I could not see *any* new versions of "virtualbox-ose-modules-2.6.24-xx" after "virtualbox-ose-modules-2.6.24-16", even though I could see all of the kernel images from "linux-image-2.6.24-16-generic" to "linux-image-2.6.24-24-generic".

Traced my issue to the default apt "sources.list" file from Hardy, which had the following lines:
deb hardy-updates main restricted
deb-src hardy-updates main restricted

However, the virtualbox-ose-modules packages are in the "universe" repository, so the new packages in "hardy-updates" were not being downloaded by 'apt-get update'. Adding the following lines to sources.list fixed the problem.

deb hardy-updates universe multiverse
deb-src hardy-updates universe multiverse

The meta-package "virtualbox-ose-modules-generic" now functions as expected, and Virtualbox works with the "virtualbox-ose-modules-2.6.24-24" package installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions