[SRU]package virtualbox-guest-utils-hwe 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1708315 reported by Steven Gilreath on 2017-08-03
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
virtualbox-hwe (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[ Regression Potential ]
* None, it has been a mistake in my hwe package creation. It should be an easy and simple fix (systemd parses the old init.d string, and when same name is detected, it obviously refuses to start

[ test case ]
install virtualbox-guest-utils and then install virtualbox-guest-utils-hwe

[ Other info ]

System doesn't allow dkms, or virtual machines built upon dfsg. I'm not interested in mesa or systems built on X.
Linux seems to be about hatred and negativity more than it is about letting go of bad things from the past, but seems to revel in the negative and futile, more than anything positive and hopeful.

There is a time, I suppose, that rubbing someones face in the past nightmare's, has value in a limited way, but at some point, keeping a good man down, lacks understanding, as is a maniacle, futile act,that helps no one involved, despite there personal prejudice. The reality, is just a tragic waste of human worth, and value, accomplishing nothing good. In linux,new is effectivlly put away from observvatin, obviously ignored and hidden.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: virtualbox-guest-utils-hwe 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.3
ProcVersionSignature: Ubuntu 4.4.0-88.111-generic 4.4.76
Uname: Linux 4.4.0-88-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
Date: Wed Aug 2 17:59:01 2017
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2017-01-10 (204 days ago)
InstallationMedia: Ubuntu-MATE 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.2.24
SourcePackage: virtualbox-hwe
Title: package virtualbox-guest-utils-hwe 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

tags: removed: need-duplicate-check

Can you please show me the output of:
dpkg -l |grep virtualbox

thanks

Changed in virtualbox-hwe (Ubuntu):
status: New → Incomplete

I suspect you installed a while ago some virtualbox-5.0 or virtualbox-5.1 from Oracle official website, and the script hasn't been deleted correctly because you never removed that package and installed the Ubuntu hwe one.

Please remove --purge it and install it again.

Vlad Orlov (monsta) wrote :

I confirm the issue with the same error message as in DpkgTerminalLog.txt.

I reproduced it in a VM with Ubuntu MATE 16.04 with the default kernel/xorg/virtualbox-guest packages when I've tried to update them all to HWE stack.

$ LC_ALL=C sudo apt-get install linux-generic-hwe-16.04 xserver-xorg-hwe-16.04 xserver-xorg-video-all-hwe-16.04 xserver-xorg-input-all-hwe-16.04 virtualbox-guest-dkms-hwe virtualbox-guest-utils-hwe virtualbox-guest-x11-hwe

.......

Setting up virtualbox-guest-utils-hwe (5.0.40-dfsg-0ubuntu1.16.04.1~16.04.3) ...
insserv: script virtualbox-guest-utils-hwe: service vboxguest already provided!
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package virtualbox-guest-utils-hwe (--configure):
 subprocess installed post-installation script returned error exit status 1

-------

I've tried to run "sudo dpkg --configure -a" after that, but it stumbles upon the same error and shows the same message.

This VM doesn't have any vbox packages from the official website (they don't provide separate guest additions packages anyway). It only has the default Xenial guest additions packages, version 5.0.40-dfsg-0ubuntu1.16.04.1.

 virtualbox-guest-utils-hwe : Conflicts: virtualbox-guest-utils
E: Unable to correct problems, you have held broken packages.

how can you have them both?

Vlad Orlov (monsta) wrote :

I surely didn't have them both installed, as apt-get wanted to remove the old guest additions packages when I told it to install the new ones.

Attaching the full log just in case.

I don't really know how to make sure the old one is purged before installing the new one

Changed in virtualbox-hwe (Ubuntu):
status: Incomplete → New
importance: Undecided → Critical
status: New → Confirmed
Changed in virtualbox (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
importance: Critical → High
Changed in virtualbox-hwe (Ubuntu):
importance: Critical → High
Vlad Orlov (monsta) wrote :

I can only add that things were working fine in 14.04 when switching to -lts packages. I never had this "service vboxguest already provided" problem there.

Vlad Orlov (monsta) wrote :

Also the original virtualbox-guest-* packages were actually removed in the process. Check my log above - it was the first action done after all new packages were downloaded.

Removing virtualbox-guest-dkms (5.0.40-dfsg-0ubuntu1.16.04.1) ...

.......

------------------------------
Deleting module version: 5.0.40
completely from the DKMS tree.
------------------------------
Done.
Removing virtualbox-guest-x11 (5.0.40-dfsg-0ubuntu1.16.04.1) ...
Removing virtualbox-guest-utils (5.0.40-dfsg-0ubuntu1.16.04.1) ...

James Cuzella (trinitronx) wrote :

Possible duplicate of Bug #1608208. Try removing all old virtualbox packages prior to installing virtualbox 5. See my comment on Bug #1608208 for detailed commands to run in order to find all the ones you have installed.

Hint: Check for "ii" lines in output of: dpkg -l | grep virtualbox

Vlad Orlov (monsta) wrote :

Nope. This one is about *-hwe packages, and there was no upgrade from 14.04.

Changed in virtualbox (Ubuntu):
status: Confirmed → Invalid
description: updated
summary: - package virtualbox-guest-utils-hwe 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.3
- failed to install/upgrade: subprocess installed post-installation script
- returned error exit status 1
+ [SRU]package virtualbox-guest-utils-hwe 5.0.40-dfsg-
+ 0ubuntu1.16.04.1~16.04.3 failed to install/upgrade: subprocess installed
+ post-installation script returned error exit status 1
Changed in virtualbox-hwe (Ubuntu Xenial):
status: New → Fix Committed
Changed in virtualbox (Ubuntu Xenial):
status: New → Invalid

An upload of virtualbox-hwe to xenial-proposed has been rejected from the upload queue for the following reason: "The changelog entries are strange and out of chronological order.".

Vlad Orlov (monsta) wrote :

Too bad - I wanted to test the fix.

I reuploaded, and you can use my ppa for this

Vlad Orlov (monsta) wrote :

I'll wait for -proposed just in case, it'll be needed for "verification-done" anyway...

Hello Steven, or anyone else affected,

Accepted virtualbox-hwe into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-hwe/5.0.40-dfsg-0ubuntu1.16.04.1~16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
Vlad Orlov (monsta) wrote :

Ok, the fix works if I'm running kernel 4.4.

$ uname -a
Linux xenial 4.4.0-101-generic #124-Ubuntu SMP Fri Nov 10 18:29:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I've installed virtualbox-guest-*-hwe packages version 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.4 from xenial-proposed, along with HWE packages of xorg:

$ LC_ALL=C sudo apt-get install --no-install-recommends xserver-xorg-hwe-16.04 xserver-xorg-video-all-hwe-16.04 xserver-xorg-input-all-hwe-16.04 virtualbox-guest-dkms-hwe virtualbox-guest-utils-hwe virtualbox-guest-x11-hwe

All good, the installation went fine, and after the reboot the system works fine.

--------------------------------

I have a problem with kernel from linux-generic-hwe-16.04 though (version of linux-image-4.10.0-40-generic package is 4.10.0-40.44~16.04.1). That's why I had to use --no-install-recommends option - to avoid installing that kernel.

The VM just won't boot with it. It says "loading initial ramdisk", then VirtualBox just keeps eating 100% CPU on each core, and the boot doesn't continue.

This happens with both original xorg + virtualbox-guest-* packages and with HWE xorg + virtualbox-guest-*-hwe packages. So it's either a separate bug, or something with my VirtualBox, but it's not caused by the fix for this bug. Therefore this update is good to go.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial

Yes, I think you are correct, a really different bug from my just buildfix upload :)

Vlad Orlov (monsta) wrote :

Boot issue solved by removing intel-microcode package - no idea why it was installed.

@Vlad please move to #1729568

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-hwe - 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.4

---------------
virtualbox-hwe (5.0.40-dfsg-0ubuntu1.16.04.1~16.04.4) xenial; urgency=medium

  * Provide vboxguest-hwe, to avoid clash with old package
    (residual config is not purged on removal LP: #1708315)

virtualbox (5.0.40-dfsg-0ubuntu1.16.04.3) xenial; urgency=medium

  * Tweak and reduce previous patch

virtualbox (5.0.40-dfsg-0ubuntu1.16.04.2) xenial; urgency=medium

  * Fix kernel module build with new kernel 4.13 (LP: #1729568)

 -- Gianfranco Costamagna <email address hidden> Fri, 10 Nov 2017 09:53:26 +0100

Changed in virtualbox-hwe (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for virtualbox-hwe has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Vlad Orlov (monsta) wrote :

Marked the main virtualbox-hwe entry as fixed, I hope you don't mind (it's Xenial-only anyway).

Changed in virtualbox-hwe (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers