[SRU] ext-pack: disable auto installation defaulting to yes

Bug #1844654 reported by Joshua Powers on 2019-09-19
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virtualbox-ext-pack (Ubuntu)
Critical
Gianfranco Costamagna
Xenial
Critical
Gianfranco Costamagna
Bionic
Critical
Gianfranco Costamagna
Disco
Critical
Gianfranco Costamagna
Eoan
Critical
Gianfranco Costamagna

Bug Description

virtualbox-ext-pack is *not* free software and therefore it should not be in the archive. This is a request to do the following:

* Remove virtualbox-ext-pack from the archive for all releases
* Ensure no version of the package is in proposed and remove if it is
* Blacklist the package from syncing from Debian

Changed in virtualbox-ext-pack (Ubuntu):
importance: Undecided → Critical
Joshua Powers (powersj) on 2019-09-19
Changed in virtualbox-ext-pack (Ubuntu Disco):
importance: Undecided → Critical
Changed in virtualbox-ext-pack (Ubuntu Bionic):
importance: Undecided → Critical
Changed in virtualbox-ext-pack (Ubuntu Xenial):
importance: Undecided → Critical
Steve Langasek (vorlon) wrote :

Removed and blacklisted.

Removing packages from eoan:
 virtualbox-ext-pack 6.0.12-1 in eoan
  virtualbox-ext-pack 6.0.12-1 in eoan amd64
  virtualbox-ext-pack 6.0.12-1 in eoan arm64
  virtualbox-ext-pack 6.0.12-1 in eoan armhf
  virtualbox-ext-pack 6.0.12-1 in eoan i386
  virtualbox-ext-pack 6.0.12-1 in eoan ppc64el
  virtualbox-ext-pack 6.0.12-1 in eoan s390x
Comment: Installer package for undistributable software; has unacceptable autopkgtests that trigger installation of encumbered software; LP: #1844654
1 package successfully removed.

Changed in virtualbox-ext-pack (Ubuntu Eoan):
status: New → Fix Released

Its a downloader, that triggers the accept of a PUEL license, and it is in contrib, I don't get why it shouldn't be allowed in the archive.
The license is clear, the postinst is clear, in no way the user can install it without understanding what is going on.

The license is clearly stated in the description, and needs to be accepted specifically by the user, the same happens with other downloaders we have in the archive.

same happens with cmdline installation

Steve Langasek (vorlon) wrote :

Your screenshots show that the default answer to the license Eula question is "yes", which is NOT acceptable for a Eula presented via DebConf. When using the non interactive frontend, this results in software assuming the license has been accepted when there has been no such intent on the part of the user.

Canonical did not accept this license, but the download was being triggered from autopkgtest instances as if we had.

I hope to have fixed the concerns wrt the archive (and sorry for that, I never thought about them...)

please let me know if the solution is acceptable, its in unapproved right now

summary: - Remove from archive
+ [SRU] ext-pack: disable auto installation defaulting to yes
Changed in virtualbox-ext-pack (Ubuntu Xenial):
status: New → In Progress
Changed in virtualbox-ext-pack (Ubuntu Bionic):
status: New → In Progress
Changed in virtualbox-ext-pack (Ubuntu Disco):
status: New → In Progress
Changed in virtualbox-ext-pack (Ubuntu Eoan):
status: Fix Released → In Progress
Changed in virtualbox-ext-pack (Ubuntu Xenial):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
Changed in virtualbox-ext-pack (Ubuntu Bionic):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
Changed in virtualbox-ext-pack (Ubuntu Disco):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
Changed in virtualbox-ext-pack (Ubuntu Eoan):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)

Hello Joshua, or anyone else affected,

Accepted virtualbox-ext-pack into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-ext-pack/6.0.6-1ubuntu1.19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in virtualbox-ext-pack (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Changed in virtualbox-ext-pack (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Robie Basak (racb) wrote :

Hello Joshua, or anyone else affected,

Accepted virtualbox-ext-pack into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-ext-pack/5.2.32-1~ubuntu18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in virtualbox-ext-pack (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Robie Basak (racb) wrote :

Hello Joshua, or anyone else affected,

Accepted virtualbox-ext-pack into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-ext-pack/5.1.38-0ubuntu1.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

the diff looks correct, and update_excuses for bionic stopped showing the test results... I like it

tags: added: verification-done verification-done-bionic verification-done-disco verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-disco verification-needed-xenial
Steve Langasek (vorlon) on 2019-09-26
Changed in virtualbox-ext-pack (Ubuntu Eoan):
status: In Progress → Fix Released
Robie Basak (racb) wrote :

I think the increased regression risk of this baking in proposed for another three days is outweighed by the harm caused by it not being fixed, so I'm releasing this today.

Thank you Gianfranco for arranging the fix promptly!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ext-pack - 6.0.6-1ubuntu1.19.04.1

---------------
virtualbox-ext-pack (6.0.6-1ubuntu1.19.04.1) disco; urgency=medium

  * Default eula to false, and disable autopkgtests, for legal issues
    LP: #1844654

 -- Gianfranco Costamagna <email address hidden> Sun, 22 Sep 2019 23:02:34 +0200

Changed in virtualbox-ext-pack (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for virtualbox-ext-pack has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ext-pack - 5.2.32-1~ubuntu18.04.2

---------------
virtualbox-ext-pack (5.2.32-1~ubuntu18.04.2) bionic; urgency=medium

  * Default eula to false, and disable autopkgtests, for legal issues
    LP: #1844654

 -- Gianfranco Costamagna <email address hidden> Sun, 22 Sep 2019 23:01:42 +0200

Changed in virtualbox-ext-pack (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ext-pack - 5.1.38-0ubuntu1.16.04.2

---------------
virtualbox-ext-pack (5.1.38-0ubuntu1.16.04.2) xenial; urgency=medium

  * Default eula to false, and disable autopkgtests, for legal issues
    LP: #1844654

 -- Gianfranco Costamagna <email address hidden> Sun, 22 Sep 2019 23:00:42 +0200

Changed in virtualbox-ext-pack (Ubuntu Xenial):
status: Fix Committed → Fix Released

thanks Robie for releasing them quickly! I would even had fixed them two days in advance if I were notified about this bug... the delay has been because I don't look to my email daily!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers