[SRU] package virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 failed to install/upgrade: sub-processo script post-installation instalado retornou estado de saída de erro 1

Bug #1605799 reported by NKStudio
270
This bug affects 52 people
Affects Status Importance Assigned to Milestone
virtualbox-ext-pack (Ubuntu)
Undecided
Unassigned
Xenial
Critical
Unassigned
Yakkety
Critical
Unassigned

Bug Description

[Impact] virtualbox-ext-pack non-installable

[test case] try to install it, the hardcoded sha256sum is different with the upstream one

[other info] upstream changed the file without changing version
http://download.virtualbox.org/virtualbox/5.0.24
      Oracle_VM_VirtualBox_Extension_Pack-5.0.24-108355a.vbox-extpack 05-Dec-2016 18:01 16M
      Oracle_VM_VirtualBox_Extension_Pack-5.0.24.vbox-extpack 05-Dec-2016 18:01 16M
http://download.virtualbox.org/virtualbox/5.0.24/SHA256SUMS
^^

Pré-configurando pacotes ...
A seleccionar pacote anteriormente não seleccionado virtualbox-ext-pack.
(Lendo banco de dados ... 366643 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../virtualbox-ext-pack_5.0.24-0ubuntu1.16.04.1_all.deb ...
License has already been accepted.
A descompactar virtualbox-ext-pack (5.0.24-0ubuntu1.16.04.1) ...
Configurando virtualbox-ext-pack (5.0.24-0ubuntu1.16.04.1) ...
virtualbox-ext-pack: downloading: http://download.virtualbox.org/virtualbox/5.0.24/Oracle_VM_VirtualBox_Extension_Pack-5.0.24.vbox-extpack
The file will be downloaded into /usr/share/virtualbox-ext-pack
0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to install "/usr/share/virtualbox-ext-pack/Oracle_VM_VirtualBox_Extension_Pack-5.0.24.vbox-extpack"
VBoxManage: error: VBoxExtPackRegister returned VERR_VERSION_MISMATCH, pReg=0000000000000000 ErrInfo='VirtualBox version mismatch - expected 5.0 got 5.1'
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ExtPackManagerWrap, interface IExtPackManager
VBoxManage: error: Context: "RTEXITCODE handleExtPack(HandlerArg*)" at line 1158 of file VBoxManageMisc.cpp
dpkg: erro ao processar o pacote virtualbox-ext-pack (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 1
E: Sub-process /usr/bin/dpkg returned an error code (1)
Um pacote falhou na instalação. Tentando recuperar:
Configurando virtualbox-ext-pack (5.0.24-0ubuntu1.16.04.1) ...
virtualbox-ext-pack: downloading: http://download.virtualbox.org/virtualbox/5.0.24/Oracle_VM_VirtualBox_Extension_Pack-5.0.24.vbox-extpack
The file will be downloaded into /usr/share/virtualbox-ext-pack
0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to install "/usr/share/virtualbox-ext-pack/Oracle_VM_VirtualBox_Extension_Pack-5.0.24.vbox-extpack"
VBoxManage: error: VBoxExtPackRegister returned VERR_VERSION_MISMATCH, pReg=0000000000000000 ErrInfo='VirtualBox version mismatch - expected 5.0 got 5.1'
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ExtPackManagerWrap, interface IExtPackManager
VBoxManage: error: Context: "RTEXITCODE handleExtPack(HandlerArg*)" at line 1158 of file VBoxManageMisc.cpp
dpkg: erro ao processar o pacote virtualbox-ext-pack (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
 virtualbox-ext-pack

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1
ProcVersionSignature: Ubuntu 4.4.0-31.50-lowlatency 4.4.13
Uname: Linux 4.4.0-31-lowlatency x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.1
AptOrdering:
 virtualbox-ext-pack: Install
 virtualbox-ext-pack: Configure
 NULL: ConfigurePending
Architecture: amd64
Date: Fri Jul 22 20:18:24 2016
ErrorMessage: sub-processo script post-installation instalado retornou estado de saída de erro 1
InstallationDate: Installed on 2016-07-19 (3 days ago)
InstallationMedia: Ubuntu-Studio 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: virtualbox-ext-pack
Title: package virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 failed to install/upgrade: sub-processo script post-installation instalado retornou estado de saída de erro 1
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
NKStudio (macerapa) wrote :
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

if you use virtualbox from official website, you should use the ext pack from there too

Changed in virtualbox-ext-pack (Ubuntu):
status: New → Incomplete
status: Incomplete → Invalid
Revision history for this message
Dan Christian (danchristian65) wrote :

I have the same problem, and I do not have Oracle's version installed. This should be re-opened.

$ dpkg -l virtualbox
dpkg-query: no packages found matching virtualbox

sudo apt-get install virtualbox-ext-pack unity-scope-virtualbox virtualbox virtualbox-dkms virtualbox-guest-additions-iso virtualbox-qt
...
Errors were encountered while processing:
 virtualbox-ext-pack

$ dpkg -l virtualbox\* | grep '^i'
ii virtualbox 5.0.24-dfsg-0ubuntu1.16.04.1 amd64 x86 virtualization solution - base binaries
ii virtualbox-dkms 5.0.24-dfsg-0ubuntu1.16.04.1 all x86 virtualization solution - kernel module sources for dkms
iF virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 all extra capabilities for VirtualBox, downloader.
ii virtualbox-guest-additions-iso 5.0.24-0ubuntu1.16.04.1 all guest additions iso image for VirtualBox
ii virtualbox-qt 5.0.24-dfsg-0ubuntu1.16.04.1 amd64 x86 virtualization solution - Qt based user interface

$ sudo apt-get install virtualbox-ext-pack
Reading package lists... Done
Building dependency tree
Reading state information... Done
virtualbox-ext-pack is already the newest version (5.0.24-0ubuntu1.16.04.1).
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-45 linux-headers-4.4.0-45-generic linux-image-4.4.0-45-generic linux-image-extra-4.4.0-45-generic linux-tools-4.4.0-45
  linux-tools-4.4.0-45-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up virtualbox-ext-pack (5.0.24-0ubuntu1.16.04.1) ...
virtualbox-ext-pack: downloading: http://download.virtualbox.org/virtualbox/5.0.24/Oracle_VM_VirtualBox_Extension_Pack-5.0.24.vbox-extpack
The file will be downloaded into /usr/share/virtualbox-ext-pack
Hash mismatch Oracle_VM_VirtualBox_Extension_Pack-5.0.24.vbox-extpack
dpkg: error processing package virtualbox-ext-pack (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 virtualbox-ext-pack
E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
Dan Christian (danchristian65) wrote : Re: [Bug 1605799] Re: package virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 failed to install/upgrade: sub-processo script post-installation instalado retornou estado de saída de erro 1
Download full text (6.5 KiB)

I think this may actually be an Oracle bug. The setup is clearly
installing a 5.0.24 file and getting 5.1 contents.

On Dec 5, 2016 5:25 PM, "Dan Christian" <email address hidden> wrote:

I have the same problem, and I do not have Oracle's version installed.
This should be re-opened.

$ dpkg -l virtualbox
dpkg-query: no packages found matching virtualbox

sudo apt-get install virtualbox-ext-pack unity-scope-virtualbox virtualbox
virtualbox-dkms virtualbox-guest-additions-iso virtualbox-qt
...
Errors were encountered while processing:
 virtualbox-ext-pack

$ dpkg -l virtualbox\* | grep '^i'
ii virtualbox 5.0.24-dfsg-0ubuntu1.16.04.1 amd64
  x86 virtualization solution - base binaries
ii virtualbox-dkms 5.0.24-dfsg-0ubuntu1.16.04.1 all
  x86 virtualization solution - kernel module sources for dkms
iF virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 all
  extra capabilities for VirtualBox, downloader.
ii virtualbox-guest-additions-iso 5.0.24-0ubuntu1.16.04.1 all
  guest additions iso image for VirtualBox
ii virtualbox-qt 5.0.24-dfsg-0ubuntu1.16.04.1 amd64
  x86 virtualization solution - Qt based user interface

$ sudo apt-get install virtualbox-ext-pack
Reading package lists... Done
Building dependency tree
Reading state information... Done
virtualbox-ext-pack is already the newest version (5.0.24-0ubuntu1.16.04.1).
The following packages were automatically installed and are no longer
required:
  linux-headers-4.4.0-45 linux-headers-4.4.0-45-generic
linux-image-4.4.0-45-generic linux-image-extra-4.4.0-45-generic
linux-tools-4.4.0-45
  linux-tools-4.4.0-45-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up virtualbox-ext-pack (5.0.24-0ubuntu1.16.04.1) ...
virtualbox-ext-pack: downloading: http://download.virtualbox.
org/virtualbox/5.0.24/Oracle_VM_VirtualBox_Extension_Pack-
5.0.24.vbox-extpack
The file will be downloaded into /usr/share/virtualbox-ext-pack
Hash mismatch Oracle_VM_VirtualBox_Extension_Pack-5.0.24.vbox-extpack
dpkg: error processing package virtualbox-ext-pack (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 virtualbox-ext-pack
E: Sub-process /usr/bin/dpkg returned an error code (1)

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1605799

Title:
  package virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 failed to
  install/upgrade: sub-processo script post-installation instalado
  retornou estado de saída de erro 1

Status in virtualbox-ext-pack package in Ubuntu:
  Invalid

Bug description:
  Pré-configurando pacotes ...
  A seleccionar pacote anteriormente não seleccionado virtualbox-ext-pack.
  (Lendo banco de dados ... 366643 ficheiros e directórios actualmente
instalados.)
  A preparar para desempacotar
.../virtualbox-ext-pack_5.0.24-0ubuntu1.16.04.1_all.deb
...
  License has already been accepted.
...

Read more...

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote : Re: package virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 failed to install/upgrade: [SRU] sub-processo script post-installation instalado retornou estado de saída de erro 1

I pushed the fix, upstream changed the file remotely

Changed in virtualbox-ext-pack (Ubuntu):
status: Invalid → Fix Committed
summary: package virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 failed to
- install/upgrade: sub-processo script post-installation instalado
+ install/upgrade: [SRU] sub-processo script post-installation instalado
retornou estado de saída de erro 1
description: updated
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :
Changed in virtualbox-ext-pack (Ubuntu):
status: Fix Committed → Fix Released
Changed in virtualbox-ext-pack (Ubuntu Xenial):
status: New → Fix Committed
Changed in virtualbox-ext-pack (Ubuntu Yakkety):
status: New → Fix Committed
Changed in virtualbox-ext-pack (Ubuntu Xenial):
importance: Undecided → Critical
Changed in virtualbox-ext-pack (Ubuntu Yakkety):
importance: Undecided → Critical
Changed in virtualbox-ext-pack (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Justin Dugger (jldugger) wrote :

Is this fix released? Both launchpad and http://packages.ubuntu.com/xenial-updates/virtualbox-ext-pack list 5.0.24-0ubuntu1.16.04.1 as the current version,

Changed in virtualbox-ext-pack (Ubuntu Xenial):
status: Fix Released → Fix Committed
Revision history for this message
mirak (mirak-mirak) wrote :

I have that issue right now, so this is not fixed.

Revision history for this message
Dan Christian (danchristian65) wrote :

I was able to work around this in the short term.

This package is really just a script that downloads the file, checks it, and installs it using the virtualbox extension manager. The check is failing, but you can manually do steps 1 and 3.

List the package scripts for details. It shows the file it's downloading when you try to install the package. You'll have to do that again by hand because dpkg cleans out the old one after the install fails. Then call the "virtualbox extension add FILE" (this is from memory, so that may not be exact).

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

yes, not fixed. You can wait a little more for release-team to accept it in proposed, or use my ppa
https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/virtualbox-ppa

summary: - package virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 failed to
- install/upgrade: [SRU] sub-processo script post-installation instalado
+ [SRU] package virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.1 failed to
+ install/upgrade: sub-processo script post-installation instalado
retornou estado de saída de erro 1
Revision history for this message
Alan Marcel (amarcel) wrote :

Hello! There any plans to fix this bug? It is affecting me on:

Distributor ID: LinuxMint
Description: Linux Mint 18 Sarah
Release: 18
Codename: sarah

Best regards.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I pinged release team some seconds ago on irc

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :
Revision history for this message
Alan Marcel (amarcel) wrote :

Thank you Locutus! It is working fine now...

Regards!

Revision history for this message
Brian Murray (brian-murray) wrote :

@LocutusOfBorg - Your description would have been much more helpful if you had actually referenced 5.1.6 (the one you changed) instead of 5.0.24 (the one in the description).

tags: added: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello NKStudio, or anyone else affected,

Accepted virtualbox-ext-pack into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-ext-pack/5.1.6-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Brian Murray (brian-murray) wrote :

Hello NKStudio, or anyone else affected,

Accepted virtualbox-ext-pack into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-ext-pack/5.0.24-0ubuntu1.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

@brian-murray, actually the bug refers to xenial (5.0.24) and yakkety (5.1.6) I just avoided two uploads closing two different bugs, because it is actually the same issue.
I tested both, and the sha256sum verification is now correct in both xenial and yakkety.

thanks!

tags: added: verification-done verification-done-xenial verification-done-yakkety
removed: verification-needed
Revision history for this message
blong (b-long) wrote :

If I do attempt to install from the proposed repository (following [this guide](https://wiki.ubuntu.com/Testing/EnableProposed)) - Is it simple enough to revert? Will I be able to keep `virtualbox-ext-pack 5.0.24-0ubuntu1.16.04.2` and disable the proposed repo?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

enable proposed,
apt-get update && apt-get install virtualbox-ext-pack
disable proposed.

this will just install it, and when it lands in release it will appear there too.

Revision history for this message
Daniel Muller (daniel-muller) wrote :

Just confirming that installing from yakkety-proposed worked

Revision history for this message
Alberto Almeida (albertocalmeida) wrote :

Had same issue after (messy) upgrade to Ubuntu 16.10.

Installing from yakkety-proposed worked for me as well.

Revision history for this message
omnihaand (fpari82) wrote :

Confirmed: Xenial-proposed does work around the install problem.

----------------------------------------------------------------
The following NEW packages will be installed:
  virtualbox-ext-pack
0 upgraded, 1 newly installed, 0 to remove and 101 not upgraded.
Need to get 11.7 kB of archives.
After this operation, 129 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu xenial-proposed/multiverse amd64 virtualbox-ext-pack all 5.0.24-0ubuntu1.16.04.2 [11.7 kB]
Fetched 11.7 kB in 0s (17.9 kB/s)
Preconfiguring packages ...
Selecting previously unselected package virtualbox-ext-pack.
(Reading database ... 321983 files and directories currently installed.)
Preparing to unpack .../virtualbox-ext-pack_5.0.24-0ubuntu1.16.04.2_all.deb ...
License has already been accepted.
Unpacking virtualbox-ext-pack (5.0.24-0ubuntu1.16.04.2) ...
Setting up virtualbox-ext-pack (5.0.24-0ubuntu1.16.04.2) ...
virtualbox-ext-pack: downloading: http://download.virtualbox.org/virtualbox/5.0.24/Oracle_VM_VirtualBox_Extension_Pack-5.0.24.vbox-extpack
The file will be downloaded into /usr/share/virtualbox-ext-pack
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully installed "Oracle VM VirtualBox Extension Pack".

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ext-pack - 5.1.6-2ubuntu1

---------------
virtualbox-ext-pack (5.1.6-2ubuntu1) yakkety; urgency=medium

  * Fix SHA256 sum, after upstream change. (LP: #1605799)

 -- Gianfranco Costamagna <email address hidden> Tue, 06 Dec 2016 15:35:33 +0100

Changed in virtualbox-ext-pack (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for virtualbox-ext-pack has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ext-pack - 5.0.24-0ubuntu1.16.04.2

---------------
virtualbox-ext-pack (5.0.24-0ubuntu1.16.04.2) xenial; urgency=medium

  * Fix SHA256 sum, after upstream change. (LP: #1605799)

 -- Gianfranco Costamagna <email address hidden> Tue, 06 Dec 2016 15:27:25 +0100

Changed in virtualbox-ext-pack (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers