Keyboard mapping is not correct in the guest

Bug #524318 reported by Ara Pulido on 2010-02-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned
virtinst (Ubuntu)
Undecided
Marc Deslauriers

Bug Description

Binary package hint: qemu-kvm

Using latest qemu-kvm package in Lucid, with both Ubuntu Server 8.04 and latest Lucid Ubuntu Server as guests.

During the installation of the guest OS, I select Spain - Spain as the keyboard mapping. When the installation finishes and I reboot in the new installed system, the keyboard mapping is not 100% correct.

*Example of a mapping working correctly:*
"ñ", as special character in Spanish, and it is mapped correctly

*Example of a mapping NOT working correctly:*
In a Spanish keyboard, pressing Shift+0, should type "=", but in KVM it types something different.
In general, every special and punctuation characters ("_", ".", ";", "@",..., ...) are not mapped correctly.

I wonder if this happens in other keyboard mapping as well.

ProblemType: Bug
Architecture: i386
CheckboxSubmission: a08fd14ff73f03f0a48f9e6d0af6c8e2
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Fri Feb 19 10:44:01 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
KvmCmdLine: Error: command ['ps', '-C', 'kvm', '-F'] failed with exit code 1: UID PID PPID C SZ RSS PSR STIME TTY TIME CMD
MachineType: LENOVO 7664R5G
NonfreeKernelModules: nvidia
Package: qemu-kvm 0.12.2-0ubuntu7
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-13-generic root=UUID=d72973b5-9d42-4204-a98d-6705012b09bb ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
SourcePackage: qemu-kvm
Uname: Linux 2.6.32-13-generic i686
dmi.bios.date: 08/15/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 7LETC4WW (2.24 )
dmi.board.name: 7664R5G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7LETC4WW(2.24):bd08/15/2008:svnLENOVO:pn7664R5G:pvrThinkPadT61:rvnLENOVO:rn7664R5G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7664R5G
dmi.product.version: ThinkPad T61
dmi.sys.vendor: LENOVO

Ara Pulido (ara) wrote :

Ara-

Could you have a look at Bug #524439 and see if it's the same issue?

Dustin Kirkland  (kirkland) wrote :

Hmm, maybe not, since you tried 8.04 too.

Can you try adding the -k option?

See:
 * http://manpages.ubuntu.com/manpages/lucid/en/man1/kvm.1.html

Ara Pulido (ara) wrote :

This bug does not happen when starting the machine from the command line with qemu.

It only happens for machines in virt-manager. Changing the package

Changed in qemu:
status: New → Invalid
affects: qemu-kvm (Ubuntu) → virt-manager (Ubuntu)
Dustin Kirkland  (kirkland) wrote :

Ah, interesting. I bet it's the -k option that's getting you.

Ara, can you post "ps -ef | grep kvm" for each of the two runs, the
working one with kvm from the command line and the one from
virt-manager?

I'm betting virt-manager is adding something to the command line
that's breaking you. Probably -k.

Ara Pulido (ara) wrote :

Good catch!

Virt-manager always adds "-k en-us" to kvm command :-(

Dustin Kirkland  (kirkland) wrote :

Hmm, there's got to be a way to override this in Virt-manager...

Might have to ask upstream. Try #virt in irc.oftc.net.

Marc Deslauriers (mdeslaur) wrote :

This is actually a bug in lucid's virtinst. I'll take care of it.

affects: virt-manager (Ubuntu) → virtinst (Ubuntu)
Changed in virtinst (Ubuntu):
status: New → Confirmed
assignee: nobody → Marc Deslauriers (mdeslaur)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtinst - 0.500.1-2ubuntu2

---------------
virtinst (0.500.1-2ubuntu2) lucid; urgency=low

  * debian/patches/0003-Fix-patch-to-keyboard-configuration.patch: disable
    as the keyboard config in Ubuntu is still in /etc/default/console-setup
    and this was causing virt-manager to always default to a en-us
    keyboard. (LP: #524318)
  * debian/patches/9002-add-ca-keymap.patch: Add French Canadian keymap to
    virtinst/keytable.py.
 -- Marc Deslauriers <email address hidden> Thu, 04 Mar 2010 10:03:41 -0500

Changed in virtinst (Ubuntu):
status: Confirmed → Fix Released
Ara Pulido (ara) wrote :

This is still happening with the latest versions of virt-manager and virtinst.

Virt Manager keeps adding the "-k en-us" option, making non en-us keyboards work incorrectly.

Changed in virtinst (Ubuntu):
status: Fix Released → New
Ara Pulido (ara) wrote :

ara@sushirider:~$ apt-cache policy virt-manager
virt-manager:
  Installed: 0.8.2-2ubuntu8
  Candidate: 0.8.2-2ubuntu8
  Version table:
 *** 0.8.2-2ubuntu8 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
ara@sushirider:~$ apt-cache policy virtinst
virtinst:
  Installed: 0.500.1-2ubuntu6
  Candidate: 0.500.1-2ubuntu6
  Version table:
 *** 0.500.1-2ubuntu6 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Marc Deslauriers (mdeslaur) wrote :

@Ara: Is this for newly created VMs, or for the VMs you already had?

Ara Pulido (ara) wrote :

Sorry for the reopening. It works correctly when creating new virtual machines.

Changed in virtinst (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers