must depend on libvirt-bin and python-libvirt

Bug #215084 reported by Thom May on 2008-04-10
4
Affects Status Importance Assigned to Milestone
virtinst (Debian)
Fix Released
Unknown
virtinst (Ubuntu)
Low
Unassigned
Nominated for Gutsy by Jeff Buchbinder

Bug Description

Binary package hint: python-virtinst

Setting up python-virtinst (0.300.2-0ubuntu3) ...

PATH= sudo apt-get install python-virtinst 3.31s user 1.20s system 10% cpu 43.045 total
: 14:27 ~ % virt-install
Traceback (most recent call last):
  File "/usr/bin/virt-install", line 32, in <module>
    import libvirt
ImportError: No module named libvirt
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/apport_python_hook.py", line 38, in apport_excepthook
    from apport.fileutils import likely_packaged
  File "/usr/lib/python2.5/site-packages/apport/__init__.py", line 1, in <module>
    from apport.report import Report
  File "/usr/lib/python2.5/site-packages/apport/report.py", line 21, in <module>
    import fileutils
  File "/usr/lib/python2.5/site-packages/apport/fileutils.py", line 16, in <module>
    from packaging_impl import impl as packaging
  File "/usr/lib/python2.5/site-packages/apport/packaging_impl.py", line 18, in <module>
    import apt
  File "/usr/lib/python2.5/site-packages/apt/__init__.py", line 8, in <module>
    from apt.cache import Cache
  File "/usr/lib/python2.5/site-packages/apt/cache.py", line 24, in <module>
    import apt.progress
  File "/usr/lib/python2.5/site-packages/apt/progress.py", line 166
    " called when the status changed "
                                     ^
TabError: inconsistent use of tabs and spaces in indentation

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/virt-install", line 32, in <module>
    import libvirt
ImportError: No module named libvirt
[1] 7548 exit 1 virt-install

If only python-libvirt is installed:
: 14:31 ~ % sudo virt-install
Thu, 10 Apr 2008 14:31:25 ERROR virConnectOpen() failed
Traceback (most recent call last):
  File "/usr/bin/virt-install", line 517, in <module>
    main()
  File "/usr/bin/virt-install", line 364, in main
    conn = cli.getConnection(options.connect)
  File "/usr/lib/python2.5/site-packages/virtinst/cli.py", line 75, in getConnection
    return libvirt.open(connect)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 135, in open
    if ret is None:raise libvirtError('virConnectOpen() failed')
libvirtError: virConnectOpen() failed

Jeff Buchbinder (rufustfirefly) wrote :

This package definitely requires libvirt-bin and python-libvirt to be useful at all, since otherwise libvirtd could not be run.

Changed in virtinst:
status: New → Confirmed
Soren Hansen (soren) wrote :

The most recent version of python-virtinst depends on "python-libvirt (>= 0.4.0-2ubuntu8)". libvirt-bin is still not (and shouldn't be) a hard dependency. It probably should be a Recommends, though.

Changed in virtinst:
importance: Undecided → Low
Thom May (thombot) wrote :

I think Recommends: is definitely warranted. Or make it really clear in the help output and manpage how and why you should specify another hypervisor.

Changed in virtinst (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtinst - 0.500.1-2ubuntu1

---------------
virtinst (0.500.1-2ubuntu1) lucid; urgency=low

  * Merge from debian testing. Remaining changes (LP: #509800):
    - debian/patches/9001_Ubuntu.patch:
      + Added lucid and enable virtio for it.
    - Demote virt-viewer to Suggests, as it's in universe.
  * Rename python-virtinst to virtinst and add transitional package
  * Do not use python-central anymore
  * Recommends libvirt-bin (LP: #215084)

virtinst (0.500.1-2) unstable; urgency=low

  [ Laurent Léonard ]
  * [701d192] Fix path to keyboard configuration.
  * [f11662f] Allow DM upload and add myself as uploader.
  * [cf14c53] Clean debian/watch.

virtinst (0.500.1-1) unstable; urgency=low

  [ Laurent Léonard ]
  * [86218c1] Imported Upstream version 0.500.1
  * [370e65b] Drop patches.
      * 0003-Don-t-use-virtio-for-cdrom-floppy- devices.patch - fixed
        upstream.
      * 0004-Add-error-handling-to- VirtualDisk._clone_local.patch - applied
        upstream.
  * [21cd5ab] Remove debian/pycompat from debian/rules clean target. Since
    CDBS 0.4.6 doesn't create debian/pycompat when debian/pyversions is set.

virtinst (0.500.0-3) unstable; urgency=low

  * [7b2d9d5] Add error handling to VirtualDisk._clone_local (Closes: #555748)

virtinst (0.500.0-2) unstable; urgency=low

  [ Laurent Léonard ]
  * [2060102] Bump Debhelper version to 7.
  * [effbb27] Bump Standards-Version to 3.8.3.
  * [babcc4b] Clean debian/rules.
  * [6bb175f] Remove debian/pycompat. According to python-support
    recommendations. Also remove it in debian/rules clean target (see
    #424898).

  [ Guido Günther ]
  * [ff8cee7] Don't use virtio for cdrom/floppy devices Patch pulled
    from upstream HG. (Closes: #553171) - thanks to Harald Dunkel

virtinst (0.500.0-1) unstable; urgency=low

  * [75709b9] bump standards version
  * [d275b5a] Imported Upstream version 0.500.0
  * [be8497e] drop patches applied upstream:
        0003-allow-to-pass-nic-model.patch
        0004-parse-etc-default-console-setup-for-keymap-informati.patch
        0005-use-QEMU-s-USB-Tablet-with-Squeeze-guests.patch
        0006-add-Ubuntu-Karmic-to-osdict.patch
        0007-fix-bridge-names-not-ending-with-digit.patch
        0008-Turn-on-ACPI-APIC-for-Windows-except-for-Xen-3.1.0.patch
        0009-Add-Windows-7-to-the-osdict.patch

virtinst (0.400.3-5) unstable; urgency=low

  [ Guido Günther ]
  * [d1f073b] add Ubuntu Karmic to osdict (Closes: #532531) - thanks to
    Christophe Sauthier
  * [a008f8b] fix bridge names not ending with digit. Pulled from upstream.
    (Closes: #533539) - thanks to Cole Robinso for the fix and Andreas
    Unterkircher for testing

  [ Laurent Léonard ]
  * [16b8a6c] Turn on ACPI/APIC for Windows, except for Xen < 3.1.0.
    Pulled from upstream. (Closes: #533201) - thanks to Cole Robinson
  * [3840c11] Add Windows 7 to the osdict. (Closes: #535781)
 -- Laurent Bigonville <email address hidden> Tue, 19 Jan 2010 21:19:47 +0100

Changed in virtinst (Ubuntu):
status: Confirmed → Fix Released
Changed in virtinst (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.