virt-manager does not display proper error dialog

Bug #998724 reported by Evren Yurtesen on 2012-05-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Undecided
Marc Deslauriers
Precise
Undecided
Marc Deslauriers
Quantal
Undecided
Marc Deslauriers

Bug Description

Test case:
1- Install virt-manager on a new Precise installation without adding user to libvirtd group
2- Launch it with virt-manager --debug
3- Notice error on console, and no error dialog to inform user

on Ubuntu 12.04 LTE the virt-manager does not function after installation.

The installation is done by following:
https://help.ubuntu.com/community/KVM/Installation

The message is:
Error: No active connection to install on.

I have found a forum entry where other people were having the same problem and there are more details there:
http://ubuntuforums.org/showthread.php?t=1976578

Evren Yurtesen (eyurtese-g) wrote :

It appears it is working when virt-manager is executed by root and bios has virtualization enabled (perhaps the packages should check this automatically eh?'

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/998724/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Robert Roth (evfool) on 2012-05-13
affects: ubuntu → virt-manager (Ubuntu)

I could resolve this issue by adding my user to kvm and libvirtd groups.

$ sudo adduser `id -un` kvm
$ sudo adduser `id -un` libvirtd

I believe the installer either should suggest adding the user to these groups or virt-manager should become root by asking credentials at startup.

After adding myself to groups, I got stuck at the following reported problem:
https://bugs.launchpad.net/ubuntu/+source/virt-manager/+bug/920853

Marc Deslauriers (mdeslaur) wrote :

virt-manager should pop up an error message indicating that your are not in the libvirtd group. Because of an incorrect patch, this isn't working properly. I will release an SRU to correct this.

summary: - virt-manager does not fuunction after installation
+ virt-manager does not display proper error dialog
Changed in virt-manager (Ubuntu Precise):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in virt-manager (Ubuntu Quantal):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in virt-manager (Ubuntu Precise):
status: New → Confirmed
Changed in virt-manager (Ubuntu Quantal):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 0.9.1-3ubuntu1

---------------
virt-manager (0.9.1-3ubuntu1) quantal; urgency=low

  * Merge from debian unstable. Remaining changes:
    - debian/control, debian/rules: Build using dh_python2
    - debian/control: Depend on python-appindicator for appindicator
      support.
    - Add a /usr/share/pixmaps/virt-manager-icon.svg symlink to link icon to
      where the Application Indicator can find it.
    - debian/patches/more_helpful_error_message.patch: explain to the user
      why he can't connect to qemu:///system and what he can do fix it.
    - debian/control: drop python-spice-client-gtk to Suggests as it is in
      universe.
    - debian/patches/use_ubuntu_package_names.patch: Suggest installing the
      packages that are actually available in Ubuntu.
    - debian/rules: Set qemu user to libvirt-qemu so appropriate
      permissions get set.
    - debian/rules: Set Ubuntu as the preferred distro so we appear first
      in the list.
    - debian/rules: disable TUI for now, since the required dependencies
      are not available (Newt Syrup).
    - debian/rules: Drop patchsys-quilt include since dpkg-source does the
      quilt dance for us.
    - Removed python-ipy dependency as it is in universe:
      - debian/control: remove python-ipy from Depends
      - debian/series: disable 0002-Use-IPy-from-python-ipy.patch patch so
        we use the one that's included in the virt-manager source.
      - debian/rules: don't delete the IPy file.
    - debian/patches/fork_before_gtk_import.patch: work around global menu
      and appindicator not working correctly by forking before the gtk
      import.
    - debian/patches/fix_accidental_recursion.patch: fix accidental recursion
      when reporting grab keys.
    - debian/patches/fix_listen_address.patch: fix connecting when graphics
      configuration uses graphics attribute.
    - debian/patches/fix_dbus_deprecation_warning.patch: fix deprecation
      warning by switching to new way of setting up the event loop.
  * Removed patches:
    - debian/patches/fix_error_reporting.patch: has equivalent Debian
      patch.
  * Dropped changes:
    - debian/control: lower libvirt-bin from Recommends to Suggests: we
      depend on python-libvirt which in turn pulls in libvirt-bin anyway.
  * debian/patches/fix_listen_address.patch: updated again to prevent
    regression when the remote server has a listen attribute that specifies
    "0.0.0.0". (LP: #837275)
  * debian/patches/more_helpful_error_message.patch: updated for new
    version and to fix error dialog. (LP: #998724)

virt-manager (0.9.1-3) unstable; urgency=low

  * [a1de813] Add presubj file to (hopefully) increase the bug report quality.

virt-manager (0.9.1-2) unstable; urgency=low

  * [d0d2014] manager: Fix error reporting when can't connect remotely.
    Thanks to Cole Robinson (Closes: #659860)
 -- Marc Deslauriers <email address hidden> Thu, 24 May 2012 11:13:42 -0400

Changed in virt-manager (Ubuntu Quantal):
status: Confirmed → Fix Released
Marc Deslauriers (mdeslaur) wrote :

SRU Request:

Impact: Users who run virt-manager for the first time don't get the proper error dialog informing them that they need to be in the libvirtd group

Development Fix: This has been fixed in Quantal by removing the superfluous line and extra comma from the broken patch

Stable fix: A minimal debdiff was prepared that fixes the broken patch in the same way

Test case:
1- Install virt-manager on a new Precise installation without adding user to libvirtd group
2- Launch it with virt-manager --debug
3- Notice error on console, and no error dialog to inform user

Regression potential:
The bad patch results in a python error, so the chances that this could get even worse are slim. Only the code path for the error dialog is changed, so regular users won't see the change.

Marc Deslauriers (mdeslaur) wrote :
description: updated

Hello Evren, or anyone else affected,

Accepted virt-manager into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in virt-manager (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

I can confirm that the update displays the error dialog correctly

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 0.9.1-1ubuntu5.1

---------------
virt-manager (0.9.1-1ubuntu5.1) precise-proposed; urgency=low

  * debian/patches/fix_listen_address.patch: updated again to prevent
    regression when the remote server has a listen attribute that specifies
    "0.0.0.0". (LP: #837275)
  * debian/patches/more_helpful_error_message.patch: remove superfluous
    line and extra comma to fix error dialog. (LP: #998724)
 -- Marc Deslauriers <email address hidden> Thu, 24 May 2012 15:35:48 -0400

Changed in virt-manager (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers