In the guest I cant get out of fullscreen mode

Bug #772729 reported by mbn18 on 2011-04-28
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Medium
Marc Deslauriers
Natty
Medium
Marc Deslauriers
Oneiric
Medium
Marc Deslauriers

Bug Description

Binary package hint: virt-manager

I found a hack way to get to the menu.
I click ctr+alt+T and a terminal is open.
Then I close the terminal and then I can access the top unity commands (file,edit,etc) where I can get out of fullscreen mode

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: virt-manager 0.8.6-1ubuntu8
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Fri Apr 29 00:37:42 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: virt-manager
UpgradeStatus: No upgrade log present (probably fresh install)

mbn18 (miki) wrote :
Marc Deslauriers (mdeslaur) wrote :

Hmm...yeah, this seems to be caused by indicator-appmenu...when virt-manager is full screen, we're still supposed to see the menu, to be able to exit fullscreen mode, but with appmenu, the menu is hidden...

Changed in virt-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in virt-manager (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in virt-manager (Ubuntu Oneiric):
assignee: nobody → Marc Deslauriers (mdeslaur)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 0.8.7-1ubuntu2

---------------
virt-manager (0.8.7-1ubuntu2) oneiric; urgency=low

  * debian/patches/fullscreen_show_toolbar.patch: When switching to fullscreen
    under Unity, the top menu bar doesn't display anymore, so there's no
    way to exit fullscreen mode. This patch displays the toolbar when in
    fullscreen to work around the issue. It also hides the menu so it
    doesn't waste more real estate when using the classic desktop.
    (LP: #772729)
 -- Marc Deslauriers <email address hidden> Wed, 18 May 2011 17:08:51 -0400

Changed in virt-manager (Ubuntu Oneiric):
status: Confirmed → Fix Released
Marc Deslauriers (mdeslaur) wrote :

SRU Request:

Impact: virt-manager users on natty cannot exit fullscreen mode because of appmenu. Normally the full-screen window draws the menubar at the top that contains the fullscreen toggle. With Unity, the menu no longer appears, rendering it impossible to exit fullscreen mode.

This bug has been addressed by making the fullscreen window display the toolbar, which contains a fullscreen button that can be clicked to exit fullscreen mode. See attached debdiff.

How to reproduce (under Unity):
1- Open virt-manager
2- Double click on a virtual machine
3- Click the fullscreen button
4- Notice there is no way to exit fullscreen mode

Test procedure:
1- Open virt-manager
2- Double click on a virtual machine
3- Click the fullscreen button
4- Check if toolbar is being displayed, and exit fullscreen mode with toolbar button

Marc Deslauriers (mdeslaur) wrote :

Accepted virt-manager into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in virt-manager (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Tom Ellis (tellis) wrote :

I tested the fix in natty-proposed (virt-manager 0.8.6-1ubuntu8.1), and the menu is now displayed when in fullscreen mode. So, this fix works for me.

Thanks.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 0.8.6-1ubuntu8.1

---------------
virt-manager (0.8.6-1ubuntu8.1) natty-proposed; urgency=low

  * debian/patches/fullscreen_show_toolbar.patch: When switching to fullscreen
    under Unity, the top menu bar doesn't display anymore, so there's no
    way to exit fullscreen mode. This patch displays the toolbar when in
    fullscreen to work around the issue. It also hides the menu so it
    doesn't waste more real estate when using the classic desktop.
    (LP: #772729)
 -- Marc Deslauriers <email address hidden> Wed, 18 May 2011 16:57:38 -0400

Changed in virt-manager (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers