Sending Ctrl + Alt + Delete to VM does nothing

Bug #680720 reported by Stephan Wienczny on 2010-11-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager
Fix Released
Critical
virt-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: virt-manager

When trying to sent the combination "Ctrl + Alt + Del" to a VM using the menu shortcut nothing happens. This is really annoying because "Ctrl + Alt + Del" can cause a reboot of the host, when the keyboard focus is not properly inside the VM ;-(

Maverick x64
virt-manager 0.8.4-7ubuntu1

Description of problem:
It's not able to send Ctrl+Alt+key shortcut to a Guest (Both RHEL and Windows)

Version-Release number of selected component (if applicable):
spice-client-0.7.2-1.el6.x86_64
qspice-libs-0.3.0-54.el5_5.2
kvm-83-224.el5
(RHEVM2.3 only)

How reproducible:
Always

Steps to Reproduce:
1. Log in RHEL guest or Windwos guest with using spice client running on RHEL6.
2. Try to use Ctrl+Alt+key (for example switching to console or setting keyboard shortcut, unlocking session in Windows).

Actual results:
Last key will be sent to a guest.

Expected results:
Whole shortcut should be sent to a guest.

Additional info:
* It does work with RHEVM22, qspice-libs-0.3.0-54.el5.5.2, kvm-83-164.el5_5.23.
* Works with Windows client.
* Gnome keyboard shortcut returns only last key.

Marc Deslauriers (mdeslaur) wrote :

I can't reproduce this. What guest OS are you running in the VM?

Changed in virt-manager (Ubuntu):
status: New → Incomplete

I'm running Ubuntu 10.10 Server and Windows 2008 R2 inside the VM. The OS inside the VM does not matter. It is reproducible on both. Tested using these steps:

1. Start VM
2. Hit 'Send Key'->'Ctrl+Alt+Delete'
- See that nothing happens. On Win2k no login screen, on Ubuntu no reboot.
3. Set the focus to the VM using the mouse.
4. Hit 'Ctrl+Alt+Delete' on the Keyboard.
- See that it works.

Since the report I updated the host to natty and the bug is still there. Im using KDE on the Host but that should not be the cause.
virt-manager 0.8.6-1ubuntu1

Marc Deslauriers (mdeslaur) wrote :

Out of curiosity, what keyboard is set under the Display device for your guests?

Changed in virt-manager (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Low

The keymap is set to "Auto".

After manually setting the keymap to "de" (my hosts keymap) the bug is gone.

It seems the problem is that pressing ctrl releases the sticky-alt.

I've tried to reproduce this with the 0.7.2 X11 client and it works fine for me. Also this is all handled on the client side, so it working when connecting to a RHEV-2.2 host, and not when connecting to a RHEV-2.3 host seems weird.

Closing this as works for me. Please re-open with some more detailed information (such as indicating package versions on all 3 of guest, host and client) if you are still seeing this.

You are aware of the use of sticky alt to send special key combis like this ? Keep alt pressed until an ALT icon overlay shows in the center of the client then press ctrl + key to send alt + ctrl + key.

mattsteven (matthew-matts) wrote :

The virt-manager documentation points out that you need something to be listening for acpi events on the guest. Since your guest may not have acipd configured or installed, install it and signals like this will work properly.

Reproduced again

My setup is:

spice-client-0.8.0-1.el6.x86_64
qemu-kvm-0.12.1.2-2.149.el6.x86_64
Guest == win7x32 with ic104 guest tools

^ -- Connected trough UserPortal from RHEVM 2.3 (4.6.0.276)

^ -- spice-server-0.7.3-2.el6.x86_64

Same happens with rhel6 guest. Sticky alt is released right after ctrl is pressed.

I've been debugging this some more on my local F-14 installation. I've replaced my qemu and spice-server packages with those from RHEL-6.1 but I still cannot reproduce this using a local vm. Next I tried both with and without an agent, no success again.

So either this is something on the host (I can reproduce by connecting to
rhevm23.spice.lab...) outside of qemu + spice-server, or more likely IMHO, this is something in the way how RHEV-M invokes qemu / sets up the connection (ssl versus plain ?) between spice-server and spice-client.

lkocman, can you please try to reproduce this using a locally hosted vm rather then by connecting to rhev-m? It might be a good idea to try and mimick the rhev-m qemu invokation as much as possible.

I'll go debug the client against rhevm23.spice.lab... tomorrow.

Works for me on a RHEL-6 host with (modified/development) spice-server and qemu-kvm and with RHEL-6.1 guest and win764 (not sure about tools), not using rhev-m.

spice-server-0.8.0-1.el6.x86_64 -- modified (probably unrelated changes)
qemu-kvm-0.12.1.2-2.149.el6 -- modified (probably unrelated changes)
spice-client-0.7.3-1.el6.x86_64

As hansg said it seems to be spice-server or qemu specific:

so are you able to reproduce it with spice-server-0.7.3-2.el6.x86_64 and qemu-kvm-0.12.1.2-2.149.el6.x86_64?

Ok, so after a day of trying with various versions to reproduce this, I can only reproduce it when RHEV-M is involved, further debugging has shown that the cause is that RHEV-M now sets the spicec hotkeys (through the XPI) to be ctrl+alt for
release cursor (and no other hotkeys for ie fullscreen). This is also the cause of bug 683823. But unlike with 683823 in this case we can do something, as we can at least make sure that sending ctrl + alt + other-key still works using sticky-alt.

I've a patch for this:
http://cgit.freedesktop.org/spice/spice/commit/?id=9d204f8b74c8fbcc6a508f956e9c483e98ce653d

Devel-acking.

New version with the patch fixing this in build, moving to modified.

    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.

    New Contents:
When a spice-client hotkey was set to Ctrl+Alt, users were unable to send, using Sticky-Alt, a Ctrl+Alt+key key sequence to a guest. That prevented various functionality such as switching focus to the console or setting keyboard shortcuts. This bug has been fixed and users can send the client a key sequence with Ctrl and Alt keys using Sticky-Alt even if a spice-client hotkey is set to Ctrl+Alt.

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0583.html

Daniel Kulesz (kuleszdl) wrote :

I was not able to reproduce this bug using virt-manager 0.9 under Ubuntu 11.10 connected to a remote KVM-host running a Windows XP Guest.

Changed in virt-manager:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.