package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #583279 reported by Ramesh Kumar on 2010-05-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gconf

My GUI Stops working, after starting the Machine it drops me on CLI login after CLi login i have to run "startx" to get the GUI.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: gconf2 2.28.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Thu May 20 16:23:00 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 1
SourcePackage: gconf
Title: package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Ramesh Kumar (ramesh-mimit) wrote :
Ramesh Kumar (ramesh-mimit) wrote :
Download full text (26.4 KiB)

Below are the errors that i got while upgrading:

#############
Setting up gconf2 (2.28.1-0ubuntu1) ...
/usr/share/gconf/schemas/virt-manager.schemas:1: parser error : Document is empty

^
/usr/share/gconf/schemas/virt-manager.schemas:1: parser error : Start tag expected, '<' not found

^
WARNING: Failed to parse default value `[????????? ???????;gnome-appearance-properties.desktop,????????? ???????????? ???????????;gnome-default-applications.desktop,?????????? ??????????;system-config-printer.desktop] ' for schema (/schemas/apps/control-center/cc_actions_list)
dpkg: error processing gconf2 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libgnomevfs2-common:
 libgnomevfs2-common depends on gconf2 (>= 2.12.1-1); however:
  Package gconf2 is not configured yet.
dpkg: error processing libgnomevfs2-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomevfs2-0:
 libgnomevfs2-0 depends on libgnomevfs2-common (>= 1:2.24); however:
  Package libgnomevfs2-common is not configured yet.
 libgnomevfs2-0 depends on libgnomevfs2-common (<< 1:2.25); however:
  Package libgnomevfs2-common is not configured yet.
dpkg: error processing libgnomevfs2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome2-common:
 libgnome2-common depends on gconf2 (>= 2.12.1-1); however:
  Package gconf2 is not configured yet.
dpkg: error processing libgnome2No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                                 No apport report written because MaxReports is reached already
                                                                                                                               No apport report written because MaxReports is reached already
          No apport report written because MaxReports is reached already
                                                                        No apport report written because MaxReports is reached already
                                                                                                                                      No apport report written because MaxReports is reached already
                 No apport report written because MaxReports is reached already
                                                                               No apport report written because MaxReports is reached already
                                                                                                                                             No apport report written because MaxReports is reached already
                        No apport report written because MaxReports is reached already
                                     ...

Sebastien Bacher (seb128) wrote :

seems /usr/share/gconf/schemas/virt-manager.schemas is corrupted, could you try to reinstall virt-manager?

I have tried, but no gain. I have even removed it... but still the condition
remains the same. /usr/share/gconf/schemas/virt-manager.schemas this file is
empty..

-Ramesh

On Thu, May 20, 2010 at 5:41 PM, Sebastien Bacher <email address hidden> wrote:

> seems /usr/share/gconf/schemas/virt-manager.schemas is corrupted, could
> you try to reinstall virt-manager?
>
> --
> package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
> https://bugs.launchpad.net/bugs/583279
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gconf” package in Ubuntu: New
>
> Bug description:
> Binary package hint: gconf
>
> My GUI Stops working, after starting the Machine it drops me on CLI login
> after CLi login i have to run "startx" to get the GUI.
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.04
> Package: gconf2 2.28.1-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-21-generic i686
> Architecture: i386
> Date: Thu May 20 16:23:00 2010
> ErrorMessage: subprocess installed post-installation script returned error
> exit status 1
> SourcePackage: gconf
> Title: package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gconf/+bug/583279/+subscribe
>

--
Thanks & Regards
Ramesh Kumar
http://linuxtrove.com

Sebastien Bacher (seb128) wrote :

the issue is a local corruption not a gconf bug

Changed in gconf (Ubuntu):
importance: Undecided → Low
status: New → Invalid
philinux (philcb) wrote :

cat: /usr/share/gconf/schemas/virt-manager.schemas: No such file or directory

philinux (philcb) wrote :

Dang hit the enter key to quick.

 apt-cache policy virt-manager
virt-manager:
  Installed: (none)
  Candidate: 0.8.2-2ubuntu8
  Version table:
     0.8.2-2ubuntu8 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main Packages

Ramesh Kumar (ramesh-mimit) wrote :

If u have the virt-manager package installed, then remove it with --purge
option then reinstall it apt-get install virt-manager. I have done this, and
it resolved most of my problems. But still facing lots of issues like my
Dell-Latitude-E5500 Laptop does not shutdown properly after upgrade, it just
hags on "rc init process killed with PID --- " something like that..

-Ramesh

On Thu, May 20, 2010 at 10:25 PM, philinux <email address hidden> wrote:

> Dang hit the enter key to quick.
>
> apt-cache policy virt-manager
> virt-manager:
> Installed: (none)
> Candidate: 0.8.2-2ubuntu8
> Version table:
> 0.8.2-2ubuntu8 0
> 500 http://archive.ubuntu.com/ubuntu/ maverick/main Packages
>
> --
> package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
> https://bugs.launchpad.net/bugs/583279
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gconf” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: gconf
>
> My GUI Stops working, after starting the Machine it drops me on CLI login
> after CLi login i have to run "startx" to get the GUI.
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.04
> Package: gconf2 2.28.1-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-21-generic i686
> Architecture: i386
> Date: Thu May 20 16:23:00 2010
> ErrorMessage: subprocess installed post-installation script returned error
> exit status 1
> SourcePackage: gconf
> Title: package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gconf/+bug/583279/+subscribe
>

--
Thanks & Regards
Ramesh Kumar
http://linuxtrove.com

philinux (philcb) wrote :

Virt-manager not installed by default.

Ramesh Kumar (ramesh-mimit) wrote :

Yes, its not installed by default, i was using it for virtualization..

-Ramesh

On Thu, May 20, 2010 at 11:21 PM, philinux <email address hidden> wrote:

> Virt-manager not installed by default.
>
> --
> package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
> https://bugs.launchpad.net/bugs/583279
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gconf” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: gconf
>
> My GUI Stops working, after starting the Machine it drops me on CLI login
> after CLi login i have to run "startx" to get the GUI.
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.04
> Package: gconf2 2.28.1-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-21-generic i686
> Architecture: i386
> Date: Thu May 20 16:23:00 2010
> ErrorMessage: subprocess installed post-installation script returned error
> exit status 1
> SourcePackage: gconf
> Title: package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gconf/+bug/583279/+subscribe
>

--
Thanks & Regards
Ramesh Kumar
http://linuxtrove.com

Loïc Minier (lool) on 2010-05-22
affects: gconf (Ubuntu) → virt-manager (Ubuntu)
Dave Gilbert (ubuntu-treblig) wrote :

is this a post-crash package corruption problem? Certainly /usr/share/gconf/schemas/virt-manager.schemas is here for
me (as part of virt-manager) - if it's missing or corrupt on your machine is it just a case of your machine crashed before it hit
the disk after instlaling it (given that your message started originalyl talking about X issues).

Dave

Ramesh Kumar (ramesh-mimit) wrote :

I solved it by re-installing virt-manager.

- Ramesh

On Sat, May 22, 2010 at 8:55 PM, Dave Gilbert <email address hidden> wrote:

> is this a post-crash package corruption problem? Certainly
> /usr/share/gconf/schemas/virt-manager.schemas is here for
> me (as part of virt-manager) - if it's missing or corrupt on your machine
> is it just a case of your machine crashed before it hit
> the disk after instlaling it (given that your message started originalyl
> talking about X issues).
>
> Dave
>
> --
> package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
> https://bugs.launchpad.net/bugs/583279
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “virt-manager” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: gconf
>
> My GUI Stops working, after starting the Machine it drops me on CLI login
> after CLi login i have to run "startx" to get the GUI.
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.04
> Package: gconf2 2.28.1-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-21-generic i686
> Architecture: i386
> Date: Thu May 20 16:23:00 2010
> ErrorMessage: subprocess installed post-installation script returned error
> exit status 1
> SourcePackage: gconf
> Title: package gconf2 2.28.1-0ubuntu1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/virt-manager/+bug/583279/+subscribe
>

--
Thanks & Regards
Ramesh Kumar
http://linuxtrove.com

Loïc Minier (lool) wrote :

I'm not sure that's the issue, but it seems the virt-manager package doesn't register its gconf schema because it doesn't call dh_gconf.

The packaging has other oddities such as including both the autotools and the python-distutils CDBS classes.

I pushed a lucid package to my ppa, and another one to maverick.

Please tell me if the package fixes the issue.

https://launchpad.net/~lool/+archive/ppa

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 0.8.2-2ubuntu9

---------------
virt-manager (0.8.2-2ubuntu9) maverick; urgency=low

  * Don't include python-distutils class, I don't think it's reasonnable to
    include multiple CDBS classes and this package has no setup.py anyway;
    instead, add a binary-install/virt-manager:: target and call dh_pysupport
    manually.
  * Include gnome class instead of autotools class; this will call dh_gconf
    and properly register/unregister the schemas, hopefully fixes LP: #583279.
  * Include gnome class after the other includes, it used to make a
    significant different, but probably doesn't make one anymore nowadays.
 -- Loic Minier <email address hidden> Sat, 22 May 2010 17:29:28 +0200

Changed in virt-manager (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers