virt-manager won't run because of wrong version of python-virtinst

Bug #576394 reported by Tom Wood on 2010-05-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: virt-manager

Starting virt-manager from command line generates the attached popup window containing the error information.

Ubuntu Lucid x86_64 fully updated as of the time of this bug report. Note that this is an upgrade installation from 8.04 LTS.

virt-manager 0.8.2-2ubuntu8
python-virtinst 0.500.1-2ubuntu6

Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting this issue.

Do you have the "virtinst" package installed? (dpkg -l virtinst)

Tom Wood (woodts) wrote :

virtinst is installed and is version 0.500.1-2ubuntu6 .

Marc Deslauriers (mdeslaur) wrote :

Could you please paste the result of ls -l /usr/share/virt-manager/virt-manager*

Marc Deslauriers (mdeslaur) wrote :

What's the contents of your /usr/share/pyshared/virtinst/version.py file?

Tom Wood (woodts) wrote :

__version__ = "0.500.1"

I had the same problem. The crux was that there was obviously and old version of virtinst still half-installed after the upgrade from hardy. The file /usr/lib/python2.6/dist-packages/virtinst-0.300.2.egg-info for example was present on my system. I solved the problem as follows:

# Will remove ubuntu-virt-mgmt and virt-manager as well
sudo aptitude purge virtinst
sudo rm /usr/lib/python2.6/dist-packages/virtinst-0.300.2.egg-info
sudo rm -Rf /usr/lib/python2.4/dist-packages/virtinst*
sudo rm -Rf /usr/lib/python2.5/dist-packages/virtinst*
sudo rm -Rf /usr/lib/python2.6/dist-packages/virtinst*
# Will re-install virt-manager as well
sudo aptitude install ubuntu-virt-mgmt

Seems to be a bug in python-support.

Ralf Heiringhoff (frosty-geek) wrote :
Download full text (4.5 KiB)

Cheers Florian, this solved my Problems aswell. I also had leftover after upgrading from Hardy to Lucid:

---------------cut-----------------------
ralf@ishtar:~$ sudo aptitude purge ubuntu-virt-mgmt virt-manager virtinst python-virtinst
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
The following packages will be REMOVED:
  acl{u} python-gtk-vnc{u} python-urlgrabber{u} python-virtinst{p} virt-manager{p} virtinst{p}
0 packages upgraded, 0 newly installed, 6 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 7.795kB will be freed.
Do you want to continue? [Y/n/?]
Writing extended state information... Done
(Reading database ... 227806 files and directories currently installed.)
Removing virt-manager ...
Purging configuration files for virt-manager ...
Removing python-virtinst ...
Removing virtinst ...
Processing triggers for man-db ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.C.cache...
Processing triggers for desktop-file-utils ...
Processing triggers for python-support ...
(Reading database ... 227609 files and directories currently installed.)
Removing acl ...
Removing python-gtk-vnc ...
Removing python-urlgrabber ...
Processing triggers for man-db ...
Processing triggers for python-support ...
[ Rootkit Hunter version 1.3.6 ]
File updated: searched for 162 files, found 135
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

ralf@ishtar:~$ ls -al /usr/lib/python2.6/dist-packages/virtinst*
lrwxrwxrwx 1 root root 45 May 1 21:04 /usr/lib/python2.6/dist-packages/virtinst-0.300.2.egg-info -> /usr/share/pyshared/virtinst-0.300.2.egg-info

/usr/lib/python2.6/dist-packages/virtinst:
total 172
drwxr-xr-x 2 root root 4096 Jun 14 22:54 .
drwxr-xr-x 52 root root 4096 Jun 15 10:27 ..
lrwxrwxrwx 1 root root 50 May 1 21:04 CapabilitiesParser.py -> /usr/share/pyshared/virtinst/CapabilitiesParser.py
-rw-r--r-- 1 root root 7854 May 1 21:04 CapabilitiesParser.pyc
lrwxrwxrwx 1 root root 35 May 1 21:04 cli.py -> /usr/share/pyshared/virtinst/cli.py
-rw-r--r-- 1 root root 8134 May 1 21:04 cli.pyc
lrwxrwxrwx 1 root root 44 May 1 21:04 CloneManager.py -> /usr/share/pyshared/virtinst/CloneManager.py
-rw-r--r-- 1 root root 19219 May 1 21:04 CloneManager.pyc
lrwxrwxrwx 1 root root 45 May 1 21:04 DistroManager.py -> /usr/share/pyshared/virtinst/DistroManager.py
-rw-r--r-- 1 root root 9565 May 1 21:04 DistroManager.pyc
lrwxrwxrwx 1 root root 45 May 1 21:04 FullVirtGuest.py -> /usr/share/pyshared/virtinst/FullVirtGuest.py
-rw-r--r-- 1 root root 12537 May 1 21:04 FullVirtGuest.pyc
lrwxrwxrwx 1 root root 37 May 1 21:04 Guest.py -> /usr/share/pyshared/virtinst/Guest.py
-rw-r--r-- 1 root root 35869 May 1 21:04 Guest.pyc
lrwxrwxrwx 1 root root 44 May 1 21:04 ImageFetcher.py -> /usr/share/pyshared/virtinst/ImageFet...

Read more...

Marc Deslauriers (mdeslaur) wrote :

Closing the bug as per the last comment. Thanks.

Changed in virt-manager (Ubuntu):
status: New → Invalid
Marc Deslauriers (mdeslaur) wrote :

Marking this as a dupe of bug 680627, which is still open, for reference reasons.

Changed in virt-manager (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers