libvirt/kvm relationships (suggest vs. recommend)

Bug #556312 reported by Neil Wilson on 2010-04-06
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libvirt
Invalid
Undecided
Unassigned
libvirt (Ubuntu)
Wishlist
Dustin Kirkland 
Lucid
Wishlist
Unassigned
qemu-kvm (Ubuntu)
Wishlist
Unassigned
Lucid
Wishlist
Unassigned
ubuntu-virt (Ubuntu)
Undecided
Dustin Kirkland 
Lucid
Undecided
Unassigned
virt-manager (Ubuntu)
Wishlist
Dustin Kirkland 
Lucid
Undecided
Unassigned

Bug Description

#215962 was shortsighted in its approach. Libvirt has a 'remote' and 'test' URI capability and could be installed on other virtual machines with a view to managing Hypervisors one step away - or for setting up test environments. At the moment the 'Recommends' on both lvm and qemu-kvm means that apt will try and install those packages on Virtual machines - causing breakages and failed daemon starts.

The Recommends on qemu-kvm and lvm should be downgraded to Suggests, or the packages should be broken out so that there is a libvirt for 'remote' and 'test' URI setups that can be installed on VMs, and one for 'physical' installations on machines that need a local hypervisor.

Additionally 'qemu-kvm' isn't required on physical machines using the Xen hypervisor.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: libvirt-bin (not installed)
ProcVersionSignature: Ubuntu 2.6.32-302.6-ec2
Uname: Linux 2.6.32-302-ec2 x86_64
Architecture: amd64
Date: Tue Apr 6 08:51:04 2010
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: libvirt

Neil Wilson (neil-aldur) wrote :

See also bug 556326

Mathias Gug (mathiaz) wrote :

According to the Debian policy:

Recommends

    This declares a strong, but not absolute, dependency.

    The Recommends field should list packages that would be found together with this one in all but unusual installations.

Suggests

    This is used to declare that one package may be more useful with one or more others. Using this field tells the packaging system and the user that the listed packages are related to this one and can perhaps enhance its usefulness, but that installing this one without them is perfectly reasonable.

It seems that Recommends is the best option for qemu-kvm.

Note that you can use the --no-install-recommends option with installing the libvirt package.

Changed in libvirt (Ubuntu):
importance: Undecided → Wishlist
status: New → Won't Fix

I disagree. It wouldn't be found in a Xen installation would it. And
if you want to use just remote URIs then ' installing this one without
them is perfectly reasonable'.

Would it not be more appropriate to split libvirt-bin into two
packages - one of which is core and can be used for remote URI,
testing and Xen installation and the other which is tied more closely
to your ubuntu KVM strategy.

There seems to be an increasing rigidity creeping into the Ubuntu mindset.

On 7 April 2010 02:24, Mathias Gug <email address hidden> wrote:
> According to the Debian policy:
>
> Recommends
>
>    This declares a strong, but not absolute, dependency.
>
>    The Recommends field should list packages that would be found
> together with this one in all but unusual installations.
>
> Suggests
>
>    This is used to declare that one package may be more useful with one
> or more others. Using this field tells the packaging system and the user
> that the listed packages are related to this one and can perhaps enhance
> its usefulness, but that installing this one without them is perfectly
> reasonable.
>
> It seems that Recommends is the best option for qemu-kvm.
>
> Note that you can use the --no-install-recommends option with installing
> the libvirt package.
>
> ** Changed in: libvirt (Ubuntu)
>   Importance: Undecided => Wishlist
>
> ** Changed in: libvirt (Ubuntu)
>       Status: New => Won't Fix
>
> --
> libvirt packages should not Recommend hypervisor packages
> https://bugs.launchpad.net/bugs/556312
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Neil Wilson

On Wed, Apr 07, 2010 at 07:00:35AM -0000, Neil Wilson wrote:
> I disagree. It wouldn't be found in a Xen installation would it. And
> if you want to use just remote URIs then ' installing this one without
> them is perfectly reasonable'.
>

I tend to follow the 80/20 rule. My guess is that 80% of the libvirt
installations use qemu-kvm. For the other 20% there is the solution to install
libvirt with the '--no-install-recommends' option.

Reopening the bug to get input from other developers.

  status confirmed

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Changed in libvirt (Ubuntu):
status: Won't Fix → Confirmed

Hmm, well, I agree with Mathias' logic.

And I do think we're following the Debian policy here for recommends
(most libvirt installs accompany a hypervisor).

But it does not have to be that way.

Personally, I'd be fine downgrading the hypervisors to suggests, if
there are no objections...

I hope that kvm (and friends) are either seeded or appropriately
depended upon by other packages. I can confirm that for UEC.

Changed in libvirt (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
status: Confirmed → In Progress

On Wed, Apr 07, 2010 at 02:16:43PM -0000, Mathias Gug wrote:
>> I disagree. It wouldn't be found in a Xen installation would it. And
>> if you want to use just remote URIs then ' installing this one
>> without them is perfectly reasonable'.
> I tend to follow the 80/20 rule. My guess is that 80% of the libvirt
> installations use qemu-kvm. For the other 20% there is the solution to
> install libvirt with the '--no-install-recommends' option.

Or "sudo apt-get install libvirt-bin qemu-kvm-".

Okay, discussed this further with Jamie in IRC...

 1) For Lucid, we're going to leave this as is (libvirt recommending kvm), as this is what our users and documentation have grown to expect up until this point at the release of our LTS
 2) For Maverick, we can/should drop this to a libvirt suggests kvm, and add a kvm recommends libvirt-bin
 3) For Maverick, we should also split out virsh to its own package, such that you can install it separately

Changed in libvirt (Ubuntu Lucid):
status: In Progress → Won't Fix
assignee: Dustin Kirkland (kirkland) → nobody
Changed in libvirt (Ubuntu):
status: In Progress → Triaged
assignee: Dustin Kirkland (kirkland) → nobody
Changed in qemu-kvm (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Wishlist
summary: - libvirt packages should not Recommend hypervisor packages
+ libvirt/kvm relationships (suggest vs. recommend)
Changed in qemu-kvm (Ubuntu Lucid):
status: Triaged → Won't Fix
Changed in qemu-kvm (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
Changed in libvirt (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
Changed in libvirt:
status: Unknown → New
Dustin Kirkland  (kirkland) wrote :

This is related to Bug #589888.

virt-manager currently recommends libvirt-bin, which itself recommends qemu-kvm. Thus, when you install virt-manager (even if you just want to manage remote machines), you get the whole hypervisor stack.

I think I agree with you -- that's wrong. I'm going to fix both of these bugs, lowering these to Suggests in Maverick.

There may be some documentation that needs updating, and perhaps a release note.

We have a couple of meta packages, ubuntu-virt-server and ubuntu-virt-mgmt that should be used instead, if someone wants to install the whole stack.

Changed in libvirt (Ubuntu):
status: Triaged → In Progress
Changed in qemu-kvm (Ubuntu):
status: Triaged → In Progress
Changed in virt-manager (Ubuntu Lucid):
status: New → Won't Fix
Changed in virt-manager (Ubuntu):
importance: Undecided → Wishlist
status: New → In Progress
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Okay, I don't see anything that needs changing in qemu-kvm itself. Looks like just virt-manager and libvirt need to be updated.

Changed in qemu-kvm (Ubuntu):
status: In Progress → Invalid
assignee: Dustin Kirkland (kirkland) → nobody
Changed in ubuntu-virt (Ubuntu Lucid):
status: New → Won't Fix
Changed in ubuntu-virt (Ubuntu):
status: New → In Progress
assignee: nobody → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-virt - 1.3

---------------
ubuntu-virt (1.3) maverick; urgency=low

  * debian/control: add an ubuntu-virt meta package, which depends on
    both ubuntu-virt-server and ubuntu-virt-mgmt; "ubuntu-virt" is the
    recommended virtualization stack for Ubuntu; LP: #556312
  * debian/control, debian/rules: migrate to simpler dh7
 -- Dustin Kirkland <email address hidden> Fri, 04 Jun 2010 21:18:13 -0500

Changed in ubuntu-virt (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvirt - 0.7.5-5ubuntu28

---------------
libvirt (0.7.5-5ubuntu28) maverick; urgency=low

  * debian/control: lower qemu-kvm and lvm2 from Recommends to Suggests,
    LP: #556312; it's reasonable to install libvirt on systems that
    host xen and qemu VMs; see meta packages (ubuntu-virt, ubuntu-virt-server,
    ubuntu-virt-mgmt) for group installation of virt pacakge sets
 -- Dustin Kirkland <email address hidden> Fri, 04 Jun 2010 19:09:36 -0500

Changed in libvirt (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virt-manager - 0.8.4-3ubuntu2

---------------
virt-manager (0.8.4-3ubuntu2) maverick; urgency=low

  * debian/control: lower libvirt-bin from Recommends to Suggests,
    LP: #556312; seems some users (like netbooks) want to manage VMs, but
    not host them; see meta packages (ubuntu-virt, ubuntu-virt-server,
    ubuntu-virt-mgmt) for group installation of virt pacakge sets
 -- Dustin Kirkland <email address hidden> Fri, 04 Jun 2010 18:58:48 -0500

Changed in virt-manager (Ubuntu):
status: In Progress → Fix Released
lunarok (lunarok) wrote :

Yep I have check and that's good like that, don't bring the virtualisation platform
Just need wait the virtinst to be update for install (dependcy is break)

lunarok (lunarok) wrote :

The version avalaible in Meverick is : 0.500.1-2ubuntu6
But virt-manager is asking >=0.500.3

So cannot install virt-manager (and of course all meta packages having virt-manager in it, like ubuntu-virt)

Dustin Kirkland  (kirkland) wrote :

Ah, yes. We'll need to wait for virtinst to be merged. Should happen
soon. I can take a look today.

lunarok (lunarok) wrote :

Ok so I wait the merge.
Now as I can use kvm at home, I will be using the virt architecture on Maverick (always have been using the "in progress" version) so if there is other issue I will say it.

Thanks for your time.

Neil Wilson (neil-aldur) on 2012-03-31
Changed in libvirt:
importance: Unknown → Undecided
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.