virt-manager deletes active disk images

Bug #514394 reported by Barry Warsaw on 2010-01-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: virt-manager

I created a new virtual machine with a larger disk image and intended on mounting my old disk image to copy everything over. I brought up the new VM details window and clicked on Add Hardware. I went through this dialog to attempt to add the existing old disk image as a new hard drive. However, during this process it looked like virt-manager was going to try to reformat the disk, but then it said it could not create it because the path to the image already existed.

I canceled out of that and virt-manager deleted the old disk image file! Obviously this is a very serious bug because all the data on that disk image is now gone. :( I'm hoping I pushed all the branches I need to Launchpad.

Soren Hansen (soren) on 2010-01-31
Changed in virt-manager (Ubuntu):
importance: Undecided → High
Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting this issue. Is it still reproducible with the newer virt-manager in lucid?
Could you please give exact steps that I could follow to try and reproduce the issue?

Thanks.

Changed in virt-manager (Ubuntu):
status: New → Incomplete
assignee: nobody → Barry Warsaw (barry)
Barry Warsaw (barry) wrote :

Hi Marc, thanks. I will test this as soon as I upgrade my host to Lucid. Should be very soon (right? :).

Changed in virt-manager (Ubuntu):
assignee: Barry Warsaw (barry) → nobody
Barry Warsaw (barry) wrote :

I can confirm that this is fixed in Lucid's virt-manager.

Marc Deslauriers (mdeslaur) wrote :

Great! Closing this bug.

Changed in virt-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers