Unable to enter fullscreen if guest desktop size == host desktop size

Bug #512679 reported by Jens Gräf on 2010-01-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
virt-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: virt-manager

I have a dual screen setup using a nvidia graphics card.
KVM guest is Windows XP, Desktop resolution 1440x900, Ubuntu desktop resolution is 1440x900 each.
Trying to switch to fullscreen only removes the window decoration of the virt-manager window (see attachment)

Switching to a lower resolution in the guest (e.g. 1280x800) allows fullscreen to work. After entering fullscreen, I'm able to change the desktop size to 1440x900 again.

System info:
Ubuntu Karmic 9.10 64 bit. all updates installed
Nvidia propietary driver, gnome desktop

Jens Gräf (jgraef) wrote :

Note: Also happens on the same machine using only one screen (rebooted with second monitor disconnected)

Jens Gräf (jgraef) wrote :

1. Start virt-manager
2. Connect to localhost://system (qemu)
3. Double-Click the xp vm
4. Select virtual-machine -> run from the menu
5. Wait until vmware is started
6. Select view->fullscreen from the menu

If I select view->fullscreen while the vm is booting, it works fine as the vm is not yet at full desktop resulution (xp boots in 640 x 480 I think). But leaving and re-entering full screen (via view -> fullscreen) brings back the trouble again.

Another note: I use a wrapper script for kvm to enable widescreen-resolutions:

/usr/bin/kvm
#!/bin/bash
exec /usr/bin/kvm.orig $@ -vga std

Otherwise I wouldn't be able to drive 1440x900 as the default driver can't handle this resolution.

Dustin Kirkland  (kirkland) wrote :

Jens-

And what version of Ubuntu are you seeing this problem on?

Changed in virt-manager (Ubuntu):
importance: Undecided → Low
Jens Gräf (jgraef) wrote :

System info:
Ubuntu Karmic 64 bit

Jens Gräf (jgraef) wrote :

Yet another note: I disabled compiz (via system->appearance->visual effects).

If I enable it again by setting it to "normal" or "extra", switching to fullscreen works.
Setting it back to "none" breaks fullscreen toggling again.

Jens Gräf (jgraef) wrote :

I did some more testing and discovered a strange behaviour. The problem seems to be related to the "scale display" setting.
It is set to "only when fullscreen" by default.
If I set it to "never" before switching to fullscreen, the problem is stil there

If I set it to "always" before switching to fullscreen, fullscreen mode works.
Interestingly, if I leave fullscreen after entering it on setting "always", I can change "scale display" to "never" or "only when fullscreen" and switching to fullscreen works now, too. (Until the next time I start virt-manager).

It seems there's a state somewhere, either in virt-manager or in metacity which is only set when using the "always" mode.
I hope that helps.

So now at least I've got an easy workaround.

Dustin Kirkland  (kirkland) wrote :

I added a compiz task to this bug, and hopefully one of the compiz developers will be able to help triage and debug this, since you say you only see this issue with compiz running.

I always disable compiz, so that's probably why I don't see the issue.

Jens Gräf (jgraef) wrote :

Actually, it's the other way around. If I ENABLE compiz, fullscreen WORKS, else not.
It seems to be a gtk/metacity issue, where fullscreen doesn't get enabled when the window itself is larger than the root window.

Marc Deslauriers (mdeslaur) wrote :

Can you reproduce this issue with a more recent version of Ubuntu, such as 10.10?

Changed in virt-manager (Ubuntu):
status: New → Incomplete
Jens Gräf (jgraef) wrote :

In 10.10 (same computer setup) I can't reproduce this issue.

Marc Deslauriers (mdeslaur) wrote :

Ah, great. I assume it's something that has been fixed in later virt-manager releases. I'm marking this bug as Fix Released. Thanks!

Changed in virt-manager (Ubuntu):
status: Incomplete → Fix Released
Changed in compiz (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers