virt-manager does not honor other architectures when using qemu

Bug #453495 reported by Jamie Strandboge on 2009-10-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: virt-manager

Steps to reproduce:

1. start virt-manager, connect to localhost (System), click New
2. pick a name (eg, testme) and choose Network boot (PXE) as the install method, click Forward
3. Choose Generic/Generic and click Forward
4. RAM and CPUs are defaults, click Forward
5. Disk is default, but don't allocate all right now, click Forward
6. click Advanced, and choose qemu/arm (I also tried ppc and i686 (I have an x86_64 host)), click Finish

The guest starts, but:
$ virsh dumpxml testme |grep qemu
Connecting to uri: qemu:///system
<domain type='qemu' id='2'>
    <emulator>/usr/bin/qemu-system-x86_64</emulator>
$ ps auxww|grep qemu
root 16866 99.8 4.8 915300 194760 ? R 16:15 1:11 /usr/bin/qemu-system-x86_64 -S -M pc-0.11 -no-kvm -m 512 -smp 1 -name test17 -uuid d9621bd2-2012-462b-1ebc-ac55000cc21e -monitor unix:/var/run/libvirt/qemu/testme.monitor,server,nowait -no-reboot -boot n -drive file=/var/lib/libvirt/images/testme.img,if=ide,index=0 -net nic,macaddr=54:52:00:33:3c:20,vlan=0,name=nic.0 -net tap,fd=19,vlan=0,name=tap.0 -serial pty -parallel none -usb -vnc 127.0.0.1:1 -k en-us -vga cirrus -soundhw es1370

ProblemType: Bug
Architecture: amd64
Date: Fri Oct 16 16:10:30 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.04 "Jaunty Jackalope" - Release amd64 (20090420.1)
Package: virt-manager 0.7.0-3ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
SourcePackage: virt-manager
Uname: Linux 2.6.31-14-generic x86_64

Jamie Strandboge (jdstrand) wrote :
Jamie Strandboge (jdstrand) wrote :

I have the following qemu related packages installed:

$ dpkg -l | egrep '(qemu|kvm|bios)' | awk '{print $1, $2, $3}'
ii bochsbios 2.4.1-1ubuntu1
ii kqemu-common 1.4.0~pre1-1ubuntu3
ii kvm-pxe 5.4.3+dfsg-0.2ubuntu2
ii qemu-kvm 0.11.0-0ubuntu5
ii qemu-kvm-extras 0.11.0-0ubuntu5
ii vgabios 0.6c-1

summary: - virt-manager does not allow selecting other architectures when using
- qemu
+ virt-manager does not use other architectures when using qemu
summary: - virt-manager does not use other architectures when using qemu
+ virt-manager does not honor other architectures when using qemu
description: updated
Changed in virt-manager (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Thierry Carrez (ttx) on 2009-10-20
Changed in virt-manager (Ubuntu Karmic):
status: Confirmed → Won't Fix
Jamie Strandboge (jdstrand) wrote :

Looking at 'virsh capabilties', this seems to be a virt-manager gui bug because libvirt shows the other architectures as available.

Jamie Strandboge (jdstrand) wrote :

Here is the virsh capabilities output showing that all the qemu architectures are available in libvirt.

Jamie Strandboge (jdstrand) wrote :

Output of virsh dumpxml test453495

Jamie Strandboge (jdstrand) wrote :

Output of virsh dominfo test453495

Jamie Strandboge (jdstrand) wrote :

This is a regression over 9.04, though 9.04 has other bugs. However, when selecting 'qemu/mips':
$ virsh dumpxml test5 |grep qemu
Connecting to uri: qemu:///system
<domain type='qemu' id='7'>
    <emulator>/usr/bin/qemu-system-mipsel</emulator>

9.04 uses the wrong machine '-M' option for ppc and sparc, so they don't work at all. Eg:

$ sudo cat /var/log/libvirt/qemu/test5.log
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin HOME=/home/jamie USER=root LOGNAME=root /usr/bin/qemu-system-ppc -S -M g3bw -m 128 -smp 1 -name test5 -uuid e9502b63-7b2e-c6b9-d1ff-f0f6ac2a7cc7 -monitor pty -pidfile /var/run/libvirt/qemu//test5.pid -no-reboot -boot d -drive file=/var/lib/libvirt/images/test5.img,if=ide,index=0 -drive file=/home/jamie/mini.iso,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:64:3d:20,vlan=0 -net tap,fd=23,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -vnc 127.0.0.1:0 -k en-us -soundhw es1370
Supported machines are:
g3beige Heathrow based PowerMAC (default)
mac99 Mac99 based PowerMAC
prep PowerPC PREP platform
ref405ep ref405ep
taihu taihu
bamboo bamboo
mpc8544ds mpc8544ds
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin HOME=/home/jamie USER=root LOGNAME=root /usr/bin/qemu-system-sparc -S -M sun4m -m 128 -smp 1 -name test5 -uuid 9a8902a0-7789-804e-c514-eaad8c31b66f -monitor pty -pidfile /var/run/libvirt/qemu//test5.pid -no-reboot -boot d -drive file=/var/lib/libvirt/images/test5.img,if=ide,index=0 -drive file=/home/jamie/mini.iso,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:0a:85:c8,vlan=0 -net tap,fd=25,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -vnc 127.0.0.1:0 -k en-us -soundhw es1370
Supported machines are:
SS-5 Sun4m platform, SPARCstation 5 (default)
SS-10 Sun4m platform, SPARCstation 10
SS-600MP Sun4m platform, SPARCserver 600MP
SS-20 Sun4m platform, SPARCstation 20
SS-2 Sun4c platform, SPARCstation 2
Voyager Sun4m platform, SPARCstation Voyager
LX Sun4m platform, SPARCstation LX
SS-4 Sun4m platform, SPARCstation 4
SPARCClassic Sun4m platform, SPARCClassic
SPARCbook Sun4m platform, SPARCbook
SS-1000 Sun4d platform, SPARCserver 1000
SS-2000 Sun4d platform, SPARCcenter 2000

Marc Deslauriers (mdeslaur) wrote :

@jdstrand: This seems to be fixed with the virt-manager version in Lucid. Are you still able to reproduce this?

Changed in virt-manager (Ubuntu):
status: Confirmed → Incomplete
Jamie Strandboge (jdstrand) wrote :

This does not appear to be fixed, at least for mips:

$ virsh capabilities
...
  <guest>
    <os_type>hvm</os_type>
    <arch name='mips'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/qemu-system-mips</emulator>
      <machine>malta</machine>
      <machine>mipssim</machine>
      <machine>magnum</machine>
      <machine>pica61</machine>
      <machine>mips</machine>
      <domain type='qemu'>
      </domain>
    </arch>
  </guest>
...

$ ps auxww|grep qemu
root 14157 9.0 0.4 549980 17084 ? S 07:43 0:00 /usr/bin/qemu-system-x86_64 -S -M pc-0.12 -no-kvm -m 256 -smp 1 -name test453495 -uuid 263c27b0-26be-aa22-463b-fe94e7b2c4c2 -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/test453495.monitor,server,nowait -monitor chardev:monitor -no-reboot -boot n -drive file=/var/lib/libvirt/images/test453495-1.img,if=ide,index=0,format=raw -net nic,macaddr=52:54:00:40:44:6b,vlan=0,name=nic.0 -net tap,fd=42,vlan=0,name=tap.0 -chardev pty,id=serial0 -serial chardev:serial0 -parallel none -usb -vnc 127.0.0.1:1 -k en-us -vga cirrus -soundhw es1370

I tried arm, but it used '-soundhw es1370' which traced back with an error about es1370 being unknown hardware.

I tried powerpc, but ran into bug #541524 (ie, no available bios).

Changed in virt-manager (Ubuntu):
status: Incomplete → Confirmed
Jamie Strandboge (jdstrand) wrote :

Actually, I was mistaken. When I tried mips I had too much RAM, so I used Back to adjust it and when I went Forward it changed the arch and emulator to the defaults without me knowing. After accounting for this, virt-manager creates the proper xml (though due to bug #541524 the machine won't start).

Changed in virt-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers