virt-manager.py crashed with SIGSEGV in cell_view_is_sensitive()

Bug #392237 reported by Frits Letteboer on 2009-06-25
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: virt-manager

I was creating a new VM and when selecting the OS Type virt-manager froze and eventually crashed.

ProblemType: Crash
Architecture: amd64
Date: Thu Jun 25 20:15:32 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/share/virt-manager/virt-manager.py
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: virt-manager 0.7.0-3ubuntu1
ProcCmdline: python /usr/share/virt-manager/virt-manager.py
ProcEnviron:
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-10.12-generic
SegvAnalysis:
 Segfault happened at: 0x7f82eaebde59 <cell_view_is_sensitive+57>: mov (%rbx),%rdi
 PC (0x7f82eaebde59) ok
 source "(%rbx)" (0xffffffffd80a9600) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: virt-manager
StacktraceTop:
 cell_view_is_sensitive (cell_view=<value optimized out>)
 update_menu_sensitivity (combo_box=0x3589860,
 gtk_combo_box_menu_popup (combo_box=0x7f82d80a9600,
 gtk_combo_box_menu_button_press (
 _gtk_marshal_BOOLEAN__BOXED (closure=0x3a1ae80,
Title: virt-manager.py crashed with SIGSEGV in cell_view_is_sensitive()
Uname: Linux 2.6.30-10-generic x86_64
UserGroups: adm admin audio cdrom dialout disk libvirtd lpadmin plugdev sambashare vboxusers

Frits Letteboer (f-letteboer) wrote :
visibility: private → public

StacktraceTop:cell_view_is_sensitive (cell_view=<value optimized out>)
update_menu_sensitivity (combo_box=0x3589860,
gtk_combo_box_menu_popup (combo_box=0x7f82d80a9600,
gtk_combo_box_menu_button_press (
_gtk_marshal_BOOLEAN__BOXED (closure=0x3a1ae80,

Changed in virt-manager (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Someone561 (someone561) wrote :

This maybe a duplicate of #391398

Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting this issue. This should be fixed in the Karmic release.

If you still get this issue, please feel free to reopen this bug with detailed steps on how to reproduce.

Changed in virt-manager (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers